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本书主要对 PSpice 的各个仿真功能进行非常详细的讲解， 并且对仿

真模型的建立与使用进行细致的分析与介绍， 最后结合实际电路和习题，
对仿真功能和模型建立进行练习和巩固。

首先， 对 PSpice 软件的基本仿真功能进行具体讲解， 包括直流静态

工作点分析、 直流分析、 交流分析、 瞬态分析、 参数分析、 傅里叶分析、
温度分析、 蒙特卡洛分析、 噪声分析、 最坏情况分析和高性能分析， 并且

结合实例进行实际操作和验证。 然后对模型的建立与使用进行讲解， 包括

元件模型建立、 激励源编辑与使用、 变压器和磁性元件模型的建立与使

用、 行为模型及传输线模型的编辑与使用。 最后对数字电路、 数 -模混合

电路和层电路的仿真进行了详细的讲解， 尤其对数字电路仿真结果的表达

及层电路的使用， 尤为具体和实用。
本书适合热衷于利用 Cadence / OrCAD 专业仿真软件对电子电路进行

设计与分析的学生或者工程师。 本书提供了软件操作的使用方法， 并且在

每章结尾通过练习对仿真步骤逐步分解， 直至仿真完成。



译　 者　 序

工欲善其事， 必先利其器。 在当今电子电路飞速发展的时代， 使用哪种软件

及如何使用软件对电路进行详尽、 系统的分析显得尤为重要。
本书主要对电路行业的标志性软件 PSpice 的仿真功能、 器件模型和电路仿

真及层电路设计进行了详细的讲解， 另外， 对电路仿真过程中出现的不收敛问题

和错误信息也进行了介绍。 每一章节均结合实际电路和习题对仿真功能和模型建

立进行练习和巩固， 并且译者已对本书每个章节的电路程序仿真验证， 读者可以

通过机械工业出版社官方网站上本书的相关页面进行下载学习。
仿真功能包括直流工作点分析、 直流扫描分析、 交流分析、 瞬态分析、 参数

扫描分析、 蒙特卡洛分析、 最坏情况分析、 高性能分析、 噪声分析和温度分析，
功能讲解与电路实例仿真操作相结合。

器件模型包括变压器模型、 行为模型、 传输线模型的功能设置与仿真应用，
以及激励源和磁性器件的编辑和设置， 并且对如何添加和建立 PSpice 模型进行

了系统的讲解。
电路仿真包括数字电路、 数 -模混合电路和层电路的详细设置与仿真分析，

对数字电路仿真结果的表达及层电路的使用讲解尤为具体和实用。
本书在内容的安排上采用功能讲解与电路实例相结合的方法， 将 PSpice 的

强大电路仿真功能融入到电路分析与设计中， 既适合初学者对仿真与电路基本功

的学习， 又适合工程师对复杂系统的功能仿真及高性能分析。
PSpice 仿 真 群 （ 336965207 ） 的 如 下 仿 友： 陈 明、 曹 珂 杰、 杜 建 兴、

黄维笑、 李少兵、 刘亚辉、 刘礼刚、 潘如政、 王晓志、 于刚、 张东东、 张远征、
赵东生、 张岳海、 张志新等对本书的文字翻译和仿真程序校对付出了辛勤的汗

水， 在此表示最衷心的感谢。 欢迎广大读者加入我们的仿真群， 与仿客们进行交

流和互动。
限于译者才疏学浅， 加之时间仓促， 难免出现翻译欠妥之处， 恳请读者批评

指正， 在此表示诚挚感谢。

张东辉

2016 年 7 月



原 书 前 言

Cadence / OrCAD 软件为电子设计自动化 （EDA） 家族成员之一， 该软件提

供原理图输入、 电路仿真、 PCB 制版等完整的设计流程。 首先利用 Capture 或者

Capture CIS 中的原理图编辑器绘制电路图， 然后利用 PSpice 对电路进行仿真，
最后利用 Cadence Allegro 或者 PCB Editor 将电路原理图转化为印制电路板， 其

中， PCB Editor 已取代 OrCAD Layout 功能。 本书所有电路均使用最新的 16. 6 版

本进行仿真， 同样， 也可以使用老版本或者最新的演示版 OrCAD PCB Designer
Lite DVD （Capture&PSpice only） 进行仿真。 可以通过 Cadence 官方网址下载演

示版软件：
http： / / www. cadence. com / products / orcad / pages / downloads. aspx
本书适合热衷于利用 Cadence / OrCAD 专业仿真软件对电子电路进行设计与

分析的学生或者工程师。 本书提供了软件操作的使用方法， 并且在每章结尾通过

练习对仿真步骤逐步分解， 直至仿真完成。
感谢西伦敦大学的技术人员 Keith Pamment 和 Seth Thomas 对仿真练习的校

对； 感谢 Cadence 公司的 Taranjit Kukal 和 Alok Tripath 对 PSpice 仿真技术的审查；
感谢 Parallel - Systems UK 公司对本书出版工作的支持。



使 用 说 明

在本书中， 黑体字代表指定工具栏按钮操作的关键字， 也表示所选菜单， 例

如， 建立新项目菜单选项如下：

上述指令操作顺序为 File > New > Project。 如上图所示， 利用黑体字母可以

从顶部工具栏对菜单进行连续选择。
本书规定单击鼠标右键缩写为 rmb。 例如在原理图中选定某元件， 然后选

择 rmb > rotate， 即单击右键， 选择旋转功能。
黑体字同样用来命名对话框和对话窗口， 例如下面的 Create PSpice Project

建立新项目窗口。

OrCAD 演示版限制

OrCAD 演示版光盘， OrCAD 16. 6 精简版可以通过官方网站 www. Cadence. com
进行免费下载或者订购， 演示版只对仿真功能和原理图大小有限制， 对使用时间

没有限制。 本书中的大多数练习都可以通过演示版进行仿真。 然而， 从 16. 5 版

本开始， 演示版软件对仿真元件的数量也进行了改变， 有所增加。
16. 5 以前版本

进行 PSpice 电路仿真时， 软件限制如下： 64 个网络节点、 20 个晶体管、 2
个子电路或者 65 个数字元件、 10 条传输线 （理想或者非理想）、 4 对耦合线，
并且 Tlines 的最大限制数量为 4。

运算放大器的内部支路节点数量计入总节点数。 所以通常选用演示版软件

eval 元件库中的 uA741 运算放大器 （简称运放）， 该运放有 19 个内部节点。 对

于数字电路， 网络节点的最大限制数量为 250。
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利用 Capture 可以对设计项目进行建立和查看， 但是不能对超过 60 个网络节

点或者 60 个元件的设计项目进行保存。 Capture CIS 演示版的数据库元件限制数

量为 10。 所建元件的引脚数量不能超过 14， 并且元件库最多只能保存 15 个

元件。
模型编辑器只能对二极管模型进行编辑， 并且模型导入向导只支持 2 个引脚

的元件和模型。 激励源编辑器只能编辑正弦波和数字时钟信号。
只能显示演示版软件建立的仿真数据。
磁性元件编辑器只能建立功率变压器模型。 另外， 磁性元件编辑器提供的模

型数据不能被编辑， 只能进行查看， 而且只包括单一磁心的模型数据。
16. 5 和 16. 6 版本

从 16. 5 版本开始， PSpice 仿真电路的网络节点数目增加至 75， 并且对子电

路数量没有限制。
激励源编辑器功能限制取消， 可以利用该功能建立激励信号源。
利用 Capture 可以创建和查看设计项目， 但无法保存网络节点超过 75 或者元

器件数量超过 60 的设计项目。
在 CIS 中进行原理图设计时元器件的限制数量为 1000。
建立元器件符号时引脚的限制数量为 100。
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第 1 章
入　 　 门

本章主要供经验很少或者没有经验的 Capture 初学者学习， 熟悉项目设置和

原理图绘制的读者可以跳过本章， 继续学习下面章节。 本章将对以下内容进行重

点讲解： 如何启动 Capture、 如何设置项目类型、 如何配置 PSpice 仿真库文件。
每章结尾都有练习题供读者对本章内容进行复习和巩固， 另外， 每章习题都

以前面章节为基础， 这样更有利于对本书的学习。

1. 1　 启动 Capture

Capture 和 Capture CIS 原理图编辑器用于 PSpice 仿真原理图的绘制。 CIS 选

项代表元器件信息系统， 允许用户从数据库而非元件库中选择和放置元件。 对于

本书内容， 无论用 Capture 或 Capture CIS 绘制电路图都适用。
如果您已经安装了 OrCAD 软件， 可以通过单击如下菜单启动 Capture 或 Cap⁃

ture CIS：
Start >Program Files >OrCAD xx. x >Capture

或者

Start >Program Files >OrCAD xx. x >Capture CIS

其中 xx. x 为软件版本号， 例如 10. 5、 11. 0、 15. 5、 15. 7、 16. 0、 16. 2、 16. 3、
16. 5 或者 16. 6。

例如：
Start >All Programs >Cadence >OrCAD 16. 6 Lite >OrCAD

Capture CIS Lite

Start >All Programs >Cadence >Release 16. 5 >Capture

如果您已经安装了 Cadence 软件， 所有相关工具均安装在 Allegro 平台下。
在这种情况下， 只有 Capture CIS 可用， 其启动路径为
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Start >Program Files >Allegro SPB xx. x >Design Entry CIS

1. 2　 创建一个仿真项目

在 Capture 中建立新设计时软件会自动创建一个项目文件 （. opj）， 该项目文

件将参考原理图、 库和输出报告文件。
绘制电路之前需要设置所建项目类型和配置库文件。 首先， 通过顶部工具栏

命令选择创建新项目：
File >New >Project

在 New Project 窗口 （见图 1. 1） 中， 输入项目名称， 并且从四种项目类型

中选择一种作为本项目的类型：
· Analog or Mixed A / D 用于 PSpice 仿真。
· PC Board Wizard 用于 PCB 项目中的原理图绘制。
· Programmable Logic Wizard 用于 CPLD 和 FPGA 设计。
· Schematic 用于原理图绘制。

图 1. 1　 创建新项目

当选定项目类型时， 将会出现 Tip for New Users 提示， 以便对项目类型进

行简要说明。 如果所建项目用于 PSpice 电路仿真， 那么选择 Analog or Mixed
A / D 作为项目类型， 这样就会激活 Capture 顶部工具栏的 PSpice 菜单。

进行电路仿真时， 建议为每个新项目建立一个文件夹。 通过单击图 1. 1 中的

Browse. . . 按钮弹出如图 1. 2 所示的 Select Directory 文件夹选择窗口。
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图 1. 2　 创建仿真项目文件夹地址

图 1. 3　 创建仿真项目文件夹

选择 Create Dir. . . 按钮将会弹出如图 1. 3 所示 Create Directory 创建文件

夹目录窗口， 用户通过该窗口对仿真文件夹进行命名。
比如创建文件名为 PSpice Exercises 的文件夹， 该名称将显示在 Select Direc⁃

tory 选择目录窗口中。 但是首先必须选定并且鼠标左键双击该文件夹， 然后该

文件夹才会如图 1. 4 所示展开。 单击 Select Directory 窗口中的 Create Dir. . . 按

钮可以创建下一级子目录或文件夹， 然后按照图 1. 3 所示对文件夹进行命名。
所建项目文件夹地址将出现在 New Project 新建项目窗口的地址对话框中

（见图 1. 1）。
创建项目文件夹的另一种方法是在图 1. 1 所示的 New Project 新建项目窗口

的地址栏中直接输入文件夹地址， Capture 会自动创建该文件夹。
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图 1. 4　 项目文件夹选择

　 　 注意：
经常会发生如下误操作： 创建了项目文件夹， 但是并没有选择该文件夹，

以至于所有的仿真文件并没有保存在所建文件夹目录下。 所以为确保所选文件

夹正确， 一定要在 Select Directory 选择目录窗口 （见图 1. 4） 中左键双击所创

建的文件夹， 以确保文件夹选择正确。

选择好文件夹之后， 接下来是 Create PSpice Project， 创建 PSpice 仿真项目

窗口， 用于创建 PSpice 仿真项目 （见图 1. 5）。

图 1. 5　 创建 PSpice 仿真项目

Capture - PSpice 已经预先配置好仿真文件库， 可以通过下拉菜单对所需库

进行选择。 最常用的新建仿真项目选项为 Simple. opj， 该项目已经配置好如下五

个默认库：
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Analog. olb
Breakout. olb
Source. olb
Sourcstm. olb
Special. olb
以上仿真文件库包含最常用的 PSpice 仿真元件， 是建立新项目的最佳选择。
另外， 可以在已有仿真项目基础上创建其升级版本， 即在版本 1 的基础上创

建新版本 2。 如图 1. 5 所示创建 PSpice 项目窗口， 选择 Create based upon an ex⁃
isting project， 然后单击 Browse 对已建项目进行选择。 当建立其新版本仿真项

目时， 旧版本仿真项目的所有文件均复制到新版本项目文件夹下， 类似于 File >
Save As 功能。

如果选择 Create a blank project 创建一个空白项目， 那么该项目下将没有

任何仿真库文件， 同样为空白库。 可以通过添加把仿真库文件加入到仿真项目

中， 本章结尾将对库文件的添加操作进行练习。
当新仿真项目创建成功后， Capture 会自动创建其 Project Manager 项目管理

器窗口 （见图 1. 6）， 该窗口列出了库文件的绝对路径。 一定要注意， 这些库为

仿真元件的外形符号库， 他们只定义元件的外部形状， 而不是 PSpice 仿真模型

库。 OrCAD 和 Cadence 软件均有其默认的库文件安装位置， 版本不同， 库文件安

装位置也会有所不同， 例如：

图 1. 6　 项目管理器窗口， 列出该项目元件库及其所在位置

<software install path > OrCad >OrCAD 10. 5 > tools > cap⁃
ture >library >PSpice
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或者

<software install path > Cadence >SPB 16. 3 > tools > cap⁃
ture >library >PSpice

通常情况下软件安装在驱动盘 C。

图 1. 7　 项目管理器窗口

　 　 提示：
如果 Project Manager 项目管理器窗口不能显示， 可以从顶部工具栏中选

择 Window > < project name > . opj 项目文件 （见图 1. 7） 对其进行显示， 如图

1. 7 所示的项目名称为 resistors。 进行仿真项目文件管理时一定要注意， 仿真项

目的文件扩展名 . opj。

另外， 可以通过单击项目管理器图标 或者 对仿真项目进行管理。

1. 3　 符号和元器件

1. 3. 1　 符号

绘制原理图之前， 能够清楚地分辨元器件和符号的区别是非常有用的。 符号

和元器件的区别在于： 符号不是通过 Place Part 菜单在原理图中进行放置。 他们

通过 Place 菜单 （见图 1. 8） 选择符号直接放置。
在 Place 菜单中分别显示每项功能对应的快捷键。 例如， 放置电源符号的

快捷键为 F， 当按下 F 键时， Place Power 放置电源菜单将会弹出， 如图 1. 9
所示。
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图 1. 8　 Place 菜单 图 1. 9　 放置电源菜单

当导线与符号相连接时， 导线的名字与符号名称一致。 例如， 需要定义导线

与 0V 电压相连接， 可以将 “0” 符号与导线相连。 通过把 VCC CIRCLE 符号

重命名为 + 5V 可以定义 + 5V 连接线。 所有与 + 5V 符号连接的导线的网络名都

为 + 5V。 网络名称和导线连接是一致的， 在 PSpice 中可以通过定义导线的网络

名称对导线进行连接。 可以使用多种不同的符号对电源和地进行定义， 并且根据

实际情况对其进行重新命名。
如图 1. 9 所示为 Place Power 放置电源菜单， 选定 VCC CIRCLE 符号并对

其重命名为 + 5V。 任何与 + 5V 连接的导线的网络名称均为 + 5V。
除了电源连接符号之外， 还包括层端口和端点连接符号， 通过它们可以把整

套设计连接在一起。 第 20 章将对以上连接符号进行详细的介绍。
PSpice 仿真软件中包括 source 和 capsym 两个符号库。 Capsym 库包含所有

模拟地和电源符号， 而 source 库也包含模拟 0V 符号， 另外， source 库还包括

D HI 数字高符号和 D LO 数字低符号， 它们分别用来设置导线或数字器件

的高低电平值。

1. 3. 2　 元器件

通过选择 Place > Part 菜单命令进行元器件放置。 图 1. 10a 为 16. 0 版本的

Place Part 放置元器件菜单格式， 图 1. 10b 为 16. 3 版本的 Place Part 放置元器件

菜单格式。
如图 1. 10b 所示， 所有元器件库都已选定， 从中我们可以清楚地看到元器件

的名称及其所属库。 当把光标放到某个元器件上面时， 软件会自动弹出矩形提示
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框， 以显示元器件所属库的绝对路径。

　 　 注意：
电池、 电压源和电流源属于 source 库， 通过 Place Part 放置元件菜单

（Place > Part） 进行放置， 使用时不要与 capsym 库 （Place > Power 或 Place >
Ground） 中的电源符号 （VCC circle， 0V 等） 混淆， capsym 库中的电源符号

只用于 ‘无形’ 的导线网络连接， 并无实际的电源特性。

如图 1. 11 所示为放置电源 Place Power 和地 Place Ground 窗口， 其中含有

source 库。 在 source 库只包含数字高 HI、 数字低 LO 和 0V 地符号。
总体来说， 各种网络连接符号通过 Place 菜单进行放置， 而实际元件通过

Place > Part 菜单进行放置。 另外， 元件库 Part 和符号库 Symbol 的扩展名均为

. olb， 为其图形显示， 用于软件绘图。

图 1. 10　 放置元器件菜单

a） 16. 0 版本　 b） 16. 3 版本
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图 1. 11　 用于放置电源的 source 库

1. 3. 3　 放置 PSpice 元器件

16. 6 版本增加了一个非常新颖的功能， 通过该功能可以快速放置通用的

PSpice 元器件， 而不用再查找半导体供应商的元器件号码。 如图 1. 12 所示， 通

过顶层工具栏的 Place 菜单放置元器件。 需要注意无源元件来自 analog 库， 但是

电位器却保存在 breakout 库中。

图 1. 12　 放置 PSpice 无源元件

按照如图 1. 13 所示可以选择 PSpice 分离器件， 该类器件来自 Breakout 库。
这些通用的半导体器件具有默认的名称和参数， 可以通过 PSpice Model Editor 对
其进行个性化设置， 但是演示版只能对二极管模型进行编辑。



10　　　 基于 OrCAD Capture 和 PSpice 的模拟电路设计与仿真

图 1. 13　 放置 PSpice 分离器件

　 　 注意：
如果知道实际的半导体器件型号， 最好从 PSpice 元器件库中对其进行查找

并使用。 对于初学电子学的新人来说， 如果只是想快速地进行电路图绘制并且

仿真， 通用元器件将非常实用。 对 Breakout 器件库中的半导体器件进行个性化

设置主要用于高级电路， 此时需要对半导体的特性参数进行配置。

　 　 提示：
正版软件和演示版软件中都包含 eval 元器件库， 该元器件库包括通用标准

的模拟和数字半导体器件。

图 1. 14 显示了如何选择可用的信号源元件。 电压源和电流源来自 source 元

件库， 而受控源来自 analog 元件库。
图 1. 15 显示了如何选择数字元件， 如果使用正版的 16. 6 版本， 门电路和触

发器电路保存在 dig prim 元件库中， ADC、 DAC 和寄存器等元器件保存在

Breakout 元器件库中。
编写本书的时候， OrCAD Lite 16. 6 版本中并不包括数字门级元件和触发器

元件。 在后续的版本中将会对其进行增加。 ADC、 DAC 和寄存器等元器件保存

在 Breakout 元器件库中。
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图 1. 14　 放置 PSpice 信号源元件

图 1. 15　 放置 PSpice 数字元件

　 　 注意：
如果使用的是 OrCAD Lite 16. 6 演示版， 切记不要使用门元件库和锁存器元

件库中的门级元件和触发器元件， 这些元件不包含 PSpice 模型， 不能进行

仿真。

1. 4　 设计模板

从 16. 3 版本开始， 设计模板的内容大大增加， 包括完整的电子电路和电路

拓扑的仿真文件， 主要类型有模拟电路、 数字电路、 模 - 数混合电路和开关电

源。 当创建新的仿真项目时， 可以通过图 1. 16 的 Create PSpice Project 创建

PSpice 仿真项目窗口中的下拉菜单进行设计模板选择。
如图 1. 17 所示为单开关正激变换器的设计模板， 其中包括原理图和文字

说明。
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图 1. 16　 可用的设计模板

图 1. 17　 单开关正激变换器设计模板
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1. 5　 本章总结

如图 1. 18 所示为 PSpice 项目管理器， 里面详细列出了项目中的各种文件及

仿真项目的检测结果， 以保证仿真项目设置正确。 一个常见的错误就是未选定所

创建文件夹， 以至于不能对其进行仿真设置。

图 1. 18　 PSpice 项目管理器设置

创建项目时另一个常见的错误就是项目类型选择错误， 例如， 项目管理器中

文件类型为 PCB 而不是 Analog or Mixed A / D。 解决此问题的方法如下： 创建一

个类型正确的新项目， 把原项目管理器中的 . dsn 文件复制到新的项目管理器中。
从 16. 3 版本开始可以通过如下操作修改项目类型： 选定项目管理器中的 Design
Resources， 然后通过单击右键 rmb > Change Project Type 进行项目类型修改，
具体操作步骤如图 1. 19 所示。

图 1. 19　 改变项目类型
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1. 5. 1　 已保存设计项目

在 16. 6 版本中， 未保存在设计项目中的电路图页现在使用星号 “∗” 进行

标识。 如图 1. 20 所示， 因为 RC 原理图中的 Page2 还未保存， 所以原理图 RC 文

件夹和设计文件 rc. dsn 均显示未保存。

图 1. 20　 未保存的电路图页以 “∗” 标识

1. 5. 2　 打开老版本 OrCAD 创建的设计项目

使用 16. 6 版本， 不用对设计项目进行更新就可以打开早期 OrCAD 版本创建

的设计项目。 如果对设计项目进行保存， 仅仅将其更新为 16. 6 版本。

1. 6　 本章练习

练习 1
按照第 1. 2 节步骤建立新 PSpice 项目， 命名为 resistors。 为仿真项目建立一

个文件夹， 例如 C： \ PSpice \ resistors， 并且给该项目配置 simple 模板 （包含五

个默认库）。
1. 选择菜单 File > New > Project 建立新项目。 在 name 栏中输入 resistors 作

为项目名称， 然后选择 Analog or Mixed A / D 作为项目类型。 最后在地址栏中输

入 C： \ PSpice exercises \ resistors 作为项目地址， 设计人员也可以根据需求自己

设定文件地址。 具体设置如图 1. 21 所示。
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图 1. 21　 建立名称为 resistors 的 PSpice 仿真项目

　 　 注意：
设计人员可以使用 Browse 浏览按钮建立和命名项目文件夹。

2. 如图 1. 22 所示为 Create PSpice Project 创建仿真项目窗口， 选择 sim⁃
ple. opj， 然后单击 OK 按钮进行确定。

图 1. 22　 选择 simple. opj 项目模板

3. 接下来将会出现如图 1. 23 所示的项目管理器窗口。
4. 通过双击 resistors. dsn 对其项目文件进行展开， 然后就能看到如图 1. 24

所示的 SCHEMATIC1 文件夹。
5. 双击 SCHEMATIC1 打开 PAGE1 文件夹， 然后双击 PAGE1 进入原理图页

面 （见图 1. 25）。
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图 1. 23　 项目管理器窗口

图 1. 24　 SCHEMATIC1 文件夹 图 1. 25　 Page1 文件夹

6. 第一次打开原理图页面时会看到预先放置好的文本文件和两个电压源。
通过方框选定文本文件和电压源， 然后按 Delete 键对其进行删除。

练习 2
绘制如图 1. 26 所示的电阻网络。

图 1. 26　 简单的电阻电路

1. 放置电阻步骤： 选择菜单 Place > Part， 然后从 analog. olb 库中选定 R 并

对其进行左键双击， 电阻将随光标移动到绘图页面。 在以前版本中， 可以通过单
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击 OK 按钮关闭放置元件窗口。 从版本 16. 0 开始， 当左键双击某元件或者单击

Place Part 放置元件时， 菜单将继续保持打开。 当第一个电阻放置到原理图

时； 另一个电阻将马上出现在光标处等待继续放置。 单击菜单 rmb > Rotate 或

者按下键盘上的 R 键对电阻进行旋转并且放置第二个电阻。 单击菜单 rmb > End
Mode 或者按下 Esc 键退出放置元件功能。 当选定某一元件时， 可以通过右键单

击菜单对其放置进行选择。 P 为放置元件的快捷键， 也可以通过放置元件图标对

元件进行放置， 不同软件版本的图标也不同， 例如 或者 。
2. 对于电阻 R1 和 R2， 双击其默认电阻值 1k， 然后修改为 10R。
3. 从 source 库中选择电压源， 并且放置到原理图中。 然后修改其电压值

为 10V。
4. 通过以下几种方式放置地符号： 选择菜单 Place > Ground （或者按 G

键）、 单击图标 或者 、 从 capsym. olb 库中选择 0V 符号 （见图 1. 27）。

图 1. 27　 放置 0V 地符号

5. 通过选择菜单 Place >Wire （或者单击图标 或 ， 或者按下快捷键

W） 进行导线绘制。 设计人员可以通过快捷键 “I” 和 “O” 对原理图分别进行

放大和缩小。

　 　 注意：
通过键盘上的 ESC 键可以退出导线绘制模式， 另外也可以通过 W 快捷键在

导线绘制和退出之间进行切换。 当操作失误时， 可以通过撤销图标 进行

恢复。
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图 1. 28　 导线和总线的自动连接

　 　 注意：
从 16. 3 版本开始， PSpice 软件可以实现两点和多点之间的自动连线， 并且

能够自动和总线进行连接， 该新功能将在第 18 章数字电路仿真中进行详细的介

绍。 通过菜单 Place > Auto Wire > Two Points （见图 1. 28） 或单击图标 可

以实现点点之间的自动连线。 左键单击第一个连接点， 然后继续单击第二连接

点， 两点就能实现自动连接。

6. Capture 能够实现导线节点的自动数字标识， 但是默认情况下原理图上

并不显示节点标识。 然而， 设计人员可以根据实际意义对导线节点进行人工标

识， 例如， 节点标识为 input 或者 output， 当对电路的不同节点进行分析时非

常实用。 这些标识也被称为网络名， 当对导线进行网络标识时首先选定需要标

识的导线， 然后通过菜单 Place > Net Alias （或者图标 、 或者快捷键

N） 进行标识。
7. 选择菜单 File > Save 对项目进行保存。

　 　 注意：
多个元件可以重叠地推在一起， 当把它们分开的时候， 各节点之间就会实

现自动连线。 如图 1. 29 所示， 在 Options > Preferences > Miscellaneous > Wire
Drag 窗口中选定 Allow component move with connectivity changes on， 当元件

移动到导线时就能实现元件节点和导线的自动连接。
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图 1. 29　 元件与导线自动连接设置

　 　

1. 7　 附加库文件练习

图 1. 30　 添加库文件

1. 选择 Place Part 放置元件

菜单， 将会打开放置元件窗口，

然后单击图标 进行库文件的添

加 （见图 1. 30）。 在以前的版本

中， 只能通过 Place Part 窗口中的

Add Library 按钮进行库文件的添

加 （见图 1. 10a）。
2. Browse File 浏览文件窗口

（见图 1. 31） 将会打开。 首先确定文件路径为 tools > capture > library > PSpice，
然后选择 ana swit. olb 元件库， 最后单击 Open 打开按钮把库文件添加到仿真
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项目中。

图 1. 31　 浏览库文件

3. 关闭 Place Part 放置元件窗口。 可以通过对库文件的展开， 确认所选库

文件是否成功添加到项目管理器中。

图 1. 32　 添加库文件至项目管理器

4. 如图 1. 32 所示， 在项目管理器

中选择 Library 库文件夹， 然后通过

rmb >Add File 对库文件进行添加。 和

步骤 2 一致， Browse File 浏览文件窗

口打开， 确定文件路径为 tools > cap⁃
ture > library > PSpice， 然后选择 1
shot. olb 元件库， 最后单击 Open 打开按钮把库文件添加到仿真项目中。

5. 打开 Place Part 放置元件窗口， 确认 1 shot. olb 库文件是否添加到项目

管理器中。
6. 在 Place Part 放置元件窗口中选定所有元件库， 然后单击 Remove Li⁃

brary 按钮对库进行删除。 这时可以确认一下哪些元件库仍然可用。
创建新项目时， 以前项目中添加的库文件同样在新项目中可以使用。 然而这

些库并没有添加到项目管理器中。 只有通过项目管理器添加的库文件才会添加到

项目管理器库文件夹中， 同样这些元件库也只能通过项目管理器进行删除。
从 16. 2 版本开始， 当选择 Place Part 放置元件时， 菜单将会出现在原理图

的右侧， 这样将会减小原理图的可用页面。 然而， 在 Place Part 放置元件窗口的

右上角有一个图钉图标 （见图 1. 33）， 通过选择该图标， 可以对 Place Part 菜单
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进行有效的隐藏。 如图 1. 34 所示， 当选择图钉图标时， Place Part 菜单将会消

失， 只留下字符 Place Part。 当鼠标放置在 Place Part 窗口时菜单会再次出现，
鼠标移开时菜单会继续隐藏， 非常实用。

图 1. 33　 隐藏 Place Part 放置元件菜单

图 1. 34　 Place Part 放置元件菜单合并



第 2 章
直流工作点分析

当电路与电池或者直流电源连接时， 电路中各节点的电压及流过元件的电流

都能计算出来， 该状态即为直流稳态状态， 也被称为稳态工作点或偏置点。 在

PSpice 中， 电路工作点仿真分析会计算电路中各节点的电压和流过各元件的电

流。 例如， 对简单的共射晶体管放大电路进行工作点分析时， PSpice 将会计算出

基极、 发射极、 集电极偏置电压和基极、 集电极、 发射极的静态电流。
进行工作点计算时， 电路中的每个电源、 元件和节点的初始值都进行考虑。

例如， 电容的初始电压值和数字器件引脚的初始状态逻辑 “1” 或 “0”。
电路中各工作点的电压和电流值会作为其他仿真分析的起始值， 以便对电路

更准确地分析。 例如， 对电路进行瞬态 （时域） 分析或者交流 （频域） 分析时，
PSpice 首先对电路进行工作点分析。 然而， 在某些特殊情况下， 电路的直流稳态

工作点无法找到时， 可以关闭工作点分析， 然后对电路继续进行其他功能的仿真

分析。 振荡器电路没有稳态工作点， 所以对其进行仿真分析， 关闭静态工作点计

算会非常实用。
当电路启用工作点计算时， 仿真输出文件中将包含以下数据： 模拟和数字节

点电压值、 电压源电流和功率值、 所有元件的小信号参数。 在 PSpice 仿真设置

中可以对工作点的输出信息进行取舍。

　 　 注意：
对电路进行工作点仿真计算时， 所有电容默认为开路， 所有电感默认为

短路。

图 2. 1 所示电路为 RC 电路， 该电路以第 1 章的电阻电路为基础， 但是增加

了与电阻 R2 并联的电容 C1。 首先绘制仿真电路图， 然后通过顶部工具栏

PSpice > New Simulation Profile 对电路进行仿真设置。 通过该工具栏可以对电路

进行直流分析、 交流分析、 瞬态分析和工作点分析设置， 通常情况下默认仿真类

型为工作点分析。
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图 2. 1　 进行直流工作点分析的 RC 电路

如图 2. 2 所示， 通常情况下电路的默认 PSpice 仿真类型为直流工作点分析。

本例采用默认仿真设置， 通过菜单 PSpice > Run 或选择图标 运行电路仿真。

图 2. 2　 工作点分析的仿真设置

　 　 注意：
在以前的版本中， 当运行仿真分析时， 会出现如图 2. 3 所示的 PSpice

Netlist Generation 生成 PSpice 网络表对话框。
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图 2. 3　 生成 PSpice 网络表对话框

图 2. 4　 撤销警告对话框

从 16. 3 版本开始， 当第一

次运行电路仿真时， 会出现如

图 2. 4 所示的 Undo Warning 撤

销警告对话框。 该对话框提示

设计人员将无法撤销或恢复以

前的 操 作。 只 需 选 中 Do not
show this box again （见图 2. 4）
不再显示此对话框， 然后单击

按钮 Yes 即可。

2. 1　 生成网络表

Capture 中的电路图以网络表的形式体现， 该网络表中包含所有元件信息及

元件与元件之间的连接关系。 当对电路进行仿真分析时， 程序会自动生成网络

表， 并把该网络表保存在项目管理器的 Outputs folder 输出文件中 （见图 2. 5）。

图 2. 5　 输出网络表 schematic1. net 的保存位置
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图 2. 6　 把 SCHEMATIC1 文件夹重命名为 RC

　 　 注意：
如图 2. 5 所示， 仿真电路图的默认名称为 SCHEMATIC1， 所以其网络表的

名称也为 schematic1. net。 对原理图重命名时， 首先选定 SCHEMATIC1， 然后

根据图 2. 6 所示选择 rmb >Rename， 把原理图重命名为 RC。

当运行电路仿真时， rc. net 网络表将会出现在输出文件夹中， 图 2. 7 所示为

原始的 schematic1. net 网络表和最新生成的 rc. net 网络表。 需要注意的是 Cap⁃
ture 不区分大小写， 任何以大写字母命名的原理图， 其网络表都将以小写字母命

名 （见图 2. 7）。

图 2. 7　 重命名 RC 原理图， 并且生成 rc. net 网络表

双击网络表名称， 网络表的内容就会呈现出来， 如图 2. 8 所示。
图 2. 8 所示为原理图的网络表， 电阻 R1 连接于节点 in 和节点 out 之间， 阻
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图 2. 8　 resistors. net 网络表内容

值为 10Ω， 温度系数为零 （TC = 0）。 V1 为电压源， 连接于节点 in 和 0V 之间，
幅值为 10V。 电阻的前缀 R 表示该网络表为同级网络表， 而不是层网络表。 电

阻特性和层电路将在第 20 章进行详细的介绍。 上述网络表详细定义了 R1、 R2
和 V1 之间的相互连接关系及各节点的网络名称。

当运行 PSpice 仿真分析时， PSpice 程序启动， 仿真分析环境窗口出现。 但

是， 当对电路进行直流工作点分析时， 因为没有波形数据， 所以不能进行图形绘

制。 然而， 可以通过 Output File 输出文件或者原理图查看计算结果， 包括各元

件的偏置电压、 电流和瞬时功率。 通过 Capture 或 PSpice 顶部工具栏中的 View >
Output File 菜单可以查看全部输出文件 （见图 2. 9）。 因为每个网络节点都已经

命名， 所以可以很容易地看到输出电压和电流值。 一定要注意， 当电路进行直流

工作点分析时， 电容默认为开路； 因此， RC 电路可实现简单的分压功能， 10V
直流电压由电阻 R1 和 R2 进行分压， 输出节点 out 的电压降到 5V。

图 2. 9　 工作点分析输出文件
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　 　 注意：
进行网络命名时， Capture 不区分大小写字母。

如图 2. 10 所示， 16. 3 版本具有一个新的功能， 即在输出文件中利用颜色对

不同的语法进行区分， 如文本、 元件值、 注释、 表达式和关键词。 如图 2. 10 所

示， 通过菜单选项 Options > Preferences > Text Editor 可以对默认颜色进行

更改。

图 2. 10　 文本编辑器的默认颜色和字体设置

输出文件对仿真电路中出现的错误和警告也进行了详细的标注， 尤其是进行

错误查询时， 这些标注就会显得更加实用。 本章结尾将对输出文件操作进行

练习。
如前所述， 仿真输出文件提供了一个非常详细的电路分析报告， 包括模拟和

数字节点电压、 流过元件的电流及小信号参数列表。 可以通过选项对工作点信息

报告进行输出设置。 在仿真设置窗口的 Category 中选择 Output file， 如图 2. 11 所

示， 并且取消 NOBIAS 选项。 选定 LIST 选项， 输出文件将会列出电路中的所有

元件、 各连接节点值、 参数值、 模型型号等参数。 图 2. 11 中还列出了可用于输

出文件的其他选项。 Reset 复位按钮将把所有选项恢复为默认设置。
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图 2. 11　 输出文件选项设置

2. 2　 显示工作点数据

当电路运行仿真之后， 各节点的偏置电压、 电流和功率值都可以在原理图中

进行显示。 在 Capture 中， 选择菜单 PSpice > Bias Points > Enable 或者通过工作

点显示图标对以上信息进行显示， 从外观上看 16. 3 版本的图标有所改变， 如图

2. 12a 和图 2. 12b 所示。
图 2. 13 显示出 RC 电阻电路的偏置电压、 电流和瞬时功率。
如图 2. 14 所示， 工作点数值的显示位数可以通过菜单 PSpice > Bias Points

> Preferences 进行修改。 到目前为止， 数值的最高准确度为 10 位。

图 2. 12
a） 16. 3 以前版本工作点显示图标　 b） 16. 3 版本工作点显示图标

可以对每个独立的工作点电压、 电流或功率进行显示或者不显示。 例如， 当

选定某条导线网络时， 电压显示图标 将被激活， 通过该图标可以设置其偏置
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图 2. 13　 显示工作点电压、 电流和功率

图 2. 14　 修改工作点数值显示准确度

电压显示或者不显示。

如果选定元件的某个引脚， 电流显示图标 将被激活， 通过该图标可以设

置其偏置电流显示或者不显示。 如果选择某个元件， 瞬时功率显示图标 将被

激活， 通过该图标可以设置其偏置功率显示或者不显示。

　 　 提示：
当打开或者关闭工作点显示功能时， 需要通过 F5 键对显示信息进行刷新。

2. 3　 保存工作点数据

对于庞大的复杂电路， PSpice 仿真需要耗费很长的时间， 那么对工作点数值

进行保存并且再利用就非常有意义。 如果使用保存的工作点数值， 必须保证电路

的网络表中的信息， 例如各元件的连接等均没有改变。 同样， 其他类型的仿真分
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析也可以利用工作点数值， 前提是电路进行再仿真时其网络表没有发生任何改

变。 正确的保存和使用工作点数值能够减少仿真运行时间。 当仿真不收敛的时

候， 保存工作点数值也非常有用。
在 Simulation Profile Settings 仿真设置窗口选择 Bias Point 工作点分析， 然

后选择 Save Bias Point 保存工作点数值。 如图 2. 15 所示， 工作点分析的详细数

据保存在 saved bias point. txt 文本文件中。 可以通过 Browse. . . 浏览按钮选择

或者创建保存该文件的文件夹。
文本文件中保存的工作点数据主要包括： 各节点电压值和电路中所有元件的

数字状态、 总功率和电压源的电流、 电路中所有元件的模型参数。

　 　 注意：
当保存工作点数据的时候， 建议增加文件的扩展名为 . txt， 这样就能够通

过 WordPad 或者 Notepad 等文字编辑器对其进行打开和浏览。

图 2. 15　 工作点设置

2. 4　 加载工作点数据

在仿真设置窗口中， 可以通过 Load Bias Point 加载工作点数据选项对已保

存的工作点数据进行加载。 图 2. 16 为选择以前保存的工作点数据对话框。 工作

点信息也可以保存并用于直流扫描和瞬态分析。
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图 2. 16　 加载已保存的工作点数据对话框

2. 5　 本章练习

练习 1
1. 图 2. 17 所示为 RC 电路， 该电路以第 1 章的电阻电路为基础， 增加电容

C1 与 R2 并联， 电容选自 analog 库， 容值为 1nF。

图 2. 17　 RC 电路

2. 删除 0V 符号然后对电路重新进行仿真， 将会出现如图 2. 18 所示的警告

信息， 要求检查仿真状态记录， 通常情况下仿真状态记录在 Capture 屏幕底部。
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图 2. 18　 警告信号

向上展开信息窗口就能看到完整的消息。 如果信息窗口不可见， 可以通过顶

部工具栏 Window > Session Log 看到如下信息：
WARNING [NET0129 ] Your design does not contain a Ground

（0） net.
实际电路的网络节点编号可能会与以上不同。 打开 PSpice 窗口， 查看输出

文件， 文件中指出某节点浮动， 未接地 （见图 2. 19）。

图 2. 19　 输出文件指出某节点浮动

3. 在 RC 电路中， 重新连接地符号然后对电路进行仿真。 仿真应该能够顺利

进行， 再无错误出现。

　 　 注意：
PSpice 会自动为每条导线分配网络名称， 除非设计人员对其进行手动命名。

在上述输出文件中， 每个节点都是浮动的， 因为整个电路没有设置 0 节点。 使

用 PSpice 或者其他 Spice 仿真软件工具时， 必须为电路设置 0V 节点， 否则输出

文件将会报告节点浮动， 电路不能顺利进行仿真分析。

如图 2. 20 所示， capsym 库中还包括其他的地符号。 如果电路进行 PSpice 仿

真， 一定要确保选择具有数字 0 标识的地符号。 电路中只要有一个 0V 地节点就

可以， 其他地符号可以放置在电路中体现与 0V 地节点之间的差异。

4. 通过选择菜单 PSpice > New Simulation Profile 或者单击图标 创建工作
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图 2. 20　 各种地符号

点仿真文件， 在 Name 栏中输入 bias 作为仿真文件名称 （见图 2. 21）， 然后单击

Create 创建仿真文件。

图 2. 21　 创建工作点仿真文件

5. 当仿真文件同名时会出现如图 2. 22 所示的对话框， 提示设计人员有相同

名称的仿真文件已经存在。 新仿真项目中已经包含默认名称为 bias 的工作点仿

真文件。

图 2. 22　 仿真文件同名时的提示

单击 OK 按钮进行确定， Capture 会自动将仿真文件命名为新名称 bias1 （见
图 2. 23）。 然后单击 Create 创建工作点仿真文件。

6. 图 2. 24 所示为仿真设置窗口。 如果未处于默认设置状态， 在 Analysis
type 分析类型栏中选择 Bias Point 工作点分析， 然后单击 Apply 应用并退出仿真

设置窗口。
7. 在 Options 选项卡中， 选择 Output File 输出文件并对其进行如下设置：

取消 NOBIAS 选项， 选定 LIST 选项 （见图 2. 25）， 最后单击 OK 按钮进行确定。
8. 运行仿真程序。 当仿真结束时， 选择菜单 View > Output file 查看输出文

件。 输出文件如图 2. 26 所示， 包括电阻、 电容和电压源的信息汇总。 但是输出
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图 2. 23　 仿真文件名称自动更新为 bias1

图 2. 24　 设置工作点仿真分析

文件并未包含输出电压和电流信息。
9. 创建新的 PSpice 仿真设置文件， 这次可以继承已有的仿真文件设置。 在

New Simulation 新仿真文件窗口中输入 bias2 作为仿真文件名称， 如图 2. 27 所示

单击下拉菜单 Inherit From， 选择 bias1， 然后单击 Create 创建新的仿真文件。
在仿真设置对话框中， 会发现 Bias Point 工作点分析已选择。 然后选择Options >
Output file， 将会看到 LIST 选项被选定， NOBIAS 选项未被选定。 单击 OK 按钮

关闭仿真设置对话框。
到目前为止我们已经建立了三个工作点仿真文件： bias、 bias1 和 bias2。
10. 通过菜单 Window > < project path > \ RC. opj file （见图 2. 28） 或者图
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图 2. 25　 输出文件选项设置

图 2. 26　 输出元件信息汇总表

标 和 可以打开项目管理器窗口。
图 2. 29 所示为 rc. dsn 的项目管理器窗口。
11. 在项目管理器窗口中， 展开 PSpice Resources > Simulation Profiles 仿真

设置文件。 如图 2. 30a 所示， 项目管理器中列出 3 个已经创建好的工作点仿真分

析文件， 同样图 2. 30b 所示的顶部工具栏的下拉菜单中也可以看到如下仿真文

件： bias、 bias1 和 bias2。
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图 2. 27　 继承已有的仿真文件设置

图 2. 28　 选择项目管理器

图 2. 29　 项目管理器窗口
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图 2. 30　
a） 项目管理器中的工作点项目文件　 b） 工作点仿真设置文件列表

在此项目中 bias2 被选中， 项目管理器采用红色图标在其左侧进行标识， 表

示该文件为当前仿真文件或者处于激活状态， 你可以在下拉菜单中选择另一个文

件， 在项目管理器中也可以通过 rmb > Make Active 对需要仿真的文件进行

激活。
12. 在图 2. 30b 的下拉菜单中选择 bias1， 然后观察项目管理器中仿真文件的

变化。 可以看到 Bias1 处于激活状态。

　 　 注意：
以上功能在不同的仿真分析文件及同一仿真文件不同的分析类型之间切换

时非常实用。
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当电路中的电压源、 电流源、 温度、 全局参数或者模型参数在一定范围内变

化时， 可以通过直流扫描分析计算电路工作点的变化情况。 扫描方式可以为线

性、 对数或者列表的形式， 但是扫描数值必须以递增的形式进行改变。
当计算电路中的电压源或者电阻值改变所引起的电路响应时， 直流扫描分析

非常实用。 直流扫描分析还可以进行嵌套， 例如令两个变量中的某一变量的值固

定， 对另一变量进行扫描。 例如， 测试晶体管的 IC - VCE特性曲线时， 对于每个

基极电流值， 测试其集电极电流随集电极 -射级电压变化的曲线。 这样直流扫描

分析将会包含两个变量： 集电极 - 射极电压 VCE和基极电流 IB， 其中， VCE为主

扫描而基极电流 IB 为辅扫描。 当基极电流 IB 阶梯改变， 集电极 - 射极电压 VCE

连续变化时， 集电极电流 IC 为一族曲线， 如图 3. 1 所示。

图 3. 1　 利用嵌套扫描对晶体管特性曲线进行仿真分析

3. 1　 直流电压扫描分析

与其他分析类型一致， 对电路进行直流扫描分析时首先需要创建仿真文件。
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对电路进行直流扫描分析， 选择菜单 PSpice > New Simulation Profile 创建仿真

文件， 然后在仿真类型对话框中选择 DC Sweep 直流扫描分析。 选定 Sweep Var⁃
iable 扫描变量为 Voltage source 电压源。 Name 为所扫描电压源的名称， 对于下

面实例， 电压源名称为 V1。 扫描类型为 Linear 线性扫描， 起始值为 0V， 结束

值为 10V， 步长为 1V。 也可以在 Value list 列表中输入如下电压值 1 2 4 5 99 100
对电压源进行参数扫描分析， 切记电压值必须按照递增的顺序排列。

图 3. 2 所示为直流线性扫描分析仿真设置对话框， 对电压源 V1 进行线性扫

描， 起始值 0V， 结束值 10V， 步长 1V。

图 3. 2　 直流扫描分析仿真设置

　 　 注意：
可以根据设计人员的习惯对电压源进行重新命名， 但是一定要确保电压源

名称的首字母为 V。 例如， 电压源的名称为 Vsupply。 利用以上方法可以对其他

元件进行命名， 例如把负载电阻命名为 RL， 这在对电路进行分析时更加有实际

意义。

3. 2　 探针

PSpice 软件中包含很多种探针， 可以通过菜单选项对其进行调用。 探针可以

对节点电压值或者流过元件的电流值进行详细的记录。 利用这些数据， 可以在
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Probe 图形显示窗口对其进行波形显示。 通过菜单选项 PSpice > Markers 可以添

加探针。 如图 3. 3 所示为探针类型， 主要包括电压探针、 电流探针和差分探针。
高级探针主要用于交流 AC 分析， 本书第 4 章将对其进行详细讲解。

图 3. 3　 PSpice 探针

图 3. 4　 PSpice 不同版本的探针图标

a） 16. 2 版本　 b） 16. 3 版本

不同的 PSpice 版本， 功能图标会有所

不同。 图 3. 4a 所示为 16. 2 版本的探针图

标， 图 3. 4b 为 16. 3 版本的探针图标。
电压探针放置在导线上就能测试该导

线的电压数据， 但是电流探针必须放置在

元件的引脚上才能采集流过该元件的电流

数据。 如果把电流探针放置在导线上而不

是元件引脚上将会出现如图 3. 5 所示的警

告信息。 在 PSpice 软件中， 元件引脚和导

线采用不同的颜色， 而且在 16. 3 版本中元

件引脚看上去比导线更加细薄。 放置功率探针时， 一定要把探针放置在元件

体上。
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图 3. 5　 警告信息： 电流探针不允许放置在导线上

　 　 注意：
对电路进行仿真之后才能放置探针， 否则探针无数据输出。 常见错误为先

放置探针， 然后对电路进行仿真设置， 当设置完成后探针会消失。

图 3. 6 所示的电阻电路中， 在节点 in 和节点 out 处增加两个电压探针以记录

其电压值。 当仿真结束后， 在图形显示窗口中将会自动出现节点 in 和节点 out 的
电压波形。

图 3. 6　 添加双电压探针

当仿真运行的时候， Probe 图形显示程序会自动启动， 并且对节点 in 和节点

out 两节点的电压波形进行显示。 x 轴为扫描电压 V （ in）， y 轴为仿真结果 V
（out）。 如图 3. 6 和图 3. 7 所示， 当电路中放置多个探针时， 其波形颜色与探针

颜色一致。

　 　 注意：
第一次放置探针时， 探针的初始颜色为灰色。 运行电路仿真分析后， 探针

的颜色将会改变， 并且 Probe 中图形的颜色与探针颜色一致。 当在 Probe 中删除

某条曲线时， 原理图上该探针的颜色将会变为灰色。 通过双击该探针， 探针颜

色将会恢复， 并且曲线波形将重新显示在 Probe 中。
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图 3. 7　 节点 in 和节点 out 处的电压波形

在 16. 3 版本中， Probe 图形显示窗口的默认背景颜色为黑色， 用户可以根据

设计要求对其进行更改。 更改方式如下： 从 PSpice 顶部工具栏选择 Tools > Op⁃
tions > Color Settings。

在 16. 2 版本中， 通过 rmb > Properties 可以对波形颜色进行修改， 如图 3. 8
所示； 而在 16. 3 版本中则通过 rmb > Trace Property 对其颜色进行设置。 如图

3. 9 所示， 虽然不同版本操作略显不同， 但是 Trace Properties 波形属性对话框

却完全一致。
在图 3. 9 所示的 Trace Properties 对话框中， 波形颜色、 类型、 宽度等均可

更改。

图 3. 8　 PSpice16. 2 版本波形属性选择 图 3. 9　 改变波形属性对话框

　 　 注意：
如图 3. 10 所示， 从 16. 3 版本开始， 用户可以通过右键对波形的相关功能

选项进行操作。
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图 3. 10　 波形菜单选项

从 16. 3 版本开始， 可以对 Probe 图形显示窗口中的坐标轴、 栅格及背景颜

色进行修改。 如图 3. 11 所示， 通过工具栏选择 Tools > Options > Color Settings
对颜色进行设置。

图 3. 11　 更改 Probe 图形显示窗口颜色
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图 3. 12　 电阻网络

3. 3　 本章练习

练习 1
如图 3. 12 所示的电阻网络为电压分

压器， 其输出电压与输入电压之比为

Vout
Vin

= R1
R1 + R2 （3. 1）

计算得

Vout = Vin
R1

R1 + R2 （3. 2）

图 3. 13　 放置网络节点

通过上式 （3. 2） 可知， 输出

电压值由电阻 R1 和 R2 决定。 当

电阻 R1 = R2 时， 输出电压等于输

入电压的一半。
1. 按照图 3. 12 绘制电阻电路

的仿真原理图， 然后如图 3. 13 所

示选择 Place > Net Alias 对节点

进行命名。
2. 通过选择菜单 PSpice >

New Simulation Profile 创建 PSpice 仿真文件， 在设置对话框中选择分析类型

Analysis type 为 DC Sweep 直流扫描分析。 如图 3. 14 所示， 扫描变量 Sweep
variable 为电压源 V1， 扫描方式为 linear 线性方式， 初始值为 0V， 结束值为

10V， 步长为 1V。 然后点击 OK 按钮对仿真设置进行确定。

图 3. 14　 直流扫描仿真分析设置



第 3 章　 直流扫描分析 45　　　

图 3. 15　 在节点处放置电压探针

3. 如图 3. 15 所示， 在网络节点 in 和节点

out 处放置电压探针。
4. 单击图标 运行仿真。
5. 运行 PSpice 仿真， 在 Probe 图形显示窗

口中将输出 V （in） 和 V （out） 两条曲线的波

形。 从图 3. 16 可以看出， 波形颜色与图 3. 15
中探针的颜色一致。 本电路为分压电路， 输出

电压值为输入电压值的一半。

图 3. 16　 对电阻电路的输入电源 Vin进行直流扫描分析时电路的输出电压特性

6. 删除接地符号， 然后重新对电路进行仿真。 将会看到如图 3. 17 所示的警

告信息对话框， 以提示仿真人员对状态记录进行检查。

图 3. 17　 警告信息

7. 状态记录通常显示在屏幕下方。 如果没有显示， 可以通过顶部工具栏菜

单 Window > Session Log 进行设置， 警告信息显示如下：
WARNING [NET0129 ] Your design does not contain a Ground

（0） net.
8. 在如图 3. 17㊀所示的警告信息对话框中单击 OK 按钮， 运行 PSpice 仿真。

㊀　 原书为 3. 15， 出现错误。 ———译者注
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图 3. 18　 输出文件中的浮动节点错误信息

如果未能显示输出文件， 通过

选择菜单 View > Output File
对其进行显示。 输出文件如图

3. 18 所示， 但是同样的电路，
网络节点编号可能会不同。 电

路将有不同的节点编号。 第 2
章对删除 0V 接地符号的影响

进行了详细的讲解， 在此还要

强调指出， 如果电路需要进行

仿真计算， 0V 节点必不可少， 否则电路节点将被认为浮动， 电路仿真不能进行。
9. 通过菜单 Place > Ground 或者快捷键 G 选择 0V 符号， 重新连接到电

路中。
10. 从电路中删除电阻 R2， 然后对电路重新运行仿真分析。
11. 运行 PSpice 仿真， 输出文件中将出现如下错误信息：
ERROR - - Iess than 2 connections at node out 1

12. 错误信息表明节点 out 无直流通路和电阻 R2 浮动。 电路能够进行 PSpice
仿真分析的另一个要求是电路的每个节点必须具有直流接地通路。 如果需要对开

路节点进行仿真分析， 可以在节点处对地连接 100GΩ 或 1TΩ 等大阻值电阻， 以

提供直流接地通路， 由于电阻阻值非常大， 对直流工作点分析不会产生影响。 同

样的， 可以通过阻值为 1μΩ 或者更小的电阻等效短路功能。
练习 2
利用直流嵌套扫描分析对晶体管特性曲线进行显示。 设置电压源 VCE为主扫

描， 基极电流为辅扫描。
1. 绘制如图 3. 19 所示的电路图。 晶体管选自 bipolar 库。 如图 3. 20 所示，

在 Place Part 放置元件菜单中选择 Add Library 添加库文件图标 或者在旧版

本中通过单击 Add Library 对元件库进行添加。 如果所用软件为演示版， 可以从

eval 库中找到 Q2N3904。 如果软件为完整版， 晶体管可以从 bipolar 库中找到。
图 3. 21 所示为库文件浏览窗口。 在库文件中选择 bipolar. olb 然后单击 Open

按钮对该库文件进行添加。
2. 双极型晶体管 bipolar 库已经添加到 Place Part 放置元件菜单中。 如图

3. 22 所示， 选定 bipolar 库， 然后在元件名称栏中输入 Q2N3904 （不区分大小

写）， 通过双击 Q2N3904 晶体管使其放置到原理图绘制界面中。

　 　 注意：
OrCAD 演示版的元件库中包含 Q2N3904 晶体管。
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图 3. 19　 晶体管电路

图 3. 20　 添加库文件

图 3. 21　 PSpice - Capture 库文件
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图 3. 22　 Q2N3904 晶体管的选取

3. 按照如上步骤放置图 3. 19 中的其他元件。
4. 对电路进行直流嵌套扫描分析， 电压源 VCE 为主扫描， 基极电流为辅

扫描。
5. 通过选择菜单 PSpice > New Simulation Profile 创建仿真设置文件， 在设

置对话框中选择分析类型 Analysis type 为 DC Sweep 直流扫描分析。 Primary
Sweep 默认为主扫描， 扫描变量 Sweep variable 为电压源 VCE， 扫描方式为

Linear 线性方式， 初始值为 0V， 结束值为 12V， 步长为 0. 1V （见图 3. 23）。 然

后单击 Apply 应用按钮对仿真设置进行确定， 但是不要退出仿真设置。
6. 在 Options 栏中选择 Secondary Sweep。 Sweep variable 扫描变量为电流
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图 3. 23　 直流主扫描设置

源 I1。 Sweep type 扫描类型为 Linear 线性扫描， 起始值为 40μA， 结束值为

200μA， 步进为 40μA。 确保选中辅扫描 Secondary Sweep 复选框， 然后单击 OK
按钮对仿真设置进行确认 （见图 3. 24）。

图 3. 24　 直流辅扫描设置

7. 在晶体管的集电极引脚放置电流探针， 然后对电路运行仿真分析。
8. 晶体管的特性曲线如图 3. 25 所示。
9. 选择菜单 Plot > Axis Settings > YAxis 对 Y 轴进行设置， Data Range 选
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图 3. 25　 通过嵌套扫描分析得到的晶体管的特性曲线

择 User Defined， 范围从 0mA 至 40mA。 然后单击 OK 按钮查看显示图形变化。
10. 选择菜单 Plot > Axis Settings > YGrid 对 Y 轴栅格进行设置， 取消

Automatic 自动设置， 并设置主栅格间距 10m。 然后单击 OK 按钮查看显示图形

变化。
11. 选择菜单 Plot > Axis Settings > XGrid 对 X 轴栅格进行设置， 主栅格

和辅栅格均设置为 None。 然后单击 OK 按钮查看显示图形变化。
12. 选择菜单 Plot > Axis Settings > YGrid 对 Y 轴栅格进行设置， 主栅格

和辅栅格均设置为 None。 然后单击 OK 按钮查看显示图形变化。
13. 选择菜单 Plot > Label > Text 输入文字， 设置字体颜色为银色， 然后

添加晶体管基极电流， 如图 3. 26 所示。

图 3. 26　 晶体管电流 Ic 随电压 Vce和电流 Ib 变化的直流嵌套扫描特性曲线
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通过对交流源的频率进行扫描， 可以对电路实现交流分析， 以计算电路的频

图 4. 1　 独立源 VAC和 IAC

a） 元件外形　 b） VAC属性

率和相位响应。 交流扫描分析也

是线性分析， 首先利用线性模型

对非线性模型进行等效， 然后在

一定范围内对电路的频率响应进

行计算。 对电路进行交流分析之

前先对其进行直流工作点分析，
然后利用所得数据在直流工作点

附近对电路进行线性化处理。 一

定要注意， 交流分析不考虑阶跃

响应等因素的影响， 如果需要对

其进行测试， 可以运行瞬态仿真

分析。
进行交流分析时， 独立的电

压源 VAC 或 电 流 源 IAC （ 见 图

4. 1a） 均选自 source 元件库。 但

是， 任何具有交流 AC 属性的独立

电压源均可作为电路的输入， 可

以用于交流分析。 如图 4. 1b 所示为电压源 VAC的属性编辑器对话框， 可以通过

该对话框对其属性进行修改。
默认情况下， 独立电压源 VAC的幅度为 1V。 对电路进行频率响应计算时，

通常希望求得电路的增益 （幅频） 和相频特性。 因为电路的增益为 Vout与 Vin的

比值， 当输入电压 Vin设定为 1V 时， 电路的增益就等于输出电压 Vout。
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4. 1　 仿真参数设置

以陷波滤波器为例， 利用交流分析求电路的频率响应。 陷波滤波器用来对某

一不需要的窄带频率进行衰减， 例如对导致音频放大器产生 “嗡嗡声” 的频率

进行去除。 图 4. 2 所示为常用的双 T 形陷波滤波器电路， 其陷波频率计算公

式如下： 　

fO = 1
2πRC （4. 1）

图 4. 2　 双 T 形陷波滤波器电路

如图 4. 3 所示为陷波滤波器的幅频响应曲线， 从图中可以得出陷波频率为

53Hz 时， 衰减 60dB。

图 4. 3　 陷波滤波器幅频特性曲线

通过菜单选择 PSpice > New Simulation Profile 创建交流分析仿真设置文件。
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如图 4. 4 所示， Analysis type 分析类型为 AC Sweep / Noise 交流扫描 /噪声分析，
频率采用对数方式， 从 1Hz 扫描至 100kHz。 交流分析有两种频率扫描方式： 线

性扫描和对数扫描， 其中对数又可以分为 10 倍频或者 8 倍频率扫描方式。 扫描

设置时一定要注意： 如果选用线性扫描， Total Points 总扫描点数为全频率范围

内的扫描点数； 如果选用 10 倍频对数扫描， Total Points 总扫描点数为 10 倍频

范围的扫描点数。

图 4. 4　 交流扫描仿真分析设置

　 　 注意：
仿真设置时容易把线性扫描的总扫描点数和对数扫描的每 10 倍频 （或 8 倍

频） 扫描点数混淆。 如果在整个频率设置范围内的总扫描点数为 10， 交流分析

波形将产生严重变形。 检查交流扫描仿真设置， 选择正确的扫描方式： 线性或

者对数。 另一个常见的错误为将 megahertz， 即 MHz （兆 Hz） 写为 mHz （毫

Hz）， PSpice 不区分大小写， 会把 MHz 误认为 mHz （毫 Hz）。 经常 megahertz
（兆 Hz） 写成 megHz 或 MEGHz 或 10E6Hz。 输入时单位 Hz 可以省略， 例如

100meg Hz 可以写成 100meg。

4. 2　 交流探针

图 4. 5 所示为 PSpice 仿真软件中交流探针的所在位置， 通过选择菜单
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图 4. 5　 交流探针菜单

PSpice > Markers > Advanced 对其进行选择和放置。 利用这些探针可以显示

曲线的分贝幅度、 相位、 群延迟及电压和电流的实部和虚部。 例如， 利用这些探

针的合理组合， 可以绘制波特图和奈奎斯特曲线。

4. 3　 本章练习

练习 1
如图 4. 6 所示为无源双 T 形陷波滤波器。 对电路进行交流扫描分析， 绘制其

幅频特性曲线。
1. 绘制如图 4. 6 所示的陷波滤波器电路。 独立电流源 VAC 选自 source 元

件库。
2. 如图 4. 7 所示， 创建 PSpice 仿真设置文件： 交流扫描分析， 对数扫描方

式， 扫描频率从 1Hz 至 100kHz， 每 10 倍频扫描点数为 100。
3. VdB电压探针能够自动计算输出电压的分贝值。 如图 4. 8 所示， 通过选择

菜单 PSpice > Markers > Advanced > dB Magnitude of Voltage 放置分贝电压

探针。
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图 4. 6　 双 T 形陷波滤波器

图 4. 7　 交流扫描分析仿真设置

4. 首先运行电路仿真， 屏幕图形显示界面将会输出如图 4. 9 所示的陷波滤

波器的幅频特性曲线。 然后利用该曲线求陷波器最低点的频率值。
5. 选择菜单 Trace > Cursor > Display 或者图标 、 打开光标， 然后

将光标置于陷波曲线的底部。 为了读数更加准确， 可以通过菜单 View > Zoom
> Area 或者图标 对曲线进行放大。 利用菜单 Trace > Cursor > Min
或者图标 和 求曲线的最小值。 对陷波曲线求最小值时， 探针光标框中将显

示陷波频率为 53. 703Hz， 衰减为 - 59. 348dB， 如图 4. 10 所示。 另外数据显示格

式还与使用的软件版本有关。 在 16. 2 和 16. 3 两个软件版本中， 探针光标框可以

放置在屏幕的任何区域。
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图 4. 8　 添加 dB 分贝电压探针

图 4. 9　 陷波滤波器幅频特性曲线

图 4. 10　 光标数据

a） 16. 2 版本　 b） 16. 3 版本

6. 选择菜单 View > Zoom > Fit
或者图标 对屏幕图形显示进行还原。
在屏幕底部选定曲线名称， 然后通过

选择菜单 Trace > Delete all Traces 或

者单击键盘上的 delete 删除键对曲线进

行删除。 现在， 我们手动添加输出电

压 V （out） 的波形曲线。
7. 选择菜单 Trace > Add Trace

或者点击图标 将会出现如图 4. 11 所

示的 Add Traces 添加曲线对话框。
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图 4. 11　 添加曲线对话框， 包括输出变量列表、 数据类型选择和各种函数

8. 在 Add Traces 添加曲线窗口中， 显示了电路中所有节点和元件的数据。
在 Simulation Output Variables 仿真输出变量列表中取消 Currents 电流和 Power
功率复选框， 通过下拉条使输出变量列表向下滚动， 选择 V （out）， 然后单击

OK 按钮进行确定。
9. V （out） 曲线将会出现在屏幕显示窗口中。 但是， 我们需要曲线进行电

压分贝显示。 选择曲线名称 V （out） 然后单击 delete 删除键对该曲线进行删除。
10. 选择菜单 Trace > Add Trace 将会出现 Add Traces 添加曲线对话框，

在对话框的右侧的 Analog Operators and Functions 栏中选择 DB （）。 如前面操

作一样， 在 Simulation Output Variables 仿真输出变量栏中选择 V （out）。 然后

在屏幕图形显示窗口底部的表达式框中将会看到 DB （V（out））。 DB 函数将自动

对 V （out） 进行分贝计算， 如图 4. 12 所示。

图 4. 12　 V（out） 转化为 dB 分贝

单击 OK 按 钮， 将 会 得 到 如 图

4. 13 所示的波形曲线。
11. 重复步骤 5， 求陷波器衰减的

分贝值。
双 T 形陷波滤波器

如图 4. 14 所示为陷波滤波器电路， 陷波频率值由公式 （4. 1） 进行计算：

fO = 1
2πRC
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图 4. 13　 陷波滤波器的幅频特性曲线

图 4. 14　 双 T 形陷波滤波器电路

如果假设图 4. 14 中的所有电阻值一致， 所有电容值一致， 改进后的电路如

图 4. 15 所示。

图 4. 15　 相同电阻值和相同电容值构成的双 T 形陷波滤波器电路

两电容的并联电容值为　 CP = C + C =2C
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两电阻的并联电阻值为　 RP = R × R
R + R = R

2
上述计算结果与图 4. 14 所示电路完全一致。
如图 4. 6 所示的陷波滤波器电路中， 电阻 R =27kΩ， 电容 C =110n。 利用公

式 （4. 1） 求陷波频率值：

fO = 1
2πRC

fO = 1
2π ×27 × 103 × 110 × 10 -9 = 53. 6Hz



第 5 章
参数扫描分析

参数扫描分析是指电路中某一参数值在给定范围变化时对电路进行的特性分

析。 参数扫描分析可以和瞬态分析、 交流分析和直流扫描分析同时运行。 电压

源、 电流源、 温度、 全局参数或者模型参数都可以进行参数扫描分析。 参数变量

通过 Special 元件库中的 PARAM 元件进行设置， 全局参数变量可以通过数学表

达式和参数变量的组合进行设置。 通过对 PARAM 元件属性编辑器进行设置， 可

图 5. 1　 全局变量参数定义

以添加新的全局变量。 例如图 5. 1
所示的电阻电路中， 把电阻 RL㊀的

阻值更改为 { rvariable}， 同样也可

以根据设计要求对其进行其他命名。
PSpice 软件通过大括号 { } 对全局

参数变量进行定义。
PARAM 元器件的名称为 PA⁃

RAMETERS： 包含定义变量名称及

其默认值列表。 在这种情况下， 如

果电路不进行参数扫描分析， RL 的默认值为 10kΩ。

5. 1　 属性编辑器

如上所述， 在 PARAM 元件属性编辑器中， 通过增加新属性对全局参数变量

进行名称和默认值的设置。 PARAM 元件属于 special 元件库， 可以放置在原理图

的任何地方。 通过双击 PARAM 元件打开其属性编辑器 （见图 5. 2）。
属性编辑器中详细列出了元件的所有属性。 例如， 电阻的属性包括封装、 电

阻值、 额定功率、 容差、 产品编号和 PSpice 模型等。 通过属性编辑器可以对元

㊀　 R2 应该为 RL， 原书有误。 ———译者注
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图 5. 2　 属性编辑器

件的属性进行添加， 例如 PARAM 元件， 对其添加属性来定义全局变量， 以用于

参数扫描分析。
当第一次选择属性编辑器并对其进行打开时， 我们将看到两种显示模式： 行

显示 （见图 5. 3a） 或列显示 （见图 5. 3b）。
如图 5. 3a 所示， 当属性编辑器进行行显示时， 更容易对其所有属性内容进

行查看。 如果属性编辑器为列显示 （见图 5. 3b）， 必须通过属性编辑器底部的滚

动条对其所有属性进行查看。 另外， 可以对属性编辑器进行行、 列显示模式切

换。 例如， 从列显示切换到行显示时， 在 Color 属性左侧的空白处 （见图 5. 3b）
通过 rmb > Pivot 对属性编辑器进行列到行的显示切换。

从行显示切换到列显示时， 在 Color 属性左侧的空白处 （见图 5. 3b）， 通过

rmb > Pivot 对属性编辑器进行行到列的显示切换。
按照如下步骤添加全局参数变量， 以用于参数扫描分析： 首先在如图 5. 3a

所示的属性编辑器对话框中选择 New Row， 将会出现如图 5. 4 所示的 Add New
Row 对话框， 然后在对话框中输入变量名称 Name 和默认值 Value。 在图 5. 4
中， 参数名称为 rvariable， 默认值为 10kΩ。 如图 5. 5 所示为添加新参数变量后

属性编辑器的显示内容。
属性编辑器中所列出的每个属性均具有名称及其参数值。 例如某晶体管的封
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图 5. 3　 PARAM 元件的属性显示

a） 行显示　 b） 列显示

装为标准 TO5 型， 其中封装为属性名称， TO5 为参数值。 当电阻的容差为 1%
时， 容差为属性名称， 1% 为参数值。 表 5. 1 列出了某些元件的属性名及其参

数值。
默认情况下， 新建属性的名称和参数值并不显示在原理图中， 所以必须通过手

动设置使其显示。 在属性编辑器对话框中选定需要显示的属性， 然后选择按钮 Dis⁃
play （或 rmb > Display） 打开 Display Properties 显示属性对话框， 如图 5. 6 所示。
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图 5. 4　 PARAM 元件中添加新属性

图 5. 5　 PARAM 元件中成功添加新参数变量 rvariable 及其默认值 10k
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表 5. 1　 属性实例

元件属性名称 元件参数值

封装 TO5

容差 1%

元件参数 R1

图 5. 6　 属性名称及其参数值显示设置

如图 5. 1 所示的电阻电路， 当用 PARAM 元件添加全局参数时， 为了方便电

路读图， 建议对其名称和参数值进行显示。

注意：
通过单击属性编辑器窗口右下角的十字交叉符号可以关闭

属性编辑器。 切记不要选择上面顶部的十字交叉符号， 这样会

关闭 Capture 软件。

5. 2　 本章练习

练习 1
当把传声器等音频输出设备与输入放大器连接时， 需要传声器的输出阻抗与

放大器的输入阻抗匹配。 对于视频和射频 （RF） 设备同样也需要进行阻抗匹配。
信号在输入信号源和负载之间传输时， 当信号源的输出阻抗与负载的输入阻抗匹

配时传输功率最大， 最大传输功率为信号源输出功率的 50% 。
如图 5. 7 所示为简单的电阻匹配电路， 绘制负载电阻功耗随其阻值变化的

曲线。
1. 创建一个新的 PSpice 仿真项目或者使用第 1 章的电阻电路仿真项目。
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图 5. 7　 阻抗匹配电阻网络

2. 从 source 元件库选择 VDC直流

电压 源， 并 设 置 其 值 为 10V。 从

analog 元件库选择电阻 R， 重命名为

RS， 阻值设置为 47k； 选择电阻 R，
重命名为 RL， 阻值设置为 { rvari⁃
able}。 从 capsym 元件库连接 0V 接地

符号 （Place > Ground）。 把电阻 RS
与 RL 的连接节点命名为 VL （Place Net > Alias） （见图 5. 7）。

3. 从 special 元件库中选择 PARAM 元件放置到原理图中。
4. 通过双击 PARAM 元件打开属性编辑器。
5. 根据属性编辑器的显示形式 （行或列） 选择单击 New Row 或者 New

Column， 以添加新参数。 如图 5. 8 所示， 创建一个新参数， 名称为 rvariable，
参数值为 10k。 该电路设置了一个全局参数， 名称为 rvariable， 默认值为 10kΩ。
如果电路未进行参数扫描分析， 该默认值即为电阻的阻值。 单击 OK 按钮对设置

进行确定， 切记不要退出属性编辑器。

图 5. 8　 创建全局参数

6. 选定新参量 rvariable， 然后对其进行显示属性设置。 图 5. 9 所示为 Dis⁃
play Properties 显示属性窗口， 在显示格式对话框中选择 Name and Value， 然后

关闭属性编辑器。
7. 对全局参数 rvariable 进行直流扫描分析， 采用线性扫描方式， 起始值为

500Ω， 结束值为 100kΩ， 步长为 500Ω。 可以通过菜单 PSpice > New Simulation
Profile 创建仿真文件， 命名为 global sweep 或者其他。 仿真分析类型选择 DC
Sweep 直流扫描分析， 扫描变量选择 Global parameter 全局参数变量， 名称为
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图 5. 9　 显示参数属性

rvariable。 扫描类型为 linear 线性扫描， 起始值为 500Ω， 结束值为 100kΩ， 步

长为 500Ω （见图 5. 10）。

图 5. 10　 全局参数扫描仿真设置

8. 通过选择菜单 PSpice > Markers > Power Dissipation 或者图标 或

在电阻 RL 上放置功率探针， 如图 5. 7 所示。
9. 通过选择菜单 PSpice > Run 或者图标 运行电路仿真。 功耗曲线如图

5. 11 所示。
10. 如图 5. 11 所示的曲线中， 可以通过打开光标测量负载电阻的最大功率。
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图 5. 11　 负载电阻功耗曲线

图 5. 12　 激活 W （RL） 曲线

通过选择菜单 Trace > Cursor > Display 或者

图标 或 显示光标。 在屏幕显示窗口中， 鼠

标左键和右键分别控制一个光标。 当第一次选

择 Cursor > Display 时， 所选定曲线名称周围

会出现白色虚线方框， 如图 5. 12 所示。
当单击鼠标左键时， 光标会跟随着鼠标左键移动。 同时光标框也会出现， 并

标出光标所在点的坐标值。 如图 5. 13a 所示， 在 16. 2 及其以前版本中， A1 为鼠

标左键光标对应的坐标值， 第一值为 x 坐标， 第二值为 y 坐标； A2 为第二光标

即鼠标右键光标对应的坐标值， 第一值为 x 坐标， 第二值为 y 坐标。 从 16. 3 版

本开始， 光标坐标值如图 5. 13b 所示， 通过该对话框可以添加不同曲线和图形的

光标坐标值， 以便进行测量。

图 5. 13　 光标点的坐标值

a） 16. 2 版本　 b） 16. 3 版本

11. 将光标置于曲线的最大值处， 然后读取负载电阻值。
同样， 如图 5. 14 所示， PSpice 软件中还有很多种光标功能， 利用这些功能

可以查找曲线上各点的值， 如最大值或者最小值。 通过选择菜单 Trace > Cur⁃
sor 或者单击顶部工具栏的图标对光标功能进行选取。

当光标移动到每个功能图标上时， 该图标的功能将进行显示， 以便读者进行
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图 5. 14　 光标的各种功能图标

正确选择。
12. 选择 Cursor Max 光标最大值图标， 将会看到光标移动到曲线的最大值

处。 如图 5. 15 所示， 光标数据栏中显示曲线取得最大值时负载电阻值为 47k，
此时电路传输功率最大。

图 5. 15　 光标最大值

13. 当光标置于曲线最大值处， 选择菜单 Plot > Label > Mark 或者单击图

标 或 ， 如图 5. 16 所示， 该点的坐标值 （47k， 531. 915μW）㊀将显示出来。

图 5. 16　 负载电阻变化时其功耗随曲线

　 　 注意：
通过选择菜单 Plot > Label 可以给曲线添加指示箭头和文字注释。

相关理论

如图 5. 17 所示的电阻电路中， 电流计算公式为

I = Vs
Rs + RL （5. 1）

㊀　 坐标值 （47k， 531. 915μW）， 原书为 （47k， 531. 915W）， 出现错误。 ———译者注
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　 图 5. 17　 电阻网络

负载电阻的功耗计算公式为

PL = I2RL （5. 2）
由式 （5. 1） 和式 （5. 2） 整

理得

PL = Vs
Rs + RL

■

■
■

■

■
■

2
RL （5. 3）

PL = Vs2
Rs2 + 2RsRL + RL2RL

（5. 4）
分子分母同时除以 RL， 整

理得

PL = Vs2
Rs2
RL +2Rs + RL

（5. 5）

通过式 （5. 5） 可以得出， 分母最小时负载电阻功率最大。 所以只需对分母

进行微分即可求得输出功率的最大值。 对分母微分得

dPL
dRL = - Rs2

RL2 + 1 （5. 6）

在拐点处：
dPL
dRL =0

所以

0 = - Rs2
RL2 + 1

Rs = RL
（5. 7）

通过微分方程 （5. 6） 可以得到， 在拐点处式 （5. 5） 的分母值最小， 即

Rs = RL 时负载电阻取得最大功率。
练习 2
陷波滤波器

图 5. 18 为本书第 4 章讲解的陷波滤波器电路， 对电路进行交流分析， 电阻

值设置为全局参数变量， 当对电阻参数进行扫描分析时， 观察电路的输出响应。
如图 5. 18 所示， 四个电阻值由全局参数 {Rvalue} 代替， 参数值由 PARAM 元

件进行定义， 如果电路未进行参数扫描分析， 其默认值为 27k。
1. 从 special 库中选择 PARAM 元件放置于原理图中。 然后双击 PARAM 添加

新的全局参数变量， 名称为 Rvalue， 默认值为 27k， 名称和参数值均显示。 具体

步骤如练习 1 所示。
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图 5. 18　 陷波滤波器： 电阻值设置为全局参数， 默认值为 27kΩ

2. 创建交流扫描分析仿真文件， 仿真设置与练习 1 的无源陷波滤波器一致：
对数扫描方式， 起始频率为 10Hz， 结束频率为 10kHz， 每 10 倍频扫描点数为

100 （见图 5. 19）。 最后单击 Apply 按钮对仿真设置进行确认， 并退出仿真设置

窗口。

图 5. 19　 交流扫描分析设置

3. 如图 5. 20 所示， 在 Options 选项栏中选择 Parametric Sweep 参数扫描，
然后对 Global 全局参数 Rvalue 进行 linear 线性方式扫描， 起始值为 24kΩ， 结束

值为 30kΩ， 步进为 1kΩ， 一共需要进行 7 次交流扫描分析。 最后单击 OK 按钮

对仿真设置进行确定。
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图 5. 20　 全局参数变量设置

4. 通过选择菜单 PSpice > Markers > Advanced > dB Magnitude of Voltage 在

输出节点 out 上放置 Vdb电压分贝探针。

5. 单击图标 运行电路仿真。
图 5. 21 所示为陷波滤波器的幅频特性曲线。 从图 5. 21 中可以看出， 当电阻

值 Rvalue 变化时陷波频率随之发生变化。 同时， 陷波处的衰减值即滤波器的 Q
值也随之发生变化。

练习 3
有源陷波滤波器

图 5. 22 所示为有源陷波滤波器电路， 该电路以前面章节的双 T 形陷波器为

基础进行设计。 和无源滤波网络一致， 陷波频率通过电阻和电容值进行设定， Q
值 （陷波处的衰减值） 由电位器 R5 设定， 该值与频率无关。

电位器 R5 具有 SET 调节参数， 利用该参数可以有效地调节 1 脚和 2 脚的阻

值与电位器阻值的比例。 例如， 如果比例设置为 0. 4， 1 脚和 2 脚之间的阻值为

0. 4 × 100k = 40k， 2 脚和 3 脚之间的阻值为 （1 - 0. 4） × 100k = 60k。 所以当 SET
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图 5. 21　 无源陷波滤波器的幅频特性曲线

图 5. 22　 有源陷波滤波器

参数在 0 ～ 1 改变时， 调节点的电阻值可以在全阻值范围变化。
为了使 SET 参数能够在 0 ～ 1 自动扫描， 添加全局参数变量 ratio， 默认值为

0. 5， 即电位器的中间值 （50kΩ）。
该有源陷波滤波器使用 AD648A 运算放大器。 任何型号的运算放大器都可以

使用， 本节实例对特殊元器件的查询进行详细的讲解。

注意：
如果设计人员持有 OrCAD 演示版光盘， 安装好 PSpice 软件， 可以从 eval

元器件库中搜索 uA741 运算放大器。

1. 如图 5. 23 所示， Place Part 放置元件菜单中包含 Search for Part 元器件

搜索功能， 利用该功能可以对运算放大器元器件库进行查询。
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图 5. 23　 元器件查询

注意：
默认情况下， 如图 5. 23 所示的搜索路径指向 Capture. olb 元器件库而不是

PSpice. lib 元器件库。 因此对运算放大器进行搜索时将不会有任何查询结果。 常

见错误： 搜索元器件时忘记更改查询路径。

更改搜索路径方法如下： 单击元器件搜索对话框右边的浏览图标 ， 然后

将打开如图 5. 24 所示的文件浏览窗口， 并且显示 [ install path] > capture >
librayr 文件夹路径， 选择右侧文件夹， 该文件夹下的元器件库列表将会在对话框

左侧详细列出。

图 5. 24　 浏览元器件查询路径

如图 5. 25 所示， 向下滚动右侧文件夹列表， 通过双击选择 PSpice 文件夹。
在对话框左侧可以看到可用的 PSpice 仿真元器件库。 最后单击 OK 按钮对选择
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图 5. 25　 PSpice 仿真库文件夹选择

图 5. 26　 运放 AD648A 属于 opamp 元器件库

进行确定。
2. 对于标准的元器件型号， 不

同厂家均有其各自的数字和字母编

号。 例如， 查询 BC337 晶体管时，
在搜索栏中输入 BC337， 我们只能查

询到一个结果。 但是， 如果在晶体管

名称后面输入通配符号 （∗）， 例如

BC337∗， 就会查询到很多结果。 当

进行元器件搜索时， 由于使用了通配

符而有效地忽略了制造商的额外

字符。
在 Search for Part 元器件搜索对

话栏中输入 AD648∗， 按下回车键或

者点击元器件搜索图标 开始进行

元器件搜索。
如图 5. 26 所示， 在 opamp 元器

件库中只有一种 AD648A 运算放大器

型号。 通过双击 AD648A 把 opamp 元

器件库添加到库文件列表中， 并且从

放置元器件对话框中可以看到该运放

的外形图。
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注意：
如果仿真人员所用 PSpice 为演示版本， 请搜索 uA741∗运算放大器， 因为

演示版软件中没有运放 AD648A。

图 5. 27　 选择运算放大器部件 B

放置元器件菜单中包含运放图

形显示窗口， 在 Packaging 封装对话

栏中显示该运放包含 A、 B 两个分

离组件， 即该运放为双运放。 在图

5. 26 中组件 A 被选中， 而在图 5. 27
中组件 B 被选中。 从图 5. 27 中可以

看出运放的标识和引脚均不同。 如

果两个组件的性能一致称为同质；
相反， 如果两个组件的性能不一致，
例如继电器和线圈， 则称为异质。

在图 5. 27 中有两个图标， 分别

表明 AD648A 具有 PCB 封装和 PSpice 模型， 因此 AD648A 可以用于电路仿真。
当所选元器件用于电路仿真时， PSpice 图标非常重要， 如果所选元器件无该图

标， 则该元器件不能用于电路仿真。
3. 把双运放的部件 A 放置于原理图中， 选定运算放大器， 然后通过 rmb >

Mirror Vertically 或者快捷键 V 对运放进行镜像垂直旋转。 当运放已经连接至电

路图中的时候， 不必删除任何连线， 也可以对其进行镜像和旋转。
4. 选择双运放的部件 B 并且放置于原理图。
5. 选定所有元器件库 （在库文件列表顶部单击鼠标左键并拖动鼠标至库文

件列表底部）， 在元器件栏中输入 pot， 将会在 breakout 元器件库中查询到该元器

件。 放置 pot 于原理图中， 并修改其参数为 100k。 双击 SET 属性， 把其默认值

0. 5 修改为 {ratio}， 修改过程中千万不要忘记大括号。
6. 设定 ratio 为全局参数变量， 默认值为 0. 5。 首先从 special 元器件库中选

择 PARAM 元器件放置于原理图中。
7. 双击 PARAM 元器件， 创建名称为 ratio 的新属性， 默认值为 0. 5， 对其名

称和数值进行显示。 具体步骤如练习 1 所示。
8. 通过菜单选择 Place > Power 放置电源符号， 然后在列表中选择 VCC_

CIRCLE 符号并修改其名称为 VCC， 最后单击 OK 按钮对设置进行确定。 按照上

述步骤放置 VSS 符号。
9. 按照图 5. 22 所示放置其他元器件， 并将各元器件进行正确连接。
10. 参数扫描分析与交流分析同时运行。 在本实例中， 对电位器的比例值

ratio 进行参数扫描分析， 起始值为 0. 1， 结束值为 0. 9， 步长为 0. 1。 首先按照
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无源陷波滤波器电路的设置方式对该电路进行交流扫描分析设置， 起始频率为

10Hz， 结束频率为 10kHz， 对数扫描方式， 每 10 倍频 100 点 （见图 5. 28）， 然

后单击 apply 按钮对仿真设置进行确定， 但是不要退出仿真设置对话框。

图 5. 28　 交流扫描分析设置

11. 在 Options 选项栏中选择 Parametric Sweep。 扫描变量选择 Global parame⁃
ter 全局参数变量， 名称为 ratio。 扫描方式为 Iinear 线性扫描， 起始值为 0. 1， 结

束值为 0. 9， 步长为 0. 1 （见图 5. 29）。 然后单击 OK 按钮对仿真设置进行确定，
并退出仿真设置对话框。

图 5. 29　 全局参数变量设置
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12. 通过菜单选择 PSpice >Markers > Advanced > dB Magnitude of Volt⁃
age， 在 ‘out’ 输出节点放置 Vdb电压分贝探针。

13. 单击图标 运行电路仿真。
仿真结果如图 5. 30 所示， 当对 R5 的比例值 ratio 进行参数扫描分析时， 滤

波器的 Q 值 （陷波频率处的衰减值） 会发生改变， 但是陷波频率值保持恒定。

图 5. 30　 有源陷波滤波器的幅频特性曲线



第 6 章
激励源编辑器

激励源编辑器为图形化编辑工具， 帮助用户定义用于瞬态仿真分析的模拟和

数字信号源。 如图 6. 1 所示， 在 sourcestm 元件库中包含三种信号源元件， 其中

每一种信号源都可以在激励源编辑器中由用户根据仿真要求进行自定义。

图 6. 1　 激励源编辑器， 用于瞬态仿真中的模拟和数字信号源的设置

当第一次从 sourcestm 元件库中选择信号源时， 其配置属性 implementation 显

示在原理图中。 该属性与激励源编辑器中所设置的激励源的名称一致。 对激励源

进行编辑时， 可以在原理图中直接输入激励源的名称， 也可以在激励源编辑器中

确定其名称。
首先选定激励源， 然后选择 rmb > Edit PSpice Stimulus 对激励源编辑器进

行启动。
当激励源编辑器启动后， 如图 6. 2 所示的 New Stimulus 新激励源窗口将会

出现。 设置时应该注意， 在 16. 3 版本中， 激励源文件的名称与 PSpice 仿真设置

文件的名称一致， 例如， 本例中为 transient. stl。 在以前版本中， 激励源文件名称

与项目名称一致。
在新激励源设置窗口中， 可以定义激励源类型为模拟或者数字， 如果在原理

图中未对激励源名称进行设定， 可以在该窗口对其进行命名。
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图 6. 2　 启动激励源编辑器

6. 1　 瞬态激励源设置

6. 1. 1　 EXP 指数激励源

如图 6. 3 和图 6. 4 所示为两种可能的指数波形， 该波形可以通过电压源 VS⁃
TIM 或者电流源 ISTIM 分别进行设置， 设置为电压源或电流源。

两指数波形在特定延迟时间 （td1） 后启动， 然后在电压 V1 和 V2 之间， 以

tc1 为时间常数按照指数形式上升或者下降至时间 td2， 时间 td2 之后， 波形以

tc2 为时间常数按照指数形式下降或上升。
例如， 在图 6. 3 中， 从 0 ～ td1 （10μs） 时间内波形电压值为 V1 （0V） 保持

恒定， 然后电压按照指数形式增加， 时间常数为 tc1 （10μs）， 一直增加到 V2
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图 6. 3　 指数上升电压波形

图 6. 4　 指数下降电压波形

（10V）。 波形上升时间为 td2 ～ td1， 为 30μs （40 - 10μs）， 然后波形按照指数形

式下降， 时间常数为 tc2 （5μs）， 一直下降到电压 V1。
如图 6. 5 所示为指数电压波形图 6. 3 的设置对话框， 其中：
V1———零时刻初始电压值；
V2———电压上升或下降值；
td1———指数上升 （或下降） 的启动时间 （延迟）；
tc1———波形上升 （或下降） 的时间常数；
td2———指数下降 （或上升） 的启动时间 （延迟）；
tc2———波形下降 （或上升） 的时间常数。
在图 6. 3 中， V1 = 0V， V2 = 10V， td1 = 10μs， tc1 = 5μs， td2 = 40μs，

tc2 = 5μs。
在图 6. 4 中， V1 = 10V， V2 = 0V， td1 = 10μs， tc1 = 5μs， td2 = 40μs，

tc2 = 5μs。
指数电压按照如下公式进行计算：
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图 6. 5　 指数激励源属性设置

v（ t） = （V2 - V1） 1 - e - time
time constant（ ）

所以在 0 ～ td1 时间内电压为常数：
v（ t） = V1

在 td1 ～ td2 时间内电压为计算公式为

v（ t） = V1 + （V2 - V1） 1 - e - （time - td1）
tc1（ ）

从 td2 至截止时间， 电压计算公式为

v（ t） = V1 + （V2 - V1） （1 - e - （time - td1）
tc1 ） - （1 - e - （time - td2）

tc2 ）[ ]

6. 1. 2　 Pulse 脉冲激励源

如图 6. 6 所示为脉冲电压波形各设置参数含义， 其中：
V1———低电压；
V2———高电压；
TD———脉冲开始之前的延时时间；
TR———上升时间， 单位 s， 定义为电压从 V1 上升至 V2 的时间差；
TF———下降时间， 单位 s， 定义为电压从 V2 下降至 V1 的时间差；
PW———脉冲宽度；
PER———脉冲周期， 即脉冲频率。
同样地， 如图 6. 7 所示， 可以使用 ISTIM 激励源定义脉冲电流源。
当第一次在原理图中放置 VSTIM、 ISTIM 或者 DigSTIM 激励源时， 其属性名

称和数值都会显示出来。 其实只需要对其 Name 名称进行显示即可。 如图 6. 8 所

示， 双击 Implementation =将打开显示属性对话框， 通过选择 Value Only 就可
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图 6. 6　 脉冲波形设置

图 6. 7　 使用 ISTIM 激励源定义脉冲电流源

以只显示该属性的 Value 值， 即激励源的 Name 名称。
如图 6. 9 所示， 使用 ISTIM 元件定义电流激励源， 通过显示属性设置， 只显

示其名称 Ipulse。 与前面操作一致， 通过选择 rmb > Stimulus Editor 启动激励

源编辑器， 然后选择 PULSE 脉冲作为 New Stimulus 新激励源类型。 使用 ISTIM
元件定义脉冲电流源， 其具体属性设置如图 6. 10 所示。 图 6. 11 为脉冲电流源波

形图。

6. 1. 3　 VPWL 分段线性激励源

分段线性信号源 （PWL） 可以用于绘制实际的电压或电流波形。 首先定义

时间和电压 （或电流） 坐标轴， 然后使用光标绘制波形。 本章结尾通过实例对

分段线性信号源的使用进行具体讲解。
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图 6. 8　 设置 Implementation = invisible

图 6. 9　 ISTIM 电流激励源， 只显示名称 Ipulse 图 6. 10　 脉冲电流源属性参数设置

图 6. 11　 按照图 6. 7 中属性参数设置的脉冲电流源波形图
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6. 1. 4　 SIN 正弦波激励源

如图 6. 12 所示为正弦波属性设置对话框， 其完整定义包括正弦波阻尼系数、
相位角和偏置值。 Offset value 为 0 时刻电压或者电流的偏置值； Amplitude 为最大

电压或电流幅值； Frequency （Hz） 为波形每秒钟的周期数即频率； Time delay
（s） 为启动延迟时间； Damping factor （1 / s） 为波形阻尼因数； Phase angle （°）
为波形初始相位角。 如图 6. 13 所示为频率调制正弦波设置。

图 6. 12　 正弦波属性设置对话框 图 6. 13　 频率调制正弦波设置

6. 1. 5　 SSFM 单频调频激励源

如图 6. 14 所示为正弦波频率调制波形， 通过对载波频率进行调制以改变其

信号波形。 正弦波公式如下：

图 6. 14　 单频调频波形
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v（ t） = Voff + Vampl × sin[2πfc t + （mod × sin（2πfm t㊀））]
其中， Voff为偏置电压； Vampl为正弦波电压最大值； mod 为调制系数； fc 为载波

频率； fm 为调制频率。

6. 2　 自定义电压源

对电路进行瞬态分析时， 利用屏幕图形显示窗口可以获得时间 -电压波形数

据， 以作为激励源进行使用。 在屏幕图形显示窗口中通过选择菜单 File > Ex⁃
port， 可以得到如图 6. 15 所示的数据选项。

也可以利用另一种方法创建时间 -电压文本文件。 首先在屏幕图形显示窗口

中选择曲线名称， 然后通过菜单选择 copy 对波形数据进行复制， 最后把数据粘

贴到文本文件中。

图 6. 15　 导出时间 -电压数据

6. 3　 仿真设置

在 16. 3 之前版本中， 当启动激励源编辑器时， 激励源文件名称与项目名称

一致， 例如， 所建项目名称为 stimulus， 则创建的激励源的名称同样为 stimu⁃
lus. stl。 所有创建的激励源都保存在 stimulus. stl 文件中， 当对不同的激励源进行

调用时， 只需改变激励源的名称即可， 例如 VSTIM、 ISTIM 或 DigSTIM。
从 16. 3 版本开始， 激励源文件与当前激活状态的仿真配置文件相关联， 可

以通过仿真配置文件对其进行访问。 在以前版本中， 激励源文件、 库文件和包含

文件均有独立的选项卡以供选择。
如图 6. 23 所示， 仿真人员可以通过配置文件对激励源进行查看。 如果未看

到激励源文件， 可以通过文件名浏览对其进行查找， 然后把激励源文件添加到配

置文件中。 添加激励源文件时需要注意如下选项：
• Add as Global： 添加为全局文件， 所有仿真项目都可以使用

• Add to Design： 添加到本设计中， 只有本仿真项目可以使用

如果所建立的标准激励源用来对所有电路进行测试， 那么， 把该激励源添加

㊀　 原书中 t 为 time， 出现错误。 ———译者注
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为全局文件将会非常实用。 可以添加多个激励源文件， 通过点击向上和向下箭头

对其顺序进行调整。 如果需要对激励源文件进行删除， 首先通过单击鼠标左键选

定需要删除的激励源文件， 然后点击红色十字图标对其进行删除。

6. 4　 本章练习

　 　 注意：
与以前版本相比， 16. 3 版本及以后版本有了很大变化。 当第一次创建新项

目时， PSpice 会自动创建偏置点仿真配置文件， 可以通过选择 PSpice Resource
> Simulation Profiles 对其进行查看。 为了保持版本之间的兼容性， 可在项目

管理器中删除偏置点仿真配置文件。

图 6. 16　 项目管理器中的偏置点仿真文件

　 　 1. 创建名称为 stimulus 的仿真项目。
2. 如图 6. 16 所示， 在项目管理器中， 通

过选择 PSpice Resources > Simulation Pro⁃
files 对项目文件进行展开， 然后删除 SCHE⁃
MATIC1 -Bias 文件。

3. 绘制如图 6. 17 所示的电路图。 信号

源 V1 为 VSTIM， 选自 Sourcestm 元件库。
4. 鼠标左键选中 VSTIM 信号源， 然后

通过右键 rmb > Edit PSpice Stimulus 对信

号源进行编辑。 如图 6. 18 所示， 在 New
Stimulus 新建激励源窗口中对信号源命名为

sin100Hz， 选 择 SIN 正 弦 波 作 为 信 号 源

类型。

图 6. 17　 利用 VSTIM 生成 100Hz 正弦波信号源



第 6 章　 激励源编辑器 87　　　

图 6. 18　 新建正弦波信号源

图 6. 19　 创建 100Hz 正弦波信号源

5. 创建 100Hz 正弦波信号源， 直流偏置

为 0， 振幅为 1V， 其他为默认值 0， 具体设置

如图 6. 19 所示。 单击 OK 按钮对设置进行确

认并保存， 根据提示更新原理图， 退出激励

源编辑器。
6. 在 Capture 中， 信号源的实现名称也显

示在 V1 上。 如图 6. 20 所示， 双击 Implemen⁃
tation = sin100Hz 然后选择 Value Only， 这样

就能仅显示信号源的名称， 更加简洁， 如图

6. 21 所示。
7. 选择菜单 PSpice > New Simulation

Profile 创建 PSpice 仿真设置文件， 命名为

transient。 如图 6. 22 所示， 在分析类型下拉

菜单中选择 Time Domain （Transient） 时域分析， 运行时间为 20ms。 单击 Ap⁃
ply 按钮对仿真设置进行确认， 但是不要退出设置窗口。
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图 6. 20　 设置信号源名称显示

图 6. 21　 只显示信号源名称

图 6. 22　 仿真设置
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　 　 8. 如图 6. 23 所示， 在设置对话框中选择 Configuration Files > Category >
Stimulus， 将会看到激励源文件 stimulus. stl 已经加入到配置文件列表中。

选中激励源文件 stimulus. stl， 然后单击 Edit 按钮启动激励源编辑器， 在编

辑器中可以详细地查看激励源 sin100Hz 的具体设置。 该方法为查看激励源的快

速方法。 最后单击 OK 按钮退出仿真设置。

图 6. 23　 仿真激励源文件显示配置

9. 如图 6. 24 所示， 在节点 out 处放置电压探针， 然后选择菜单 PSpice >
Run 运行电路仿真， 从仿真结果可以得到电阻两端为正弦电压波形。

图 6. 24　 放置电压探针
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　 　 注意：
如果在屏幕图形显示窗口中输出为平直曲线， 很可能由于没有删除默认配

置激励源文件 bias. stl。 此时可以查看本章练习开始部分的设置。 激励源编辑器

把 bias. stl 默认为当前仿真配置文件。 如果在图 6. 23 中未发现激励源文件， 可

以通过 Browse 浏览按钮对偏置文件夹进行选择， 然后把激励源文件添加到设

计中。

10. 如图 6. 25 所示， 在项目管理器中， 选择文件夹 PSpice > Resources >
Stimulus Files 将会看到 transient. stl 激励源文件。 可以通过双击该文件打开激励

源编辑器对其进行查看。

图 6. 25　 查看 transient. stl 激励源文件

图 6. 26　 Vpulse 脉冲源设置

11. 在 Capture 中选中 VSTIM 并启动

激励源编辑器。 在激励源编辑器中将会看

到前面设置的 SIN 正弦波信号源。 通过单

击 Cancel 按钮对其进行取消。
12. 如图 6. 26 所示， 选择 Stimulus

> New 创建脉冲信号源， 名称为 Vpulse，
初始值为 0V， 幅值为 1V， 无初始延迟，
上升时间为 500μs， 下降时间为 1ms， 脉

冲宽度为 2ms， 周期为 10ms。 单击 OK 按

钮对激励源进行保存， 但是不要根据提示

对原理图进行更新。 点击 Exit 按钮退出激

励源编辑器。
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　 　 注意：
当对激励源的每项属性进行数值设置时， 可以通过键盘上的 TAB 键从上到

下对属性框进行选择。

　 　 注意：
在 Capture 中， 如果已经对激励源命名为 sin100Hz， 则不能通过激励源编辑

器对其名称进行修改。 在早期软件版本中， 如果对原理图进行更新， 光标将会

变成一个沙漏形， 停在那里不动。 如果确实需要对原理图进行更新， 切换到

Capture 窗口， 然后再进行更新， 此时将会看到图 6. 27 警示对话框。 单击 OK 按

钮进行确定。

图 6. 27　 更改激励源名称警告

图 6. 28　 使用 Vpulse 激励源

13. 如图 6. 28 所示， 在 Capture
中， 双击激励源名称 sin100Hz， 将其

更改为 Vpulse。
14. 通过选择菜单 PSpice > Run

或者单击蓝色运行图标 对电路进

行仿真分析。
15. 测试电阻两端是否为脉冲电

压波形。
16. 在 Capture 中， 选中 VSTIM，

然后通过 rmb > Edit Stimulus Editor 对其进行编辑。 在激励源编辑器中， 早期

设置的 PULSE 信号源属性将会显示出来。 点击 Cancel 按钮对其设置进行取消。
17. 通过选择 Stimulus > New 创建新激励源。 对其命名为 Vin， 信号类型为

PWL （分段线性曲线）。

　 　 注意：
信号源设置过程中可能会遇到坐标轴更改的提示问题。
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　 　 18. 从顶部工具栏选择菜单 Plot > Axis Setting 对坐标轴进行设置。 如图

6. 29 所示， 对绘制图形的分辨率进行设置。

图 6. 29　 坐标轴设置

19. 在图形窗口将会出现笔状光标。 绘制如图 6. 30 所示的近似于分段线性

电压波形。 软件自动选择图形第一点， 该点坐标为 （0， 0）。 只要把三个峰值坐

标点定义精确， 其他各点的准确度并不十分重要。 该激励源将在第 7 章瞬态仿真

分析中使用。 按 Escape 键退出绘图模式。

图 6. 30　 分段线性电压波形
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20. 如果需要删除或者移动某点， 按 Escape 键退出绘图模式， 将光标移动到

该点， 此时所选中坐标点将会变成红色， 然后对其进行删除或者移动。 修改完成

后， 选择菜单 Edit > Add 或者单击图标 或 重新返回绘图模式。

　 　 注意：
在 16. 3 以前版本中， 用户只能随时间增加放置坐标点， 而不能倒退。 如果

需要删除或者移动某坐标点时， 按 Escape 退出绘图模式， 把光标放置于某点，
该点将会变成红色， 然后对其进行删除或者移动。

21. 保存激励源文件并退出激励源编辑器， 但是不要对原理图进行更新。
22. 把激励源名称由 Vpulse 更改为 Vin， 然后重新对电路进行仿真， 电阻两

端电压波形将变为分段线性波形。

　 　 注意：
Vin 激励源将在第 7 章进行使用。



第 7 章
瞬 态 分 析

瞬态分析用于计算电路在用户设定时间内的响应。 瞬态分析的准确度取决于

软件内部所设置的时间步长的大小， 该步长与仿真开始时间以及仿真结束时间共

同决定了电路的仿真运行时间。 然而， 根据第 2 章内容， 在时间 t = 0s 时刻， 电

路首先进行直流偏置工作点分析， 以确定其各点的直流工作点状态。 对于每个时

间步长， 节点电压和电流值都进行计算， 并且与前一时刻的数值进行比较。 只有

当两值之差优于所设定容差的时候， 电路才会继续按照步长进行仿真计算。 在电

路仿真过程中， 时间步长动态调整， 以满足仿真容差要求。
例如， 对于缓慢变化的信号， 时间步长将会增加， 但是不会降低计算准确

度。 然而对于快速变化的信号， 例如上升沿非常陡峭的脉冲波形， 时间步长就会

减小， 这样才能够满足仿真准确度要求。 电路进行仿真分析时， 软件内部的最大

仿真步长由用户设定。
如果通过减小仿真步长， 计算结果仍然不能满足准确度要求， 仿真分析将不

会收敛， 在仿真报告中将会输出仿真不收敛信息。 第 8 章将对收敛问题以及解决

方案进行详细的讨论。
在某些电路中无法得到直流工作点数值， 例如振荡器电路。 对于这些电路，

在仿真分析设置时可以通过选择跳过初始直流静态工作分析， 以保证电路仿真分

析能够正常运行。 如果为电路增加初始值设置， 在瞬态分析时， 电路将把所设置

的初始值设定为直流偏置工作点数值。

7. 1　 仿真设置

图 7. 1 为 PSpice 瞬态 （时域） 仿真分析设置对话框。 在本例中仿真时间为

5μs。 Start saving data after 为开始保存数据的时间点设置， 在该时间点之后的数

据才进行保存， 以便 Probe 进行图像显示时使用， 使用该设置的主要目的为减少

数据量。
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图 7. 1　 瞬态分析仿真设置对话框

Maximum step size： 定义软件内部最大仿真步长， 该值取决于 Run to time
仿真结束时间， 通常设置为仿真结束时间的 1 / 50。

Skip the initial transient bias point calculation： 瞬态分析时是否跳过初始偏

置点计算选项， 如果选定该选项， 电路在进行瞬态分析时将不再计算偏置点

数值。

7. 2　 SCHEDULING 设置

Scheduling 选项允许用户在瞬态分析过程中动态地修改仿真步长。 例如， 对

某段时间进行高准确度仿真时就需要小步长， 而对于准确度要求不高的时段就可

以使用大步长。 同样 Scheduling 也可以用于其他与运行时间相关的仿真设置参数

中， 例如 RELTOL、 ABSTOL、 VNTOL、 GMIN 和 ITL， 可以通过菜单 PSpice >
Simulation Profile > Options 查看上述参数。 用户可以按照如下 Scheduling 命令

格式对其数值进行替换：
{SCHEDULE （t1， v1， t2， v2. tn， vn）}
在设置时一定要注意， t1 通常设置为 0。
例如， 为了使仿真更加高效， 需要每间隔 1ms 把相对准确度 RELTOL 数值

从 0. 001%修改为至 0. 1% ， 具体设置格式如下：
{schedule （0， 0， 1m， 0. 1， 2m， 0. 001， 3m， 0. 1， 4m， 0. 001）}
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第 8 章将对仿真设置进行更详细的讨论。

7. 3　 测试点设置

16. 2 版本对测试点进行了介绍， 允许用户能够有效地标记和保存测试点的

瞬态仿真分析状态， 并且根据测试点数据重新对电路进行瞬态仿真。 允许用户根

据所选仿真周期对电路进行仿真分析。 如果电路进行仿真时出现收敛问题， 可以

在出现仿真错误之前定义测试点， 这样就可以只对测试点之前进行仿真， 而不必

运行全部仿真分析。
测试点设置只能用于瞬态仿真分析， 如图 7. 2 所示， 首先选择菜单 Analysis

> Options， 然后在对话框中选择 Save Check Points 和 Restart Simulation。 测试

点通过指定测试点之间的时间间隔进行定义。 仿真时间间隔为秒， 实际的时间间

隔通常为分钟 （默认值） 或小时。 按照设定时间点对测试点数据进行创建。

图 7. 2　 保存测试点数值

对已经保存测试点的电路进行重新仿真之前， 用户可对其元件值、 参数值、
仿真设置选项、 测试点重启和数据保存选项进行设置更改。 如图 7. 3 所示为 Re⁃
start Simulation 重新仿真选项设置。

所保存的测试点数据为仿真时间， 以秒 （s） 为单位， 例如测试点数据文件

内容为重新仿真起始时间设定为 4ms。 接下来电路将进行瞬态分析， 并且从 4ms
开始保存数据。
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图 7. 3　 使用保存的测试点数据重新对电路进行仿真

7. 4　 利用文本文件定义时间 -电压形式的激励源

第 6 章对分段线性激励源进行了介绍， 该激励源利用图形化电压波形对电路

进行输入。 输入波形以时间 -电压的形式进行坐标值定义， 然后通过属性编辑器

进行输入或者通过外部文本文件进行读取。

图 7. 4　 分段线性信号源

a） 电压源　 b） 电流源

如图 7. 4 所示为分段线性电压源 VPWL 和电流源

IPWL， 图 7. 5 为分段线性电压源的时间和电压对应数

值。 通过默认情况下， VPWL 和 IPWL 的属性编辑器中

显示八组数据， 但是如图 7. 5 所示， 属性编辑器中可

以添加更多的时间 - 电压数据。 如果时间 - 电压的数

据量非常大， 可以使用文本文件对其进行输入， 这样

将会更加高效并且易于操作。
图 7. 6 所示为引自某文本文件的 VPWL_ FILE 元

件， 图 7. 7 所示为该元件的部分时间 -电压参考数据对。 例如， 在 1ms 时电压为

0. 2055V， 在 2ms 时电压为 0. 3273V， 以此类推。 PSpice 经常忽略语句的第一行，
所以利用第一行语句功能进行注释是一种非常实用的方法。

当引用如同 Vin. txt 类似的文本文件时， 需要指明其文件的详细地址。 可以

使用绝对地址以指明该文件的直接路径， 或者使用相对寻址指定该文件相对于该

项目的位置。
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图 7. 5　 VPWL 和 IPWL， 属性编辑器中的时间 -电压数据

图 7. 6　 分段线性元件 VPWL_ FILE 图 7. 7　 激励源 Vin 对应的时间 -电压数据点

如图 7. 8 所示， 通过层次结果形式表示出 Vin. txt 允许放置的不同文件夹

位置。
例如， 如果将 Vin. txt 文件与原理图放置在同一文件夹中， 可以在 VPWL_

FILE 元件的 < FILE >属性中输入 . . \ Vin. txt 作为其文件名。 例如：
Project Folder >PSpiceFiles >schematics >simulation profiles

. . . \. . \Vin. txt. . \Vin. txt　 Vin. txt
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图 7. 8　 调用 VPWL_FILE 建立的时间 -电压文本文件 Vin. txt

还可以为文本文件提供绝对路径。 例如， 放置激励源的文件夹名称为 stimu⁃
lus， 可以在 VPWL_FILE 元件的 < FILE > 属性框中键入 C： \ stimulus \ Vin. txt 作为

名称。
在 source 库中还有其他 VPWL 和 IPWL 元件， 利用这些元件可以生成多周期

或者重复周期的信号波形。 PSpice 软件的 source 库中的 file 元件列表如下：
VPWL_F_RE_FOREVER

VPWL_F_RE_N_TIMES

VPWL_RE_FOREVER

VPWL_RE_N_TIMES

IPWL_F_RE_FOREVER

IPWL_F_RE_N_TIMES

IPWL_RE_FOREVER

IPWL_RE_N_TIMES

下面结合练习对上述信号源的实际应用进行详细讲解。

7. 5　 本章练习

练习 1
本练习主要演示最大时间步长对仿真准确度的影响， 并且介绍 Scheduling 命

令的具体使用。
1. 绘制如图 7. 9 所示电路， 其中信号源 VSIN 选自 source 库， 然后与负载电

阻 R1 相连接。

图 7. 9　 正弦波电压源与负载电阻相连接
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2. 创建名称为 transient 的仿真文件， Analysis type 仿真类型设置为 Time
Domain （Transient） 时域分析， Run to time 运行时间设置为 10ms， 正好显示

10 个正弦周期波形， 具体设置如图 7. 10 所示。

图 7. 10　 瞬态分析仿真设置

在节点 out 放置电压探针， 仿真波形如图 7. 11 所示， 从图 7. 11 中可以看出

波形分辨率比较低。

图 7. 11　 分辨率低时正弦波波形发生失真

3. 在 Probe 图形显示界面选择工具栏 Tools > Options 中的 Mark Data
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Points 选项或者点击图标 将会清楚地看到组成正弦波的各个数据点。
4. 在仿真设置文件中， 通过使用 schedule 命令， 可以对设定时间点的仿真

步长进行缩小。 在Maximum step size 最大步长设置对话框中输入 schedule 命令，
但是由于输入框比较小， 所以建议首先在类似记事本的文本编辑器中对 schedule
命令进行编辑， 然后再把编辑好的命令复制并粘贴到命令框中， 例如：

{schedule （0， 0， 2m， 0. 05m， 4m， 0. 01m， 6m， 0. 005m， 8m，

0. 001m）}
5. 运行电路仿真。 保持 Mark Data Points 处于选定状态， 从图 7. 12 中可以

看出， 随着仿真步长的减小， 波形的分辨率逐渐提高。

图 7. 12　 仿真最大步长减小时的正弦波波形变化

练习 2
如图 7. 13 所示为峰值检波电路， 其中输入信号源 Vin 由 Sourcstm 库中的激

励源编辑器生成， 或者为 file 文件输入的时间 - 电压波形。 下面对以上两种方式

进行详细讲解。
1. 创建名称为 Peak Detector 的仿真项目， 然后绘制如图 7. 13 所示的电路

图。 如果用户所用仿真软件为演示版， 运算放大器型号选择 uA741。
2. 将文件夹 SCHEMATIC1 重命名为 Peak Detector。
3. 从 special 元件库中选择 IC1， 对电容 C1 的初始电压值 （ IC） 进行设置，

以保证在 t = 0 时刻电容两端的电压为 0V ， 或者， 双击电容 C1， 在 Proper⁃

ty Editor 属性编辑对话框的 IC 设置栏中输入 0， 如图 7. 14 所示。 上述设置能够

保证在 t = 0 时刻， 电容器两端的电压为 0V。 如果电容需要更换， 切记对更换后

的电容进行初始值设置。 通常情况下 IC1 显示在原理图中， 以便对其初始值更加

明了。
4. 创建名称为 transient 的仿真设置文件， 运行时间设置为 10ms， 然后关闭

仿真设置窗口。 下面通过两种方法对峰值检测电路的输入信号源 Vin 的电压波形
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图 7. 13　 峰值检波电路

图 7. 14　 将电容的初始电压设置为 0V

进行设置。
使用激励源编辑器生成的图形波形

5. 使用第 6 章已经定义的 Vin 信号源作为输入激励源， 在仿真设置窗口中

选择 Configuration Files 文件配置选项， 然后在 Category 目录中选择 Stimulus
激励源， 最后通过 Browse 浏览按钮对激励源文件 stimulus. stl 进行选定。 如图

7. 15 所示， 单击 Add to Design 把所选激励源添加到设计中。 第 6 章已经对激励

源的具体添加步骤进行了详细的讲解。
6. 选定激励源名称， 然后单击 Edit 可以对激励源进行编辑。 接下来软件会

自动启动激励源编辑器， 并显示 Vin 电压波形。 设置完成后关闭仿真设置文件。
7. 转到设置步骤 12。
使用时间 -电压 FILE 文件描述输入波形

8. 如图 7. 16 所示， 在类似记事本的文本编辑器中输入时间 - 电压数据点。
默认情况下， 仿真程序会忽略文本文件的第一行内容， 所以第一行不要输入具体

数据。 然而， 可以在第一行开头使用星号∗， 对文本文件添加说明或者对数据内

容进行注释。 仿真器将忽视开头为星号∗的字符串。
将文件命名为 Vin， 选择 txt 文本格式， 并且将文件保存在该项目的仿真文
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图 7. 15　 在仿真设置中添加激励源文件 图 7. 16　 输入电压波形 Vin
的时间 -电压对应数据

件夹中， 如图 7. 17 所示， Peak Detector > peak detector - PSpiceFiles。 确保文

件的扩展名为 . txt， 即 Vin. txt。
9. 从 source 库中选择 VPWL_FILE 信号源， 将其名称 < FILE > 按照图 7. 18

所示 . . \ . . \Vin. txt 进行重命名。

图 7. 17　 将 Vin 文本文件放置在仿真文件夹中 图 7. 18　 添加 VPWL_FILE
信号源

10. 如图 7. 19 所示为峰值检测电路。
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11. 转到设置步骤 12。
12. 将电压探针放置于 in、 out 输入和输出节点， 然后对电路运行瞬态仿真

分析。 如图 7. 20 所示为输入电压 Vin 随时间变化时峰值检测电路的输出响应。
生成 Vin 周期信号

13. 删除 VPWL_FILE 信号源， 然后从 source 库中选择 VPWL_F_RE_FOREV⁃
ER 周期信号源。 按照第 9 步设置方式， 双击 < FILE > ， 然后输入 . . \ . .
\Vin. txt。

图 7. 19　 文本文件作为激励源的峰值检测电路

图 7. 20　 峰值检测电路输入输出电压随时间变化波形

14. 配置 PSpice 设置文件， 仿真时间增加到 50ms， 运行仿真程序。 仿真结

果如图 7. 21 所示， 其中 Vin 为周期信号。
15. 对 VPWL_F_RE_N_TIMES 信号源进行研究。



第 7 章　 瞬 态 分 析 105　　

图 7. 21　 输入电压信号 Vin 为周期模型



第 8 章
仿真收敛问题和错误信息

PSpice 软件使用 Newton - Raphson 迭代法求解非线性电路方程的节点电压和

电流。 该算法利用初始 “估测” 值对电路进行反复迭代计算， 最终电压值和电

流值收敛到一个恒定值。 正如第 7 章所讲， 对于每个时间步进， 软件都会对节点

电压和电流值进行计算， 并且与前一个时间步进的直流计算值进行比较。 只有当

相邻两个直流差值符合规定的容差时， 软件才会按照下一个内部时间步长继续对

电路进行分析计算。 在对电路的仿真计算过程中， 时间步长会根据实际计算值进

行动态调整， 直到满足设置容差。 然而， 如果无论如何调整仿真步长都不能满足

设置容差时， PSpice 将会输出报告： 由于收敛问题， 仿真不能继续进行。 当迭代

过程中时间步长改变得太小时电路也不能继续进行仿真。 当电路中出现快速变化

的信号， 例如上升沿非常快的脉冲信号， 此时电路也有可能出现不收敛问题。
当电路设计不合理、 参数缺失或者数值错误时也会出现电路不收敛现象。 本

章将对主要的常见错误进行详细的讨论。

8. 1　 常见错误信息

Error -Node <name > is floating

上述语句表明电路中缺少零伏节点 0。 具体实例参考第 2 章练习 1 和第 3 章

练习 1。
Error -Missing DC path to ground

缺少对地直流通路。 在该节点与 0 节点或者接地路径之间增加大阻值电阻。
具体实例参考第 3 章练习 1。

Error -Less than two connections at node <name >

Capture 元件无对应 PSpice 模型， 所以该元件不能用于 PSpice 仿真分析。 当

某个网络点悬空时， 也会输出上述错误信息。
Error -Voltage source or inductor loop
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电压源模型为理想元件， 无内部串联电阻， 因此， 当两个电压源并联时， 电

流将会无限大， 从而超越最大电流限制值。 电压和电流的极限值限定为 ± 1e10V
和 ± 1e10A。

电感本质上为时变电压源， 当电感与电压源或者另一个电感并联的时候也会

出现上述错误。 在 PSpice 元件库中， 电感为理想模型， 其绕组阻抗为零。

8. 2　 建立静态工作点

当对电路进行瞬态分析和直流扫描分析的时候， 首先需要对电路进行偏置点

分析。 然而， 当 PSpice 无法计算出电路各节点的偏置点数值时， 电源电压值将

会从 100%向零降低， 非线性电路将会被有效地线性化， 从而提高其偏置点计算

成功的几率。

图 8. 1　 PSpice 输出信息

当对电路进行瞬态仿真分析时，
PSpice 启动， 仿真过程将会出现在仿真

状态窗口和输出窗口中。 如图 8. 1 所示

为输出窗口中的仿真报告： 偏置点计算

完成， 瞬态分析起始和结束信息以及仿

真结束等信息。
当电路进行工作点分析、 瞬态分析、

直流扫描分析和交流分析的时候， 仿真人员可以通过输出窗口中的显示信息判断

电路仿真是否收敛。

8. 3　 收敛问题

如果电路在仿真过程中出现收敛问题， PSpice 仿真将会暂停， 并且会出现如

图 8. 2 所示的仿真运行设置对话窗口。 此时用户可以根据电路特性对仿真参数进

行修改， 然后重新进行仿真分析。
输出文件内容主要为最后一次仿真计算的电压值以及仿真不收敛元器件， 通

过以上信息， 可以判断电路不收敛的问题根源。
对于收敛问题， 至今仍然没有非常明确的解决办法。 我们所需要做的就是尽

量把问题具体定位， 然后根据电路特性进行具体解决。 对于大规模电路， 有条不

紊地对电路进行分解， 然后对各个局部电路进行仿真分析。 对于层次电路， 首先

对每个模块进行独立仿真分析， 这样对解决收敛问题非常有益。 对大规模电路进

行仿真分析时， 首先对每个模块成功地进行仿真分析， 然后再把各模块顺次组合

成为完整设计。 第 20 章将对分层设计进行详细讲解。
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图 8. 2　 PSpice 运行设置

对于非常复杂的大规模电路， 可以利用模拟行为模型 （ABMs） 对各个模块

进行代替。 ABMs 行为模型主要利用数学表达式或数组的形式对元器件或者电路

行为进行模拟。 利用该模型进行仿真分析时， 仿真速度非常迅速， 可更加快捷的

对不收敛电路进行定位， 然后对其进行替换和消除。 然而， 如果 ABMs 模型使用

不当， 也可能会导致收敛问题出现。 特别是数学表达式中包含分母变量时， 在一

定的电路条件下， 分母可能等于零， 从而超出 PSpice 的极限值 ± 1e10V 和

± 1e10A。
仅由几个元器件构成的小电路也可能引起收敛问题； 对于非常普通的二极

管， 如果建模时未包含串联电阻， 其电流和电压值也可能会超出 PSpice 的限制

值 ± 1e10 V 和 ± 1e10A。
理想情况下， 半导体厂商提供的元器件模型非常齐全， 并且已经通过仿真测

试， 不应该成为收敛问题的主要原因。 唯一可能出现的问题就是， 某些半导体模

型由子电路形成， 特别是功率 MOSFETs 器件， 这样就很可能出现收敛问题。

8. 4　 仿真设置

如图 8. 3 所示， 在仿真设置对话框中， 通过选择 Options 选项对仿真收敛进

行具体设置。
在 PSpice 算法中， 电压和电流根据其先前值进行计算， 对于节点电压值，

其收敛条件如下：
| v（n - 1） - v（n） | > RELTOL∗v（n） + VNTOL （8. 1）

对于电流值， 其收敛条件如下：
| i（n - 1） - i（n） | > RELTOL∗i（n） + ABSTOL （8. 2）
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其中， RELTOL 为相对误差； VNTOL 和 ABSTOL 分别为电压和电流的绝对

误差。 相对误差 RELTOL 的默认值为 0. 001， 即准确度为 0. 1% 。 只有当连续电

压和连续电流值满足相对准确度设置值时， 电路才能收敛， 仿真才能继续进行。
如果某高压电路的输出电压为 100V， 电压绝对误差 VNTOL 的默认值为

1μV， 而此时可以增加到 10mV 或者 100mV 却不会影响计算准确度， 但是对收敛

问题却有很大帮助。 电流绝对误差 ABSTOL 的默认值为 1pA， 对于大电流电路，
同样可以应用上述策略对其绝对电流误差进行增加。

PSpice 仿真软件通过 ITL1、 ITL2 和 ITL4 对迭代次数进行设置， 以便仿真收

敛。 在某些情况下， 仅仅通过增加迭代次数就可以使电路收敛， 而无需降低仿真

准确度。 在图 8. 3 中， ITL1 和 ITL2 用于直流偏置点计算， ITL4 用于瞬态分析。
对电路进行瞬态分析时， 可以通过直流偏置点计算和瞬态分析测试电路是否收

敛， 以便决定是否增加其迭代限制。

图 8. 3　 仿真设置对话框

在仿真设置窗口的 Option 选项中增加了 AutoConverge 自动收敛功能。 当仿真

过程中出现不收敛问题时， PSpice 软件通过 AutoConverge 改进仿真设置以便电路

能够成功进行仿真。 如图 8. 4 所示， 在自动收敛窗口中输入各设置值的最大限定

值， 软件将会按照该最大限定值对电路进行仿真计算。 当电路出现不收敛问题

时， PSpice 会自动对其仿真设置进行修改， 电路将会再次从 t = 0 时刻进行仿真

分析。



110　　 基于 OrCAD Capture 和 PSpice 的模拟电路设计与仿真

图 8. 4　 自动收敛设置

在每个半导体器件内部， 都有一个

很小的电导区为电流提供通路， 以便电

流和电压的初始值偏置点数值能够进行

计算。 如图 8. 3 所示， 在 PSpice 中该电

导被称为 GMIN， 为仿真设置全局参数

之一。 当电路中含有大关断电阻元件例

如功率 MOSFETs 或者二极管时， 电导

参数的设置将会非常实用。 GMIN 的默

认值为 1. 0E - 12 西门子 （用符号表示

为 S）， 但是根据实际电路该值可以增

加 10 倍或 100 倍。 通过选定 Use GMIN
stepping to improve convergence 选 项，
PSpice 可以根据电路仿真状态自动调节

GMIN 参数值， 使得电路仿真能够顺利

进行， 实践表明该选项非常实用。

8. 5　 本章练习

练习 1

图 8. 5　 缺少 0V 节点

1. 绘制如图 8. 5 所示的电路

图， 然后通过选择 PSpice > New
Simulation Profile 创建偏置点分

析文件。 在 Analysis 分析类型中

选择 Bias Point 工作点分析， 然

后单击 OK 按钮对仿真设置进行

确定。
2. 通过菜单选择 PSpice >

Run 或者单击运行按钮 对电路进行仿真分析， 将会看到如图 8. 6 所示的警告

信息对话框， 该对话框要求仿真人员对状态记录进行检查。

图 8. 6　 警告信息

通常情况下， 仿真状态记

录出现在屏幕底部， 如果状态

记录没有出现， 可用通过选择

顶部工具栏的 Window > Ses⁃
sion Log 对其进行读取， 具体

信息如下：
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WARNING [NET0129 ] Your design does not contain a Ground

（0） net.

图 8. 7　 浮动节点错误信息

单击 OK 按钮对警告信息

进行确定， 然后 PSpice 程序将

会启动。
3. 在 PSpice 输出文件中，

显示如图 8. 7 所示的错误信息。
因为电路未设置 0V 节点， 所

以所有节点都悬空。 通过在电

路中连接 0V 地节点符号可以

使电路顺利进行仿真。
练习 2

图 8. 8　 浮动节点

1. 首先绘制如图 8. 8 所示的

仿真 电 路 图， 然 后 通 过 菜 单

PSpice > New Simulation Profile
创建偏置点仿真文件。 在 Analy⁃
sis 分析类型对话框中选择 Bias
Point 偏置点计算， 然后单击 OK
按钮对仿真设置进行确定。

2. 通过选择菜单 PSpice >
Run 或者单击运行按钮 对电路

运行仿真分析。
3. 在 PSpice 输出文件中，

显示如图 8. 9 所示的错误信息。 输出该错误信息的主要原因在于节点 B 无对地直

流通路， 当两个电容串联连接时经常出现上述错误信息。 通过给 C1 或者 C2 并

联大阻值电阻可以消除上述错误信息， 从而使电路继续进行仿真分析。

图 8. 9　 浮动节点错误信息
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图 8. 10　 电感回路

练习 3
1. 首先绘制如图 8. 10 所

示的仿真电路图， 然后通过菜

单 PSpice > New Simulation
Profile 创建偏置点仿真文件。

2. 运行仿真分析 。
3. PSpice 仿真输出文件中

显示如图 8. 11 所示的错误信

息。 电感中未包含串联电阻，
通过对其增加串联电阻可以使

电路仿真继续进行。

图 8. 11　 电感环路仿真错误信息

练习 4
1. 绘制如图 8. 12 所示的仿真电路图， 晶体管 2N3904 选自 Capture transistor

元器件库。 选择菜单 Place > Net Alias， 然后按照电路图对各节点进行网络标号。

图 8. 12　 电路元器件缺少 PSpice 仿真模型

2. 创建偏置点仿真分析文件。
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3. 运行仿真分析 。
4. 如图 8. 13 所示， PSpice 输出文件中将显示一条错误信息， 以注明网络表

中无晶体管仿真模型。

图 8. 13　 电路中某元器件无 PSpice 仿真模型

5. 在电路图中， 晶体管旁边出现一个绿色圆圈。 单击该圆圈， 将会出现如

图 8. 14 所示的警告信息， 以表明晶体管 Q1 未配置 PSpice 仿真模型。 如果元器

件需要进行 PSpice 仿真分析， 必须为其配置 PSpice 仿真模型， 否则电路仿真不

能运行。 仿真模型配置将在第 16 章进行详细讲解。

图 8. 14　 缺少 PSpice 仿真模型



第 9 章
变压器仿真

变压器由两个或者更多个线圈 （电感） 通过磁耦合实现。 空心变压器由 analog
元器件库中的 K Linear 耦合元器件构成， 而非线性变压器则由磁心模型 K 构成。
对于线性变压器， 绕组为线圈的电感值， 单位为亨利 （H）； 而对于非线性变压器，
绕组为线圈的匝数值， 所以， 设计人员在仿真变压器时一定要非常注意。

PSpice 中的磁心模型具有滞环效应， 并且其耦合系数介于 0 和 1 之间， 耦合

系数用来定义线圈之间的磁通耦合程度。 耦合于同一磁心的多个线圈， 其耦合系

数接近于 1。 但是对于空气线圈来说， 其耦合系数就要小很多了。

9. 1　 线性变压器

如图 9. 1 所示为降压线性变压器模型， 一次侧和二次侧耦合电感的单位为亨

利 （H）。 两个线圈 L1 和 L2 通过磁心 K1 （K Linear） 紧密地耦合在一起。 理

想情况下， 一次侧和二次侧电路完全电气隔离。 然而如第 2 章所述， PSpice 仿真

电路中的每个节点必须有直流接地通路， 否则电路会出现不收敛问题。 在变压器

二次侧和 0V 地之间连接一个大阻值电阻 R4， 可以解决上述不收敛问题， 而不会

对仿真准确度造成显著影响。

　 　 注意：
在电感标识上面增加了一个小圆点， 以指示电流的流动方向和电压极性，

也可以指明线圈的相互绕制方式。 在以前的 OrCAD 版本中， 只能通过对电感的

引脚显示才能判断绕组之间的耦合方式。

9. 2　 非线性变压器

如图 9. 2 所示为非线性变压器电路， 该变压器由三个电感线圈 L1、 L2 和 L3
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图 9. 1　 线性空心变压器

耦合而成。 首先把电感名称 L1、 L2 和 L3 添加到磁心 K 的属性编辑器中， 然后

修改其属性， 使其显示到原理图中， 以便能够更加清晰地表明变压器的构成。 标

准磁心 K 最多可以耦合六个电感。 制造商的磁心模型都保存在 magnetic 元器件

库中。 本节电路实例所用磁心模型为 E13 6 6 3C81。

图 9. 2　 非线性中心抽头变压器

选定磁心 K， 然后通过 rmb > Edit PSpice Model 打开 PSpice 模型编辑器，
可以观测磁心的磁滞回线。 在模型编辑器中可以看到的磁心模型的详细文本描

述。 通过选择 View > Extract Model， 然后在信息窗口中点击 Yes 按钮， 磁滞回

线就会绘制出来。 磁心各参数组成的表格显示在模型编辑器底部。 对于每个磁
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心， 其气隙参数均可以被设定。 另外还有一个表格窗口用于输入 BH 曲线数据，
以便提取模型参数。 如图 9. 3 所示为磁心 E13 6 6 3C81 的模型参数和磁滞回

线图形。 第 16 章将对模型编辑器的具体使用进行更加详细的讲解。

图 9. 3　 E13 6 6 3C81 磁心的模型参数和磁滞回线

9. 3　 预定义变压器

如图 9. 4 所示， XFRM LINEAR 为线性变压器， 保存在 analog 元器件库中。
如图 9. 5 所示为非线性变压器， 包括一次侧、 二次侧带中心抽头以及双绕组的变

压器， 保存在 breakout 元件库中。 通过双击变压器进入其属性编辑器， 然后输入

电感值、 线圈电阻和匝数， 对变压器的属性进行编辑。

图 9. 4　 线性变压器 XFRM LINEAR
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图 9. 5　 非线性变压器

9. 4　 本章练习

练习 1
绘制降压变压器电路， 一次绕组电感值为 3. 1H， 串联电阻为 0. 2Ω； 二次绕

组电感值为 31mH， 串联电阻为 0. 2Ω。 该变压器与 100Ω 负载电阻连接， 对输入

信号源实现 10 倍降压功能。
1. 创建名称为 Linear Transformer 的新仿真项目， 然后绘制如图 9. 6 所示的

电路图。 其中电感、 电阻和磁心 K Linear 均选自 analog 元器件库。 V1 为正弦波

信号源 VSIN， 选自 source 库， 耦合系数设置为 0. 65。

图 9. 6　 线性变压器

2. 如果所用 OrCAD 为老版本， 电感符号上面没有圆点标识， 可以通过对其

引脚 1 进行显示以标注其极性， 然后根据设置需求对其进行相应的定向旋转。
3. 双击 K Linear， 打开其属性编辑器， 并按照图 9. 7 所示输入电感名称。
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选中 L1 和 L2， 然后通过 rmb > Display 选择 Value Only 对其显示属性进行设

置， 如图 9. 8 所示。

图 9. 7　 定义耦合电感

图 9. 8　 电感属性显示设置

图 9. 9　 输入线圈编号

　 　 注意：
误解： 电感线圈的名称必须按属性编辑器中的 L1 ～ L6 的顺序键入。 如果

电感线圈名称分别为 L3、 L4 和 L5， 用户可以按照图 9. 9 所示对其进行输入。
建议对磁心 K 的标识进行显示， 特别是对线圈进行注释以及修改编号的时候。

4. 如图 9. 10 所示， 对电路进行瞬态仿真分析， 运行时间为 50ms。
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图 9. 10　 瞬态仿真分析设置

5. 在变压器的一次侧和二次侧网络节点处放置电压探针， 对电路运行仿真

分析。 仿真结果如图 9. 11 所示， 当输入电压为 100V 正弦波时， 输出电压为

6. 4V 的正弦波， 输入、 输出相位差 180°。

图 9. 11　 降压变压器的一次侧和二次侧电压波形

如果电路中未放置电压探针， 当 PSpice 仿真窗口出现时， 选择 Trace > Add
Trace， 然后从左侧仿真变量窗口中选择 V（primary） 和 V（secondary） 进行变压

器一次电压和二次电压显示。
6. 空心变压器的一次电压、 二次电压之比与一次电感、 二次电感值的关系

如下：
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VS
VP

=
LS
LP

所以， 当耦合系数 K 的值增加为 1 时， 变压器二次电压值近似为 10V。 在实

际设计和生产中， 空心变压器的耦合系数很低。

　 　 注意：
在对变压器电路进行仿真分析时， 当输出正弦波波形出现失真时， 需要对

仿真最大步长进行限制。

练习 2
下面结合实例， 对非线性带中心抽头的变压器电路进行仿真分析。
1. 建立名称为 Non Linear Transformer 的仿真项目， 然后绘制如图 9. 12 所示

的电路图。 如图所示， 输入相应的电感值， 该参数为绕组的匝数值。 磁心选自

magnetic 元器件库， 型号为 E13 6 6 3C81。 耦合系数设置为 0. 99。

图 9. 12　 非线性、 中心抽头变压器电路

2. 如练习 1 所示， 双击 K 打开属性编辑器， 然后在属性编辑器中输入电感

名称 L1、 L2 和 L3， 并对其进行显示。
3. 对电路进行瞬态仿真分析设置， 运行时间为 50ms。
4. 在网络点 primary、 secondary1 和 secondary2 放置电压探针， 然后运行

电路仿真。
5. 图 9. 13 所示为非线性变压器的一次电压和二次电压波形。 通过图形可以

看出， 两二次绕组的峰值电压均为 25. 1V。
6. 如果读者有时间和精力， 可以继续对 analog 和 breakout 库中的其他变压

器进行研究。
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图 9. 13　 变压器一次电压和二次电压波形



第 10 章
蒙特卡洛分析

蒙特卡洛分析本质上是一种数学统计分析， 根据指定的统计分布， 当元器件

模型参数按照规定的容差极限随机变化的时候计算电路的响应。 例如， 迄今为止

本书仿真的所有电路， 其元器件的参数值均为固定值。 然而， 对于电阻、 电感和

电容等实际的分立元件， 其参数值均有一定的容差。 例如， 当选择 10kΩ ±1%的

电阻时， 可以预测设计测量的电阻应该在 9900 ～ 10100Ω。 电路中的其他分立元

件和半导体器件均存在容差。 所以， 当所有元器件的容差效果组合在一起时， 可

能对电路的输出响应造成巨大的偏差。 尤其当设计滤波器时， 元器件容差可能会

导致滤波器的频率特性产生偏差。
当元器件模型参数或者元器件参数值在规定的容差范围内随机变化时， 蒙特

卡洛分析为电路设计提供统计数据， 以预测电路的输出响应。 在蒙特卡洛分析过

程中， 元器件参数值的改变遵循特定的统计分布。 进行蒙特卡洛分析时， PSpice
按照指定的次数对电路重复进行直流分析、 交流分析或者瞬态分析， 每次仿真分

析所用的元器件参数值或元器件模型参数值均按照蒙特卡洛指定分布随机生成。
仿真运行次数越多， 元器件的各个参数值在其容差范围内出现的几率越大。 为了

使统计分析更加准确， 可以对电路进行成百上千次的仿真分析， 以便在元器件容

差范围内覆盖更多的参数和模型值。 实际上， 蒙特卡洛分析主要通过改变元器件

值和元器件模型参数值来预测电路的鲁棒性和产品的成品率。
虽然蒙特卡洛的分析结果在 PSpice 图形显示界面 （Probe） 中为一族曲线，

但是通过 Performance Analysis 性能分析可以生成直方图， 并且把统计数据及其

统计数据摘要共同显示于直方图中， 这样就能更加直观的对蒙特卡洛分析的统计

结果进行研究。

10. 1　 仿真设置

蒙特卡洛分析与交流分析、 直流分析或者瞬态分析同时进行。 首先在原理图
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中通过 Property Editor 元器件属性编辑器对各元器件的容差进行设置， 然后再

根据设计需求对电路进行仿真设置。 如图 10. 1 所示为带通滤波器， 电阻和电容

等元器件的容差已经添加并且显示于电路中。 对电路进行交流仿真分析设置， 起

始频率为 10Hz， 结束频率为 100kHz。 PSpice 首先按照各元器件的标称值对电路

进行蒙特卡洛分析， 然后按照规定运行次数， 利用随机参数值进行仿真分析。
如图 10. 2 所示为交流扫描分析与蒙特卡洛分析仿真设置。

图 10. 1　 1500Hz 带通滤波器

图 10. 2　 蒙特卡洛仿真分析设置
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输出变量

仿真输出变量由用户指定， 可以为节点电压值、 独立电流源或者独立电压

源。 在本例中， 输出变量设置为 V（out）。
运行次数

运行次数用来设置电路进行直流分析、 交流分析或者瞬态分析的仿真次数。
在 Probe 中可以显示的波形数量最多为 400 条。 然而， 如果对波形进行打印输

出， 在最新版本的 PSpice 仿真软件中， 最大打印数量已经从 2000 条增加至

10000 条， 数量大大扩展， 以满足用户的需求。 电路运行第一次仿真时所使用的

元器件参数为其标称值， 未包含容差值。
分布类型选择

元器件的模型参数按照指定的概率曲线在标称值和最大容差极限值之间分

布。 默认情况下为均匀分布， 即元器件取得每个值的概率相等； 另一种分布类型

为高斯分布， 即钟形曲线分布， 通常用于生产制造行业。 与容差边缘数值相比，
元器件参数值更倾向于在标称值中心点附近分布。

用户可以根据指定的偏差和概率数组定义特定的概率分布曲线， 其中偏差的

范围为 - 1 ～ 1， 概率的范围为 0 ～ 1。 PSpice A / D 参考手册对概率分布进行了详

细的讲解， 用户可以根据实际需求进行相关学习。 PSpice A / D 参考手册的安装

地址 < install dir > doc \ pspcref \ pspcref. pdf。
随机种子数

与通用随机数发生器一致， PSpice 也需要利用初始种子数生成随机数。 该种

子数必须为 1 ～ 32767 的奇数， 如果用户未指定该数值， 则其默认值为 17533。
数据保存形式

按照指定的运行方式对仿真数据进行保存。 例如， 如果只想查看标称值运行

时的电路响应， 选择 none。 如果需要保存每次运行的数据， 选择 ALL。 如果从

标称值开始， 每运行三次保存一次数据， 例如第四次、 第七次、 第十次等以此类

推， 可以通过选择 every， 然后在 run 栏中输入 3 来实现上述功能。 如果希望对前

三次仿真数据进行保存， 选择 first， 然后在 run 栏中输入 3 来实现上述功能。 如

果希望对第三次、 第五次、 第七次、 第十次的仿真数据进行保存， 选择 run
（list）， 然后在 run 栏中输出 3、 5、 7、 10 就可以实现上述功能。 所保存的数据

波形将会在 Probe 屏幕图形显示窗口进行显示。
MC 加载 /保存

PSpice 对电路进行蒙特卡洛分析时， 把仿真过程中随机生成的模型参数值和

元件参数值保存在规定文件中， 以供后续分析和研究。
更多设置

利用该选项对数据整理函数进行配置， 使得输出波形只返回唯一数值。 例
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如， MAX 最大值， 函数用于搜索并返回该波形的最大值。 YMAX 函数用于计算

电路在标称值和随机值仿真时波形的最大差值。 RISE 和 FALL 函数用于计算波

形第一次向上或者向下通过设定阈值时的时间值。 对于每个功能函数， 都可以根

据实际计算需求对其指定工作范围。 如图 10. 3 所示为整理函数设置窗口。

图 10. 3　 整理函数设置窗口

整理函数功能概括：
YMAX： 求与标称值运行时的最大差值

MAX： 求最大值

MIN： 求最小值

RISE EDGE： 求第一个与设置阈值交叉的上升点

FALL EDGE： 求第一个与设置阈值交叉的下降点

10. 2　 元件容差设置

在 PSpice 最新版本中， 分立元件 R、 L 和 C 均具有容差属性， 通过属性编辑

器可以对其容差进行添加和设置。 当输入容差参数值时， 务必在数值后面输入%
符号， 例如 10% ， 否则仿真结果会出现误差。

在以前的 OrCAD 版本中， 只有通过唯一途径———Breakout 元件和模型编辑

器为分立元件添加容差。 例如对电阻添加容差时， 首先从 breakout 元件库中选择

Rbreak 元件， 然后通过 rmb > Edit PSpice Model 打开模型编辑器， 最后通过设

置语句对其容差进行添加。 Rbreak 的默认模型语句为

. model Rbreak RES R = 1

其中， Rbreak 为模型名称， 可以根据实际电路需求对其名称进行修改， 该

名称显示在原理图中； RES 为 PSpice 模型类型； R 为数值因子， 用于设置电阻
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参数值的倍率； dev 和 lot 为两种容差类型， 可以按照如下格式对模型进行添加：
. model Rmc1 RES R = 1 lot = 2% dev = 5%

在上述语句中， 模型名称已经修改为 Rmc1， 包含两种容差类型。 dev 容差

规定同一模型名称的元件其参数值在该容差范围内独立变化， 而 lot 容差规定同

一模型名称的元件其参数值在该容差范围内一致变化。
Dev 设置为 5% ， 该电阻模型与标准的 5% 电阻意义完全一致， 即每个电阻

的阻值在 5%范围内独立变化， 彼此之间不受任何影响。
Lot 设置为 2% ， 即相同模型名称的元件参数值将会按照 2% 的容差一起改

变。 该容差主要用于集成电路设计， 当温度变化时， 所有元件参数值按照相同的

趋势改变。 合并后， 电阻模型 Rmc1 的总容差将达到 ± 7% 。
下面结合单列直插 （SIL） 或双列直插式 （DIL） 电阻排模型对 lot 和 dev 容

差进行讲解： 每个电阻设定独立的 dev 容差值， 这样随机生成的每个电阻的阻值

将与其他电阻值不同。 由于电阻模型的 lot 容差设置值一致， 当温度升高时， 所

有电阻的参数值将按照相同的百分比同时增加。
如上所述， 只有分立元件才具有附加的容差属性参数， 并且可以通过属性编

辑器对其进行设置。 如果需要对某厂家生产的晶体管的放大倍数 Bf 添加容差值，
以测试电路特性， 可以通过模型编辑器对其 Bf 值添加 dev 容差， 具体添加格式

如下：
. model Q2N3906 PNP （Is = 1. 41f Xti = 3 Eg = 1. 11 Vaf = 18. 7
Bf = 180. 7 dev = 50% Ne = 1. 5 Ise = 0）

在本例中， 对晶体管的放大倍数 Bf 添加 dev 容差， 数值为 50% ， 容差分布

类型为平均分布。 然而， 通常情况下 Bf 的数值更符合高斯分布， 通过对模型添

加语句 dev / gauss = 12. 5%进行高斯分布设置， 其极限误差为 ± 4σ， 具体模型设

置语句如下：
. model Q2N3906 PNP （Is = 1. 41f Xti = 3 Eg = 1. 11 Vaf = 18. 7
Bf = 180. 7 dev/gauss = 12. 5% Ne = 1. 5 Ise = 0）

10. 3　 本章练习

练习 1
如图 10. 4 所示为 Sallen 和 Key 1500Hz 带通滤波器电路图。 电阻和电容均添

加容差属性， 利用蒙特卡洛分析预测带通频率的统计变化。
1. 绘制如图 10. 4 所示电路图。 如果所用 OrCAD 软件为演示版， 则运放型号

选择 eval 库中的 uA741； 或者选用 opamp 库中的 LF411 运算放大器， 通过 Part
Search 元器件查询可以看到 LF411 运放来自不同的生产商， 每个运放都可以使
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图 10. 4　 1500Hz 带通滤波器

用。 V1 为 VAC交流源， 选自 source 元器件库， 用于交流 AC 分析； 通过选择菜单

Place >Power 放置电源符号 VCC CIRCLE， 然后分别对其重命名为 +12V 和 -12V。

　 　 注意：
当对运放 LF411 进行元器件搜索时， 务必确认搜索地址为 < install dir > \

Tools \ Capture > Library > PSpice library （详见第 5 章的练习 3）。

2. 首先把所有电阻的容差值设置为 5% 。 按住 Ctrl 键并选择电阻 R1、 R2 和

R3， 然后选择 rmb > Edit Properties 打开属性编辑器。 如图 10. 5 所示， 在属性

编辑器中选择 Tolerance 容差行 （或列） 然后通过 rmb > Edit 对其进行编辑。 如

图 10. 6 所示， 在属性值编辑对话框中输入 5% ， 然后单击确定， 完成容差值

设置。

图 10. 5　 选中整个 Tolerance 容差行， 然后选择 Edit 对其进行编辑
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图 10. 6　 为电阻添加 5%容差值

3. 在图 10. 5 中选择整个

TOLERANCE 容差行， 然后选

择 rmb > Display， 在图 10. 7
属性显示对话框中选择 Value
Only 只对数值进行显示， 最

后单击 OK 按钮对显示设置进

行确定。

图 10. 7　 容差显示值设置

4. 重复步骤 2 的操作， 把电容 C1 和

C2 的容差值设置为 10% 。
5. 如图 10. 8 所示， 创建名称为 AC

Sweep 的 PSpice 仿真设置文件， 对电路

进行交流对数扫描分析， 频率范围从 100
至 10kHz， 每 10 倍频 50 个点。 并且在

Options 对 话 框 中 选 择 Monte Carlo /
Worst Case 蒙特卡洛 /最坏情况分析。

输出变量设置为 V（out）， 运行次数

为 50。 采用平均分布， 随机数种子采用

默认值， 保持为空。 蒙特卡洛仿真设置如图 10. 9 所示。

图 10. 8　 交流分析仿真设置

6. 通过选择菜单 PSpice > Markers > Advanced > dB Magnitude of Voltage
在 out 输出节点处放置 dB 分贝探针， 然后对电路运行仿真分析。
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图 10. 9　 蒙特卡洛仿真分析设置

　 　 注意：
对电路进行蒙特卡洛仿真分析时会生成大量的数据。 由于我们只对输出节

点的波形数据关心， 所以可以设置为只保存电路图中放置探针节点处的显示波

形数据。 在仿真设置窗口中， 选择 Probe Window 探针窗口， 然后选定 All mark⁃
ers on open schematic 即可实现上述功能。

7. 当仿真运行时， 将会出现如图 10. 10 所示的运行列表， 选择 All， 然后单

击 OK 按钮进行确定。

图 10. 10　 数据显示选择
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8. 如图 10. 11 所示为带通滤波器的输出频率特性曲线。 通过选择菜单 View >
Output File 打开输出文件 { XE “Output File” }， 然后向下拖动查看每次蒙特卡

洛仿真运行数据。 在文件底部， 将会看到数据统计结果概述以及每次仿真数值与

标称值的偏差。
但是， 通过 Performance Analysis 性能分析可以以柱状图的形式更好地对中

心频率统计分布进行观测。 性能分析将在第 12 章进行详细讲解， 练习 2 只对带

通滤波器中用到的性能分析进行讲解。

图 10. 11　 利用蒙特卡洛分析带通滤波器的输出特性曲线

练习 2
1. 在 Probe 屏幕图形显示窗口中， 通过顶部工具栏选择 Trace > Perform⁃

ance Analysis 对电路进行性能分析。 在 Performance Analysis 窗口底部点击 Wiz⁃
ard 向导， 然后在下一个窗口中点击 Next 下一步。 将会看到如图 10. 12 所示测量

函数列表。

图 10. 12　 可用测量函数
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2. 选择 CenterFrequency 测量函数， 然后单击 Next 下一步。
3. 在如图 10. 13 所示的 Measurement Expression 测量函数表达式窗口中，

输入需要查询的波形名称 V（out）。 在 db level down for measurement 中输入 3。
上述设置将对滤波器中心频率两边下降 3dB 的频率点进行测量， 该测量以标称

值 （无元件容差） 运行时的最大输出值点频率为中心频率。 然后在 Performance
Analysis Wizard 性能分析向导中单击 Next 进行下一步设置。

图 10. 13　 设置 V（out） 为输出变量， 下降值为 - 3dB

4. 如图 10. 14 所示为标称仿真时带通滤波器的输出波形曲线。 波形上面所显

示的数值为两测量点的中心频率值。 在这种情况下， 中心频率定义为最大值的 3dB
带宽值。 通过该数值， 可以确定电路响应是否正确， 波形图中的测量点是否正确。

图 10. 14　 对电路进行标称值仿真时， 输出波形曲线上的 - 3dB 带宽测量值显示
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5. 在 Performance Analysis Wizard 性能分析向导对话框中选择 Next 继续进

行分析。
6. 图 10. 15 为直方图显示， 把统计数据和概率值汇总于一起。

图 10. 15　 利用直方图形式对中心频率可能扩散区域进行显示

7. 把电阻容差修改为 1%， 电容容差修改为 5%， 对电路重新运行仿真分析。
与上述性能分析步骤一致， 对电路进行中心频率测量， 仿真结果如图 10. 16 所示。

图 10. 16　 当元件的容差值变小时中心频率的统计分布数据

　 　 注意：
因为元件的容差值显示于电路图中， 所以没必要通过属性编辑器对其容差

显示属性进行更改。 在电路图中双击容差值， 然后对其输入新的容差值即可。

8. 再一次对电路运行性能分析， 但是本次对输出波形的带宽进行测量。

　 　 注意：
在 Probe 图形显示窗口中可以对直方图的显示数目进行修改。
步骤如下： Tools > Options > Histogram Divisions。



第 10 章　 蒙特卡洛分析 133　　

滤波器技术指标

滤波器增益计算公式：

|G | = R3
2R1

|G | = 150 × 103

2 × 1. 5 × 103 = 50 （10. 1）

分贝 dB 表示形式为

|G | dB = 20log1050 = 34dB
带通滤波器的中心频率计算公式为

f = 1

2πC R1R2
R1 + R2

■

■
■

■

■
■R3

（10. 2）

其中， C1 = C2 = C

f = 1

2π ×10 × 10 -9 1. 5 × 103 × 1. 5 × 103

1. 5 × 103 + 1. 5 × 103
■

■
■

■

■
■ × 150 × 103

f = 1501Hz
所以 - 3dB 带宽为

f = 1
πCR3

f = 1
π ×10 × 10 -9 × 150 × 103 = 212. 2Hz

（10. 3）

　



第 11 章
最坏情况分析

最坏情况分析主要用于确定对电路性能影响最关键的元件。 首先， PSpice 对
每个具有容差参数设置的元件进行灵敏度分析， 按照最大容差值的一定百分比在
正负两个方向进行仿真计算， 以确定正负容差哪个对最坏情况下的输出影响比较
大。 然后， 将所有执行最坏情况分析的元件值设置为其容差最大值， 以便对电路
进行最坏情况分析。 为了减少仿真运行次数， 利用测量函数对最小值、 最大值和
阈值在最坏情况下的输出差异进行检测。

图 11. 1　 由回转等效电路构成的陷波滤波器电路

如图 11. 1 所示为回转等效电感电路， 由运放 U1B、 电阻 R4 和 R5 以及电容
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C2 组成， 该电路可实现高感抗功能， 在本例中等效电感值为 100H。 等效电感与

电容 C1 串联构成串联调谐电路， 利用该电路确定陷波滤波器的频率特性。 首先

利用理想的元件值， 对陷波滤波器的频率特性进行仿真分析。 但是每个元件都有

容差， 将会对滤波器的陷波频率产生影响。 因此， 为每个元件添加容差值， 利用

最坏情况分析确定哪些元件对电路的性能影响最大。 陷波频率值可以通过对输出

电压的最小值检测得到。 因此， 最坏情况分析可以通过对输出电压进行测量函数

计算得到， 该函数只记录输出电压的最小值。

11. 1　 灵敏度分析

首先记录每个元件参数值改变时滤波器输出电压最小值， 然后通过数据分析

各元件对陷波滤波器特性的影响效果， 以确定哪个元件对陷波频率影响最严重。
PSpice 依次对每个元件进行灵敏度分析， 每个元件的参数值计算公式为

value = nominal value * （1 + RELTOL）

其中， RELTOL 为相对容差， 如图 11. 2 所示， 可以通过菜单 PSpice Simula⁃
tion Settings > Options 对其进行修改。 默认情况下 RELTOL 的值为 0. 001
（0. 1% ）。

图 11. 2　 options 选项仿真设置
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例如， 电阻 R1 的值为 20kΩ， 容差为 5% ， 则其预期值为 19 ～ 21kΩ。 如果

RELTOL 的值设置为 0. 01 （ ± 1% ）， 则电阻值最大增加为 20200Ω， 最小减小为

19800Ω。 当电阻值容差在正负方向变化时， 分别记录其最坏情况下的陷波电压

值， 以确定当电路进行最坏情况分析时应该使用正负哪个容差极限值。 如果电阻

值减小 1%时输出电压最小， 则电路进行最坏情况分析时电阻 R1 的阻值取其负

容差极限值， 即 19kΩ。
当对电阻 R1 完成灵敏度分析后， 其参数值将被重新设置为其标称值 20kΩ，

然后继续对电阻 R2 进行灵敏度分析， 修改其参数值为容差极限值， 记录输出电

压最小时的容差改变方向。 最后根据上述计算结果， 设置电阻值为其对应方向容

差极限值， 计算出最坏情况下输出电压的最小值。
在上述分析中， 假设输出电压值跟随元件值的连续变化而连续变化， 而且各

元件独立变化， 无相互交叉变化。 当元件值一起变化时， 输出电压值可能会发生

变化。

11. 2　 最坏情况分析

电路进行最坏情况分析时， 根据灵敏度仿真分析结果， 设置各元件值为其对

应方向的容差极限值。 如果仿真时电阻 R1 为 20kΩ -1%时输出电压最小， 则 R2
的阻值将被设置为 20kΩ -5% 。

最坏情况分析与 DC 直流分析、 AC 交流分析或者 Transient 瞬态分析同时运

行， 对元件参数的相互耦合关系不进行考虑。 灵敏度分析和最坏情况分析结果均

保存在输出文件中， 仿真人员可以通过 Probe 屏幕图形显示窗口对其进行查阅。

11. 3　 添加元件容差

电路进行蒙特卡洛仿真分析时， 可以在原理图中直接对电阻 R、 电感 L 和电

容 C 等元件添加容差值。 同样地， 也可以利用 breakout 元件中的 dev 和 lot 语句

设置容差值， 例如：
. model Rwc1 RES R =1 dev =5% lot =2%

dev 语句所设置的容差为具有相同模型名称的元件独立变化的容差值； lot 语
句设置的容差为相同模型名称的元件一起变化的容差值。

进行蒙特卡洛分析时， 首先必须定义一个输出变量， 该变量可以为节点电压

值或者独立电流源或者独立电压源。 如图 11. 3 所示， 输出变量为节点电压值

V（out）。
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图 11. 3　 最坏情况分析仿真设置

11. 4　 测量函数设置

电路进行蒙特卡洛分析时， 利用测量函数对电路的输出响应进行测量， 并且

与设定参数值进行比较。 利用以下五种函数对最坏情况仿真结果进行定义：
• YMAX 查询每个波形仿真结果与元件标称值仿真结果在 Y 方向上的最大

差值。
• MAX 查询每个波形的最大值。
• MIN 查询每个波形的最小值。
• RISE EDGE （value） 查询波形第一次以上升方式穿越阈值 （value） 的

时间值。 该函数假定曲线上至少有一个点在规定值以下， 至少有一个点在规定值

以上。
• FALL EDGE （value） 查询波形第一次以下降方式穿越阈值 （value） 的

时间值。 该函数假定曲线上至少有一个点在规定值以上， 至少有一个点在规定值

以下。
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11. 5　 本章练习

1. 绘制如图 11. 4 所示的电路图。 LF412 为双运算放大器， 选自 opamp 元件

库， 用户也可以根据实际情况， 选择其他运算放大器。

图 11. 4　 陷波滤波器电路图

2. 按住 Ctrl 键对所有电阻进行选定， 然后通过 rmb > Edit Properties 对其属

性进行编辑。
3. 在 Property Editor 属性编辑器中， 选中 Tolerance 容差属性整行 （或整

列） 然后通过 rmb > Edit 对容差参数进行设置 （见图 11. 5）。

图 11. 5　 对所有电阻的容差属性进行选定
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图 11. 6　 为电阻添加 5%的容差值

如图 11. 6 所示， 在 Edit
Property Values 属性参数值

编辑窗口添加 5% 的容差值，
然后单击 OK 按钮对设置进

行确定并关闭属性编辑器。
4. 重复操作步骤 3 和步

骤 4， 把电容 C1 和 C2 的容

差设置为 10% 。
5. 如图 11. 7 所示， 对电路进行交流分析设置， 起始频率为 10Hz， 截止频率

为 10kHz， 对数扫描方式， 每 10 倍频 100 点。 然后单击 Apply 按钮对仿真设置进

行确定， 切记不要退出仿真设置。

图 11. 7　 交流分析设置

6. 如图 11. 8 所示， 在仿真设置窗口的 Options 选项中选择 Monte Carlo /
Worst Case 并且把 Output variable 输出变量设置为 V（out）。 然后单击 Apply 按

钮对仿真设置进行确定， 切记不要退出仿真设置。
7. 如图 11. 9 所示， 单击 More Settings 进行更多设置， 在 Find 对话框中选择

minimum （MIN） 为测量函数， 并且选择 Low 为 Worst Case Direction 最坏情况

分析方向。 然后单击 OK 按钮对仿真设置进行确定， 切记不要退出仿真设置。
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图 11. 8　 设置最坏情况分析

图 11. 9　 选择 MIN 测量函数

8. 如图 11. 10 所示， 在仿真设置窗口选择 Options 选项卡， 然后选择 Out⁃
put File 输出文件， 在输出文件设置中不要选定 Bias Point Node Voltages 和

Model parameter values 选项。 然后单击 OK 按钮对仿真设置进行确定， 切记不

要关闭仿真设置窗口。
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图 11. 10　 输出文件选项设置

9. 如图 11. 11 所示， 在仿真设置窗口中选择 Options 选项卡， 然后把相对准

图 11. 11　 修改相对准确度 RELTOL
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确度 RELTOL 的值修改为 0. 01。 最后单击 OK 按钮对仿真设置进行确定并关闭仿

真设置窗口。
10. 通过菜单选择 PSpice > Markers > Advanced > dB Magnitude of Voltage

在 out 节点放置 Vdb 电压分贝探针。
11. 单击按钮 运行电路仿真。
12. 如图 11. 12 所示， 在 Probe 图形显示窗口中能够看到两条输出陷波频率

曲线。 标称值仿真时陷波频率值为 234Hz， 而在最坏情况下的陷波频率值

为 199Hz。

图 11. 12　 理想情况下的陷波频率值为 234Hz， 最坏情况下的陷波频率值为 199Hz

13. 如图 11. 13 所示， 打开 Output File 输出文件， 通过向下拖动文件内容对

其最小值列表进行查看。 通过输出文件可以看出， 仿真结果与预期设计一致， 相对

于 R1、 R2 和 R3 而言， R4、 R5、 C1 和 C2 对输出电压的陷波效果影响更大。

图 11. 13　 最小值列表
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如图 11. 14 所示， 通过向下拖动输出文件查看 Worst Case All Devices 最坏

情况元件列表。 从列表中可以看到灵敏度分析结果及电路进行最坏情况仿真分析

时各元件参数值的改变方向。

图 11. 14　 最坏情况分析时元件容差极限值列表

图 11. 15　 最坏情况仿真分析概要

14. 如图 11. 15 所示， 在

输出文件底部为最坏情况仿真

分析概要， 从中可以得出最坏

情况时陷波频率为 199Hz， 偏

离标称值 7% 。
15. 电容的容差修改为 5% ， 电阻 R4 和 R5 的容差修改为 1% ， 对电路重新

运行仿真分析， 查看最坏情况仿真结果是否有所改善。
16. 如图 11. 16 所示为改善后最坏情况下陷波频率特性曲线， 图 11. 17 为仿

真分析概要， 从中可以看出最坏情况下的陷波频率值为 218Hz， 与标称频率

234Hz 更加靠近。

图 11. 16　 改善后最坏情况下陷波频率特性曲线

图 11. 17　 最坏情况下频率值的改善
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高性能分析

高性能分析利用测量函数对屏幕图形显示窗口中的一族曲线进行扫描分析，
然后根据测量函数定义返回一系列计算值。 例如， 对 RC 网络的输入电压源进行

扫描分析时， 将会得到一组电容充电电压波形。 对电路运行高性能分析， 利用上

升沿时间测量函数对波形上升沿时间进行计算， 将会得到上升沿时间与扫描电压

源电压的关系波形。

12. 1　 测量函数简介

PSpice 软件拥有超过 50 种的测量函数， 表 12. 1 所示为其中的一部分。 完整

的测量函数清单见书后附录。 本书第 10 章练习 2 对标准的 CenterFrequency 中心

频率和 Bandwidth 带宽函数进行了详细的定义。 但是， 用户可以根据实际需求对

测量函数的测量范围进行自定义。 例如， Center - Frequency XRange 中心频率测

量函数允许用户确定波形的 X 轴范围， 即频率范围。 用户也可以根据实际需求

自己定义测量函数。
表 12. 1　 部分 PSpice 测量函数列表

函数定义 函数功能描述

Bandwidth 波形的带宽 （需要选择 dB ）

Bandwidth Bandpass 3dB 波形的 （3dB ） 带宽

CenterFrequency 波形的中心频率 （需要选择 dB）

CenterFrequency XRange 在指定的 X 轴范围内波形的中心频率 （需要选择 dB）

ConversionGain 第一个波形与第二个波形最大值的比

Cutoff Highpass 3dB 高通滤波器的 3dB 带宽

Cutoff Lowpass 3dB 低通滤波器的 3dB 带宽

DutyCycle 第一个脉冲周期的占空比

Falltime NoOvershoot 无过冲的下降时间
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（续）

函数定义 函数功能描述

Max 波形的最大值

Min 波形的最小值

NthPeak 第 N 个波峰的值

Overshoot 阶跃响应曲线的过冲

Peak Value 第 N 个波峰的值

PhaseMargin 相位裕度

Pulsewidth 第一个脉冲的宽度

Q Bandpass 计算指定 dB 值频率响应的 Q 值

Risetime NoOvershoot 无过冲阶跃响应曲线的上升时间

Risetime StepResponse 阶跃响应曲线的上升时间

SettlingTime 波形从起始 X 至阶跃设置完成的时间

SlewRate Fall 波形下降摆率

12. 2　 测量函数定义

在 PSpice 中， 通过选择菜单 Trace >Measurements 可以对测量函数进行查看，
图 12. 1 中包含所有可用测量函数， 以及创建、 查看、 编辑和评估测量等选项。

图 12. 1　 PSpice 中的可用测量函数
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如图 12. 2 所示为 Risetime NoOvershoot 函数定义。
上升时间定义为最大电压或者电流值取其 10%和 90%时的时间差值。 所以

需要进行两次测量， 第一次测量最大电压值 （或电流值） 的 10%对应的时间值

（x1）； 另一次测量最大电压值 （或电流值） 的 90%的时间值 （x2）。
利用如下查询命令计算波形曲线的 10%和 90%坐标点对应的时间值：
Search forward level （10% ， p）！ 1

Search forward level （90% ， p）！ 2

图 12. 2　 Risetime NoOvershoot 函数定义

在本例中， 沿波形正方向 （p） 搜寻波形为最大值的 10%处对应的时间值，
并且把该点设置为第一个数据点 （x1）， 然后继续沿波形正方向 （p） 搜寻波形

为最大值的 90%处对应的时间值， 并且把该点设置为第二个数据点 （x2）。
在图 12. 2 中， 第一行称为函数表达式， 表明该函数的功能为计算 x2 和 x1 的差

值， 即 x2 - x1。 在函数定义中， 以#开头的文字为注释行， 为用户提供注释信息。

12. 3　 本章练习

练习 1
1. 创建名称为 Risetime 的仿真项目， 然后按照图 12. 3 所示绘制 RC 电路图，

并且如图 12. 3 所示对网络节点 out 进行命名。
2. 创建 PSpice 瞬态仿真分析， 运行时间为 5μs。
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图 12. 3　 上升时间测量

3. 在 out 网络节点放置电

压探针。
4. 运行电路仿真。
5. 仿真结果如图 12. 4 所

示， 为一条平滑直线。 这是因

为电路进行瞬态仿真分析之前，
首先进行了直流工作点分析。
进行工作点分析时电容电压值

为 10V， 已达到稳态值。 所以

当时间 t = 0s 时， 电容两端电压如图 12. 4 所示， 为 10V。

图 12. 4　 稳态时电容两端电压波形

6. 按照本书第 7 章练习 2 中的具体操作， 利用 special 元件库中 IC1 元件把

t =0s 时刻电容的初始电压值设置为 0V。 如图 12. 5 所示， 同时选定 Skip the ini⁃
tial transient bias point calculation 选项， 然后对电路进行仿真分析。

7. 仿真结果如图 12. 6 所示， 电容两端电压为指数上升波形。
8. 在 PSpice 中， 选择菜单 Trace > Evaluate Measurement， 然后在右侧的测

量函数列表中选择 Risetime NoOvershoot （1） 无过冲阶跃响应曲线的上升时间

测量函数， 其中 （1） 表示该函中只包含一个参数。
在 Trace Expression 曲线表达式对话框中， 光标所选定的变量名称会自动输

入到函数中。 选择 V（out）， 函数表达式将如图 12. 7 所示。 然后单击 OK 按钮对

设置进行确定。
9. 曲线测量结果如图 12. 8 所示。
10. 通过选择 或者 打开光标， 测量电压在 1V （10% ） 和 9V （90% ）
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图 12. 5　 选择 Skip the initial transient bias point calculation 选项

图 12. 6　 电容两端电压波形从 0V 开始按照指数形式上升

的坐标值， 并确认上升时间是否正确。
练习 2
测量 Sallen 和 Key 低通滤波器的截止频率。
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图 12. 7　 选择 Risetime NoOvershoot 测量函数

图 12. 8　 测量结果

1. 如图 12. 9 所示， 绘制 Sallen 和 Key 滤波器电路图。
2. 对电路进行交流扫描分析设置， 起始频率为 1Hz， 截止频率为 10kHz， 对

数扫描方式， 每 10 倍频 20 个点。
3. 通过菜单选择 PSpice > Markers > Advanced > dB magnitude of Voltage，

在输出网络节点 out 放置 Vdb 电压分贝探针。
4. 运行电路仿真。
5. 在 PSpice 中， 选择菜单 Trace > Evaluate Measurements > Cutoff Low⁃

pass 3dB （）， 然后选择 V（out）。 测量结果如图 12. 10 所示， 输出电压 V（out）
的截止频率为 99. 6Hz。

6. 如图 12. 11 所示为 Sallen 和 Key 低通滤波器的频率特性曲线。
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图 12. 9　 Sallen 和 Key 低通滤波器

图 12. 10　 截止频率的测量值为 99. 6Hz

图 12. 11　 Sallen 和 Key 低通滤波器的频率特性曲线
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行 为 模 型

行为模型 （ABM） 为传统的电压控制电压源 E （VCVS） 和电压控制电流源

G （VCCS） 的扩展型。 行为模型利用传递函数、 数学表达式或者查表方式对电

子元件或者电路进行描述。 ABMs 利用系统的方法设计电子电路， 为设计人员提

供了一种新的电路设计思路。 电路系统由电路模块构成， 每个模块由 ABM 元件

组成， 利用该方式构成的电路系统可以大大减少仿真时间。 如果系统设计符合指

标要求， 那么每个模块可以依次由其最终实际电路代替， 构成实际的电路系统。
同样地， 实际电路也可以由 ABM 元件构成的模块代替， 以便大大简化电路， 更

有利于系统分析。
PSpice 中有两种类型的 ABM 元件： 一种为 PSpice 等效元件， 差分输入双端

输出； 另一种为控制系统元件， 单端输入单端输出。 E、 F、 G 和 H 为标准的模

型元件， 保存在 analog 库中， 而 ABM 元件保存在 ABM 库中， 用户使用时一定要

注意元件及其对应库， 以免错用或者找不到元件。

13. 1　 行为模型

扩展库提供另外五种附加函数， 分别为

Value———数学表达式

Table———查表

Freq———频率响应

Chebyshev———滤波器

Laplace———拉普拉斯传递函数

如图 13. 1 所示， 利用行为模型 Evalue 实现倍压功能。 EValue 为差分输入

（IN + ， IN - ）、 双端输出 （OUT + ， OUT - ） 的 ABM 元件。 当初次使用该元件

时， 其默认表达式为

V （% IN + ，% IN -）

上式含义为计算输入引脚 IN +和 IN - 之间的电压差值。 通过对表达式乘以
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系数 2 实现倍压功能。 切记， 表达式一定书写在方括号内部， 否则表达式无效。
倍压表达式如下：

2* {V （% IN + ，% IN -）}

图 13. 1　 电压倍压放大器

如图 13. 2 所示为输入电压为 1V 正弦波时的输出电压波形。 从图 13. 2 中可

以看出， 输出电压峰值为 2V， 与输入正弦波同相， Evalue 行为模型很简洁的实

现了电压倍压功能。

图 13. 2　 倍压放大器的输入、 输出电压波形

见表 13. 1， 很多数学函数均可用于行为模型表达式中， 以便对电路进行

简化。
表 13. 1　 数学函数

函数名称 表达式

ABS 输入信号的绝对值 | x |

SQRT 输入信号的方均根 x

PWR | x | exp

PWRS xexp

LOG 自然对数 ln（x）
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（续）

函数名称 表达式

LOG10 以 10 为底的对数 log10 （x）

EXP 自然指数 ex

SIN 求正弦， x 单位弧度 sin （x）

COS 求余弦， x 单位弧度 cos （x）

TAN 求正切， x 单位弧度 tan （x）

ATAN 反正切函数 tan - 1 （x）

ARCTAN 反正切函数 tan - 1 （x）

ABM 元件可以使用条件语句对电路的运行状态进行设置。 如图 13. 3 所示，
当输入电压大于 4V 时， 输出为 0V， 否则输出为 5V。 通过上述语句可以构成非

常实用的比较器， 仿真波形如图 13. 4 所示。

图 13. 3　 ABM 比较器

图 13. 4　 ABM 比较器仿真波形

图 13. 5 为一阶低通滤波器， 截止频率为 159Hz， 传递函数为



154　　 基于 OrCAD Capture 和 PSpice 的模拟电路设计与仿真

Vout
Vin

= 1

1 + j ω
ωC

（13. 1）

截止频率为

ωC = 1
CR =2πf

f = 1
2πCR = 1

2π ×10 -6 × 103 = 159Hz
（13. 2）

图 13. 5　 低通滤波器

如图 13. 6 所示为低通滤波器的频率特性曲线。

图 13. 6　 低通滤波器的频率特性曲线

拉普拉斯行为模型可以对滤波电路的传输特性在 s 域进行描述， 其中 s = jω、
ω = 2πf， 则低通滤波器在 s 域的传递函数为
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Vout
Vin

= 1
1 + sτ （13. 3）

其中， τ = CR =10 -6 × 103， τ = 0. 001s。
利用式 （13. 4） 传递函数重新绘制滤波电路， 如图 13. 7 所示。

Vout
Vin

= 1
1 + 0. 001∗s （13. 4）

图 13. 7　 拉普拉斯低通滤波器

　 　 注意：
输入 s 的系数时一定要输入符号∗， 例如输入 1 + 0. 001∗s， 而不应该输入

1 + 0. 001s。

图 13. 8 所示为拉普拉斯低通滤波器的频率特性传输曲线。

图 13. 8　 拉普拉斯低通滤波器的频率特性传输曲线

如图 13. 9 所示， ABM 模型的两个输入节点均与地连接， 但是 ABM 模型的

表达式以 source 节点电压为参考， 利用这种表达方式可以减小电路连线的复杂程
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度， 尤其是多个 ABM 模型同时由同一个输入源激励的时候， 利用上述方式就更

加实用。 图 13. 9 电路中的 ABM 模型为 GVALUE， 该模型以电流形式输出， 所以

其输出端不能为悬空， 在其输出端对地连接 R1 电阻， 为电路提供直流通路。

图 13. 9　 设置 source 节点为参考电压

13. 2　 本章练习

练习 1
如图 13. 10 所示电路中， 利用 ABM 行为模型 EFREQ 对带通滤波器的频率特

性进行模拟。 EFREQ 元件以频率、 幅度、 相位的表格形式对其频率特性进行

描述。

图 13. 10　 利用行为模型 EFREQ 构建带通滤波器

1. 利用 ABM 元件库中的行为模型 EFREQ 绘制图 13. 10 所示电路图。 交流

源 VAC （V1） 选自 source 元件库。
2. 双击 EFREQ 打开属性编辑器， 选定 Table 属性， 然后输入： （0. 1， - 40，

170） （1k， - 40， 160） （2k， - 20， 140） （3k， - 0， 100） （6k， - 0， - 100）
（10k， - 20， - 140） （20k， - 40， - 160） （30k， - 40， - 170）。

3. 对电路进行交流扫描分析设置， 起始频率为 1Hz， 截止频率为 100kHz，
通过菜单选择 PSpice > Markers > Advanced > dB Magnitude of Voltage， 在 out
网络节点放置 VdB电压分贝探针。
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4. 对电路运行交流扫描分析， 将会得到如图 13. 11 所示的带通滤波器频率

特性响应波形。

图 13. 11　 利用行为模型 EFREQ 实现带通滤波器的频率特性

练习 2
1. 利用 ABM 元件库中的行为模型 GVALUE 绘制如图 13. 12 所示的整流电路

图。 G1 的输入端接地， 利用函数表达式对行为模型的输入信号进行定义。

图 13. 12　 利用行为模型构建整流电路

2. 对电路进行瞬态仿真分析设置， 仿真时间为 4ms。
3. 运行仿真。
4. 利用行为模型 EFREQ 构建第 10 章的 1500Hz 带通滤波器， 并对其特性进

行研究。
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噪 声 分 析

噪声分析与交流分析同时运行， 对电路的输出噪声和等效输入噪声进行计

算。 指定输出节点的输出噪声为电路中所有电阻噪声和半导体器件噪声有效值的

和。 如果电路本身不产生噪声， 则等效输入噪声定义为产生相同输出噪声所需要

的输入噪声， 即等效输入噪声等于输出噪声除以电路增益。

14. 1　 噪声类型

14. 1. 1　 电阻噪声

约翰逊噪声或热噪声主要由导体内部电子的随机热运动产生， 随着频率和温

度的升高而增强。 在 PSpice 电路仿真中， 电阻的热噪声由电流源及其并联的无噪

声电阻构成。 由于噪声电流源具有很大的随机性， 所以采用有效值对其表示

如下：

i2 = 4kTΔf
R （A2 / Hz） （14. 1）

式中　 k———波尔兹曼常数： 1. 38e -23 （JK -1）；
T———热力学温度 （K）；
R———电阻 （Ω）；
Δf———频率带宽 （Hz）。

14. 1. 2　 半导体器件噪声

半导体器件噪声通常由热噪声、 散粒噪声和闪烁噪声组成。 热噪声主要由半

导体器件内部固有的寄生电阻产生。 但是散粒噪声由电流流过 PN 结时的随机波

动噪声电流产生， 公式如下：
i2 = 2qI（A2 / Hz） （14. 2）
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式中　 q———电子电量： 1. 602 × 10 -19C；
I———流过器件电流 （A）。

闪烁噪声产生的原因至今为止都没有被广泛地理解， 但是通过人们长期的观

察与实验， 初步归因于半导体通道的物理缺陷和电荷载体的重组。 通常情况下，
闪烁噪声只在低频时发生， 噪声电流与频率成倒数关系， 随着频率的升高而降

低。 闪烁噪声电流计算过公式为

i2 =
KF × IAFd

Δf （A2 / Hz） （14. 3）

式中　 KF———闪烁噪声系数；
Id———流过器件的电流；
AF———闪烁噪声指数；
Δf———频率带宽。

14. 2　 总噪声

电路运行噪声分析之后， 热噪声、 散粒噪声和闪烁噪声共同构成电阻和半导

体器件的总噪声， 并且和曲线波形显示方法一致， 可以在 Probe 屏幕图形显示窗

口中进行显示。 表 14. 1 列举了一些元器件的可用噪声变量名称。
元器件的噪声谱密度 （NTOT） 测量单位为 V2 / Hz。
电路总噪声可以通过如下两种形式进行表示： NTOT （ONOISE）， 单位 V2 / Hz，

或者 RMS 输出求和 V （ONOISE）， 单位为 V / Hz。

等效输入噪声为 V （INOISE）， 计算公式为
V（ONOISE）
gain of circuit， 单位为 V / Hz或

者 A / Hz。 如果电路为电流源输入， 则输入噪声单位为 A / Hz； 如果电路为电

压源输入， 则输入噪声单位为 V / Hz。
表 14. 1　 Probe 中可用噪声输出变量名称

元器件名称 输出变量 噪声

电阻 NTOT 热噪声

二极管 NRS RS 寄生热噪声

NSID 散粒噪声

NFID 闪烁噪声

NTOT 总噪声

晶体管 NRB RB 寄生热噪声

NRC RC 寄生热噪声

NRE RE 寄生热噪声
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（续）

元器件名称 输出变量 噪声

NSIB 基极电流散粒噪声

NSIC 集电极电流散粒噪声

NFIB 闪烁噪声

NTOT 总噪声

场效应晶体管 NRD RD 寄生热噪声

NRG RG 寄生热噪声

NRS RS 寄生热噪声

NRB RB 寄生热噪声

NSID 散粒噪声

NFID 闪烁噪声

NTOT 总噪声

14. 3　 运行噪声分析

噪声分析必须与交流分析同时运行。 如图 14. 1 所示， 对电路进行交流仿真

分析设置时， 可以通过 Noise Analysis 噪声分析选项对其进行选定。 本实例求输

出电压节点 V （out） 的总输出噪声。 I / V Source 为电路的输入电流源或者电压

源， 通常为交流源 VAC或者 IAC。 本实例中参考源为 V1。

图 14. 1　 交流扫描分析和噪声分析仿真设置
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Interval 对话栏输入整数， 用来指定输出文件中噪声数据保存的频度， 即频

率点间隔。 输出文件表格中的数据由频率点间隔设定值 Interval 确定， 当电路进

行交流扫描仿真分析时， 每隔固定频率点保存一个数据。 例如图 14. 1 中， 交流

扫描分析的起始频率为 10kHz， 结束频率为 1GHz， 每 10 倍频 10 个点， 则 10 倍

频的频率值分别为 10kHz、 100kHz、 1MHz、 10MHz、 100MHz 和 1GHz。 所以第

10 个频率点为 100kHz， 第 20 个频率点为 1MHz， 以此类推。 如果每 10 倍频点数

设置为 5， Interval 同样设置为 10， 此时输出文件中保存的频率值变为 10kHz、
1MHz 和 100MHz。 如果 Interval 保留为空， 则输出文件中没有噪声数据生成。 切

记不要将屏幕图形显示中的波形数据点与频率间隔相混淆， 波形数据点由交流扫

描分析设置决定。

14. 4　 噪声定义

任意 t 时刻的噪声电压瞬时值定义为 vn（ t）。 因为本质上噪声电压为统计值，
所以采用有效值 （rms） 对其进行计算， 公式为

En =
vn（ t）2

（V） （14. 4）

同样， 电流噪声的有效值计算公式为

In =
in（ t）2

（A） （14. 5）

电阻两端的噪声电压有效值计算公式为

En = 4kTRΔf （V） （14. 6）
电阻的噪声电流有效值计算公式为

En = 4kTRΔf
R （A） （14. 7）

式中　 k———波尔兹曼常数： 1. 38e -23 （JK -1）；
T———热力学温度 （K）；
R———电阻 （Ω）；
Δf———频率带宽 （Hz）。

利用 PSpice 进行噪声计算时， 假定增益带宽为 1， 即 Δf = 1。
电阻的噪声功率有效值计算公式为

Pn =
E2
n
R = I2nR （W） （14. 8）

噪声功率谱密度 S 的计算公式为

S =
Pn
Δf （W / Hz） （14. 9）
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将公式 （14. 8） 带入公式 （14. 9）， 则 S 表示为

S =

E2
n
R

■

■
■

■

■
■

Δf =

4kTR
R

■

■
■

■

■
■

Δf
S = 4kT（W / Hz） （14. 10）

噪声电压谱密度 en 的计算公式为

en =
En
Δf =

4kTRΔf
Δf

en = 4kTR Δf
Δf

en = 4kTR Δf
Δf

Δf
Δf

en = 4kTR
Δf

（V / Hz）

　
　
　

　 （14. 11）

同样地， 噪声电流的谱密度 in 的计算公式为

en =

4kT
R
Δf

（A / Hz） （14. 12）

如果将 En 和 In 的有效值直接进行相加运算是不正确的， 噪声源按如下公式

相加：
E2
n = E2

n1 + E2
n2

或者

En = E2
n1 + E2

n2 （14. 13）
在 PSpice 电路中， 双极型晶体管的噪声主要包括基极、 发射极、 集电极电

阻产生的热噪声和基极、 发射极电流产生的散粒和闪烁噪声。 假定增益带宽为

1， 即 Δf = 1Hz 时， 每个噪声源由下面的谱功率密度表示：
集电极寄生电阻热噪声计算公式为

I2c = 4kT
RC

AREA
■

■
■

■

■
■

（A2 / Hz） （14. 14）

基极寄生电阻热噪声计算公式为

I2b = 4kT
RB （A2 / Hz） （14. 15）

射极寄生电阻热噪声计算公式为

I2e = 4kT
RE

AREA
■

■
■

■

■
■

（A2 / Hz） （14. 16）
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基极散粒和闪烁噪声电流计算公式为

Ib = 2qIb +
KF × IAFb

Δf （A / Hz） （14. 17）

集电极散粒噪声电流计算公式为

Ic = 2qIc（A / Hz） （14. 18）
式中　 AREA———面积比例因数， 默认值为 1；

AF———闪烁噪声指数；
KF———闪烁噪声系数。

14. 5　 本章练习

利用简单的晶体管电路对噪声组成进行分析。 电阻 RB 的阻值非常大， 将该

电阻产生的噪声与晶体管产生的噪声进行对比。
1. 绘制如图 14. 2 所示的电路图。 晶体管 Q2N3904 选自 bipolar 元器件库；

电压源 V1 为交流源 VAC， 选自 source 元器件库。

图 14. 2　 简单的晶体管放大电路

2. 建立 PSpice 仿真设置文件， 对电路进行交流扫描分析， 起始频率为

10kHz， 截止频率为 1GHz， 对数扫描方式， 每 10 倍频 10 个频率点。 如图 14. 3
所示， 选择 Noise Analysis 噪声分析， 输出变量定义为 V（ out）， 输入源设置

为 I1。
3. 运行电路仿真。
4. 如图 14. 4 所示， 在 PSpice 中选择菜单 Trace > Add 添加晶体管集电极寄

生电阻的噪声谱密度曲线 NTOT （RC）， 单位为 V2 / Hz。
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图 14. 3　 交流分析和噪声分析设置

图 14. 4　 晶体管集电极寄生电阻的噪声谱密度波形

5. 在屏幕图形显示窗口中添加晶体管基极寄生电阻的噪声谱密度曲线

NTOT （RB）。 如图 14. 5 所示， 通过与晶体管集电极寄生电阻的噪声谱密度曲线

对比， 晶体管基极寄生电阻的噪声谱密度更大。
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图 14. 5　 晶体管集电极和基极寄生电阻的噪声谱密度对比

6. 在屏幕图形显示窗口中删除寄生电阻的功率谱密度曲线， 然后添加如图

14. 6 所示的晶体管 Q1 的噪声曲线： NFIB （Q1）、 NRB （Q1）、 NRC （Q1）、
NRE （Q1）、 NSIB （Q1）、 NSIC （Q1）。 从图 14. 6 中可以看出， 基极电流的散

粒噪声 NSIB （Q1） 对总噪声产生的影响最大， 并且该噪声表现为低频特性。

图 14. 6　 晶体管的噪声波形

　 　 注意：
在屏幕图形显示窗口中删除曲线时， 首先在窗口底部选中曲线名称， 该名

称变为红色， 然后单击 delete 键对其进行删除。

7. 在屏幕图形显示窗口中删除集电极电流散粒噪声 NSIC （Q1）， 然后可以

看到晶体管寄生电阻产生的噪声。
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8. 选择菜单 Trace > Delete All Traces 删除所有曲线波形， 然后在图形显示

窗口中添加基极电阻 RB 的噪声功率谱密度曲线 NTOT （RB） 和晶体管 Q1 的总

噪声功率谱密度曲线 NTOT （Q1）。 从图 14. 7 中可以看出， 在电路的所有噪声中

晶体管产生的噪声最大。

图 14. 7　 电路中晶体管产生的噪声最大

9. 删除所有曲线波形。
10. 如图 14. 8 所示， 在图形显示窗口中添加电路的总输出噪声曲线 NTOT

（ONOISE）， 单位为 V2 / Hz。

图 14. 8　 电路的总输出噪声波形

11. 删除总输出噪声曲线 NTOT （ONOISE）， 然后添加等效输入噪声曲线

I （NOISE）。 如图 14. 9 所示， 因为晶体管的电流增益与频率成正比， 所以输入

噪声随着频率的升高而增大。 因为输入信号源为电流源， 所以输入噪声单位为

A / Hz。
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图 14. 9　 等效输入噪声随着频率的升高而增大

12. 删除输入噪声曲线 I（NOISE）， 然后如图 14. 10 所示， 添加输出噪声曲

线 V（ONOISE）， 单位为 V / Hz。

图 14. 10　 电路的输出噪声波形

13. 仿真输出文件以表格的形式对噪声分析数据进行整理， 主要频率为 10
倍频点 10kHz、 100kHz、 1MHz、 10MHz、 100MHz 和 1GHz。 从工具栏选择菜单

View >Output File， 然后向下拖动文件内容对起始频率 10kHz 的噪声数据进行

查看， 如图 14. 11 所示。
输出文件的第一部分规定噪声计算的频率值， 接下来分别对晶体管和两个电

阻的噪声计算值进行显示， 单位为 V2 / Hz， 然后分别列出总噪声 NTOT（ON⁃
OISE） 和 V（ONOISE） 的计算数据， 单位分别为 V2 / Hz 和 V / Hz。

根据上述数据， 对电路的传递函数进行计算， 频率为 10kHz 时电路的增益
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值为 832. 9， 利用所得增益值对等效输入噪声 I （NOISE） 进行计算， 因为输入

信号源为电流源， 所以噪声单位为 A / Hz。

图 14. 11　 输出文件中的噪声计算数据



第 15 章
温 度 分 析

温度变化可能会影响电路的性能和特性。 半导体器件， 电阻、 电容和电感等

大多数电子元件的特性也受温度影响。 上述所有元器件内部均有受温度控制的模

型参数， 通过温度扫描分析可以改变元件的模型参数， 从而影响电路的电气

性能。

15. 1　 温度系数设置

温度变化时， 电阻的参数值与温度的关系式为

R = R（nom）∗[1 + TC1∗（T - Tnom） + TC2∗（T - Tnom）2] （15. 1）
式中　 TC1———线性温度系数 （ × 10 -6 / ℃），

TC2———二次温度系数 （ × 10 -6 / ℃ -2），
T———仿真温度 （℃），

Tnom———常温 （℃）， 默认值为 27℃。
另外， TCE 为指数温度系数， 此时电阻值与温度的关系式为

R = R（nom）∗1. 01TCE∗（T - Tnom） （15. 2）
通常情况下， 电阻生产厂商为用户提供线性温度系数 TC1 的参数值。
电阻的温度系数通常定义为温度变化一摄氏度时电阻值变化百万分之几的形式，

即 （ ×10 -6 / ℃）。 例如， 电阻值为 10kΩ， 线性温度系数为 +200 （ ×10 -6 / ℃）， 则

TC1 =0. 0002， TC2 =0， 当温度升高 20℃时， 电阻值为

R = 10000 × [1 + （0. 0002∗20）]
因此， 当温度升高 20℃时， 电阻值 R = 10040Ω。
与电阻值定义相似， 当温度变化时电感和电容值的计算公式分别为

L = L（nom）∗[1 + TC1∗（T - Tnom） + TC2∗（T - Tnom）2]
C = C（nom）∗[1 + TC1∗（T - Tnom） + TC2∗（T - Tnom）2]

与电阻不同的是， 电感和电容没有 TCE 指数温度系数。
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在早期的 OrCAD 软件中， Capture 中的元件并没有温度系数等相关参数， 所

以不能对其添加温度系数 TC1 和 TC2。 蒙特卡洛分析时主要使用 Breakout 元件，
可以通过 PSpice 模型编辑器对其温度系数进行添加。

例如， 对电阻添加线性温度系数 TC1 = 0. 02 （ × 10 -6 / ℃） 时， 首先从 Brea⁃
kout 元件库中选择 Rbreak 元件， 然后通过 rmb > Edit PSpice Model 打开其

模型：
. model Rbreak RES R =1

并修改为

. model Rtemp RES R =1 TC1 =0. 02

15. 2　 运行温度分析

电路进行交流分析、 直流分析或者瞬态分析时， 其默认温度 （TNOM） 为

27℃， 如图 15. 1 所示， 通过仿真设置窗口中的 Options 选项对其进行设置。
TNOM为仿真默认温度， 同时电路中各元件的模型参数值也以该温度为基准进行

计算。

图 15. 1　 默认的仿真选项设置参数值

如图 15. 2 所示， 在仿真设置窗口选择 Temperature （Sweep）， 通过输入单

一仿真温度或者温度列表， 可以对电路实现多个温度值的瞬态仿真分析。
在上面仿真实例中， 电路将在 27℃、 55℃和 125℃时分别进行瞬态仿真分
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析， 然后将各个温度下的仿真波形同时显示在 Probe 图形显示窗口中。

图 15. 2　 设置仿真温度值

如图 15. 3 所示， 在仿真设置窗口中选择直流扫描分析， 扫描变量设置为温

度， 起始值为 0℃， 结束值为 50℃， 步进为 1℃， 当电路仿真运行结束时， Probe
屏幕图形显示窗口中的 x 轴将为扫描温度值。 电路进行温度仿真分析时， 其温度

变化值为 T - Tnom。

图 15. 3　 温度扫描分析设置
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15. 3　 本章练习

练习 1
规定电阻值为 10kΩ， 温度系数为 200 （ × 10 -6 / ℃）， 则 TC1 = 0. 0002。
1. 绘制如图 15. 4 所示的电路图， 双击电阻打开属性编辑器。 把线性温度系

数 TC1 的值设置为 0. 0002， 然后按照图 15. 5 所示对 TC1 的名称和数值进行显示

设置。 最后按照电路图所示对网络节点 VR 进行命名 （Place > Net Alias）。

图 15. 4　 添加电路温度系数

　 　

图 15. 5　 显示温度系数 TC1 的

名称和参数值

2. 如图 15. 6 所示， 对电路进行直流线性温度扫描分析设置， 起始温度为

0℃， 结束温度为 50℃， 步进为 1℃。

图 15. 6　 直流温度扫描分析设置
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3. 运行电路仿真分析。
4. 在 Probe 屏幕图形显示窗口选择 或者 对电阻值进行显示。 电阻值为

电阻两端的电压与流过电阻的电流的比值。
5. 通过 Add Traces 窗口底部的表达式对话框对电阻值进行定义。 首先从

Simulation Output Variables 仿真输出变量列表中选择 V （VR）。 然后从右侧的

图 15. 7　 电阻 R1 的表达式

Functions or Macros 函数列表中选择除号 “ / ” 并

且继续从仿真输出变量列表中选择 I （R1）。 最后将

会看到如图 15. 7 所示的函数表达式。
另外， 用户可以直接输入所需表达式， 而不必

从变量或者函数列表中选择。 如图 15. 8 所示， 在 Probe 屏幕图形显示窗口中将

会看到电阻值随着温度的升高而逐渐增大。

图 15. 8　 电阻值随温度变化的特性曲线

在 Probe 屏幕图形显示窗口中打开光标， 可以看到温度为 27℃时电阻值为

10kΩ， 温度为 47℃时电阻值为 10040Ω， 通过以上数据可以得到温度升高 20℃
电阻值增加 40Ω， 即线性温度系数为 200 （ × 10 -6 / ℃）。

图 15. 9　 对电阻添加二次温度系数

6. 如图 15. 9 所示， 线性温度系数 TC1 设

置为 0， 二次温度系数 TC2 设置为 0. 001， 重

新对电路运行仿真分析。 通过对上次显示波形

进行保存和读取， 可以在下次仿真时直接显示

该波形， 而不必重复输入曲线表达式。
7. 在 Probe 屏幕图形显示窗口中选择菜单

Window > Display Control > Last Session >
Restore， 将会得到如图 15. 10 所示的二次曲

线波形。
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图 15. 10　 温度变化时， 二次温度系数 TC2 对电阻值的影响

练习 2

图 15. 11　 利用嵌套扫描对二极管的

温度特性进行分析

1. 绘制如图 15. 11 所示的电路图。 二

极管 D1N914 选自 diode 或者 eval 元件库。
2. 设置嵌套直流扫描分析。 如图

15. 12 所示， 电压源 V1 设置为主扫描，
起始值为 0V， 结束值为 + 10V， 步进为

0. 01V。 如图 15. 13 所示， 温度设置为

辅扫描， 起始值为 - 55℃， 结束值为

+ 75℃， 步进为 10℃。

图 15. 12　 主扫描设置
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图 15. 13　 辅扫描设置

3. 显示二极管的电流值随其电压值变化的特性曲线。 首先选择菜单 Plot >
Axis Settings > X Axis， 然后在图 15. 14 中选择按钮 Axis Variable， 在变量列表

中选择 V1（D1）作为新的 x 轴。 单击 OK 按钮对设置进行确定。

图 15. 14　 改变 x 轴变量
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4. 添加二极管电流波形曲线。 选择菜单 Trace > Add > I （D1） 对流过二

极管 D1 的电流波形进行添加。 图 15. 15 所示为温度变化时， 二极管的电流随电

压变化的一族波形曲线。

图 15. 15　 温度变化时， 二极管 D1N914 的电流随电压变化的波形曲线



第 16 章
添加和建立 PSpice 模型

PSpice 模型可以在模型编辑器中进行建立和编辑。 PSpice 模型编辑器可以通

过 Start 开始菜单选择 PSpice > Simulation Accessories > Model Editor 以独立

模式进行启动， 或者在 Capture 原理图中选定某 PSpice 元器件， 然后选择 rmb >
Edit PSpice Model 也可以对其进行启动。 当在 Capture 原理图中对 PSpice 元器件

模型进行编辑时， 该模型将以副本的形式保存在库文件中， 该库文件的名称与仿

真项目的名称一致， 例如 < project name > . lib。 这样 PSpice 原始模型将保持原

样， 不会被修改。 复制库将被写入项目文件， 并且成为项目管理器中 PSpice 配

置库文件之一。 当为 PSpice 模型建立新的元器件符号时， 一定要为该元器件配

置库文件路径， 具体方式为： 在仿真设置窗口中选择 Configuration Files > Cat⁃
egory > Library， 然后把元器件对应的库文件添加进去。

16. 1　 PSpice 元器件属性

在 Capture 中， 如果某元器件需要进行电路仿真， 那么该元器件必须具备如

下四个特定属性：
·Implementation： 模型名称

·Implementation Path： 模型所属路径， 如果模型在仿真设置文件中已经配

置， 该项为空

·Implementation Type： PSpice model
·PSpiceTemplate： 为模型和子电路提供 Capture 元器件接口

当 Capture 元器件在 Capture 或者模型编辑器中被建立的时候， 上述四项属

性会自动地添加到元器件属性列表中。 图 16. 1 所示为晶体管 Q2N3904 的相关

属性。
Q2N3904 的 PSpiceTemplate 定义为

Q^@ REFDES % c % b % e @ MODEL
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其中， 第一个字母 Q 代表双极型晶体管。 其他的元器件类型见表 16. 1。 全

部元器件的类型列表如附录 2 所示。
符号 “^” 用来对元器件的所属层路径进行定义， 可以使用该元件的具体层

路径代替符号 “^”。 例如， 如图 16. 2 所示的网表显示该电路由 Top 顶层和 Bot⁃
tom 底层构成， 在底层电路中有电阻 R1 和 R2， 它们的层路径被分别定义为 R
Bottom R1 和 R Bottom R2。 在顶层电路中也有一个电阻， 被定义为 R1。

图 16. 1　 Q2N3904 的相关属性

表 16. 1　 PSpice 元器件定义

首字母 元器件类型 引脚

R 电阻 1， 2
C 电容 1， 2
L 电感 1， 2
D 二极管 Anode， cathode
Q 晶体管 Collector， base， emitter
M MOSFET Drain， gate， source， bulk
Z IGBT Collector， gate， emitter
I 电流源 + ve node， - ve node，
V 电压源 + ve node， - ve node，
X 子电路 Node 1， node 2， …node n
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图 16. 2　 层电路网络表

@ REFDES 为元器件标号， 例如 Q1、 R2 等。 % 定义引脚名称， 各类元器件

的引脚命名顺序见表 16. 1。 @ MODEL 为模型名称。

16. 2　 PSpice 模型定义

PSpice 模型的一般定义格式为

. MODEL <model name > <model type >

+ （[ <parameter name > = <value >

模型名称的首字母必须为表 16. 1 中规定的字母， 最长为 8 个字符。 元器件

类型必须与元器件名称一致， 例如， NPN 只能用于双极型晶体管。 表 16. 2 详细

列出了 PSpice 元器件名称及其对应的元器件类型。
例如， Q2N3904 晶体管的详细模型定义如下：
. model Q2N3904 NPN（Is =6. 734f Xti =3 Eg =1. 11 Vaf =74. 03 Bf =

416. 4 Ne =1. 259
+ 　 　 Ise =6. 734f Ikf =66. 78m Xtb =1. 5 Br = . 7371 Nc =2 Isc =0

Ikr =0 Rc =1

+ 　 　 Cjc =3. 638p Mjc = . 3085 Vjc = . 75 Fc = . 5 Cje =4. 493p Mje =

. 2593 Vje = . 75
+ 　 　 Tr =239. 5n Tf =301. 2p Itf = . 4 Vtf =4 Xtf =2 Rb =10）

　 　 National pid =23　 　 case =TO92

　 　 88 -09 -08 bam creation
表 16. 2　 PSpice 模型类型

模型 元器件类型 元器件

Qname NPN NPN 晶体管

PNP PNP 晶体管

LPNP L 型 PNP 晶体管

Dname D 二极管

Cname CAP 电容
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（续）

模型 元器件类型 元器件

Kname CORE 非线性磁心

Lname IND 电感

Mname NMOS N 型 MOSFET

PMOS P 型 MOSFET

Jname NJF N 型 JFET

PJF P 型 JFET

Rname RES 电阻

Tname TRN 传输线

Bname GASFET N 型 GASFET

Zname IGBT N 型 IGBT

Nname DINPUT 数字输入元件

Oname DOUTPUT 数字输出元件

Wname ISWITCH 电流控制开关

Uname UADC 多位 ADC

UDAC 多位 DAC

UDLY 数字延迟线

UEFF 边沿触发其

UGATE 标准门电路

UIO 数字 I / O 模型

UTGATE 输出门

Sname VSWITCH 电压控制开关

模型名称 Q2N3904 以字母 Q 开头， 表明 Q2N3904 为双极型晶体管模型。 模

型类型为 NPN， 模型参数书写于大括号 { } 内。 标题行以星号∗开头， 对元器

件的基本信息进行介绍， 例如， 半导体器件的生产厂家、 生产日期、 元器件封装

（PCB） 等。
大多数元器件按照基本的模型定义方式进行定义。 然而， 也可以完全按照如

下方式对模型进行定义：
. MODEL <model name > [AKO： <reference model name > ]
+ <model type >

+ （[ < parameter name > = < value > [tolerance specifica⁃
tion]]*

+ [T MEASURED = <value > ] [[T ABS = <value > ] or
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+ [T REL GLOBAL = <value > ] or [T REL LOCAL = < value

> ]]）
当新模型建立在另外一个模型基础上的时候， 可以使用 AKO 语句进行新模

型建立， 这样只需要修改部分模型参数即可， 大大简化模型建立工序。 例如， 需

要建立 BF 最小值为 75 的晶体管 Q2N3904 的 PSpice 模型， 其他模型参数保持不

变， 则新模型定义如下：
. model Q2N3904 minBF AKO：Q2N3904 NPN （BF =75）

以原始晶体管模型为基础， 采用不同的模型参数， 利用该方法可以建立一组

晶体管模型。
在模型定义语句中， 有三个参数与温度息息相关， 因为这些模型参数值的计

算和测量以温度为标准。
T MEASURED

T ABS

T REL GLOBAL or T REL LOCAL

T MEASURED 为模型参数值测量温度。 默认值为 27℃， 如果对其进行设

置， 将覆盖 TNOM。
T ABS 用来设置元器件工作的热力学温度。 无论电路工作温度是多少， 元

器件的温度将恒定为 T ABS。
T REL GLOBAL 为元器件提供偏置温度， 即元器件温度等以电路温度与 T

REL LOCAL 的差值。
T REL LOCAL 主要适用于当某个晶体管的工作温度高于其他晶体管的电

路中。 例如， 某 Q2N3904 晶体管需要布置在热源旁边， 该热源的温度比环境温

度高 5℃， 此时可以在模型语句结尾处添加如下语句 T REL GLOBAL = 5℃，
详细语句如下：

. model Q2N3904 NPN（Is =6. 734f Xti =3 Eg =1. 11 Vaf =74. 03 Bf

=416. 4 Ne =1. 259
+ 　 　 Ise =6. 734f Ikf =66. 78m Xtb =1. 5 Br = . 7371 Nc =2 Isc =0

Ikr =0 Rc =1

+ 　 　 Cjc =3. 638p Mjc = . 3085 Vjc = . 75 Fc = . 5 Cje =4. 493p Mje

= . 2593 Vje = . 75
+ 　 　 Tr =239. 5n Tf =301. 2p Itf = . 4 Vtf =4 Xtf =2 Rb =10 T

REL GLOBAL =5）

　 　 National pid =23 　 　 case =TO92

　 　 88 -09 -08 bam creation
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当电路在 - 55℃、 27℃和 125℃进行仿真分析时， 晶体管 Q2N3904 的温度分

别为 - 50℃、 32℃和 130℃。

16. 3　 子电路

PSpice 元器件可以表示为多个器件的组合， 运算放大器 （运放） 和电压调

节器即由这种方式构成。 这类元器件被称为子电路， 在 PSpice 模板中的第一个

字母为 X。 运算放大器 LF411 的 PSpice 模板为

X ^@ REFDES % + % - % V + % V - % OUT @ MODEL

元器件的引脚顺序必须与 PSpice 子电路的定义相匹配， 运算放大器 LF411
的子电路语句如下：

connections：　 　 　 　 non -inverting input

　 　 　 　 　 　 　 　 　 　 |inverting input

| |positive power supply

| | |negative power supply

| | | |output

| | | | |

. subckt LF411 1 2 3 4 5

c1 　 11 12 4. 196E -12
c2 　 6 7 10. 00E -12
css　 10 99 1. 333E -12
dc　 5 53 dy

de　 54 5 dy

dlp　 90 91 dx

dln　 92 90 dx

dp　 4 3 dx

egnd 99 　 0 poly（2），（3，0），（4，0） 0 . 5 . 5
fb　 7 99 poly（5） vb vc ve vlp vln 0 31. 83E6 - 1E3 1E3 30E6

-30E6

ga　 6 0 11 12 251. 4E -6
gcm　 0 6 10 99 2. 514E -9
iss　 10 4 dc 170. 0E -6
hlim 90 　 0 vlim 1K

j1 　 11 2 10 jx
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j2 　 12 1 10 jx

r2 　 6 9 100. 0E3
rd1 　 3 11 3. 978E3
rd2 　 3 12 3. 978E3
ro1 　 8 5 50

ro2 　 7 99 25

rp　 3 4 15. 00E3
rss　 10 99 1. 176E6
vb　 9 0 dc 0

vc　 3 53 dc 1. 500
ve　 54 4 dc 1. 500
vlim　 7 8 dc 0

vlp　 91 0 dc 25

vln　 0 92 dc 25

. model dx D（Is =800. 0E -18 Rs =1m）

. model dy D（Is =800. 00E -18 Rs =1m Cjo =10p）

. model jx NJF（Is =12. 50E -12 Beta =743. 3E -6 Vto = -1）

. ends

　 　 注意：
当为子电路模型创建元器件符号的时候， 首先出现一个矩形方框， 可以对

矩形方框进行编辑， 或者根据实际需求使用 Capture 中 Part Editor 元器件编辑器

绘制元器件符号图形。

16. 4　 模型编辑器

模型编辑器主要用于查看模型的文本定义、 特性曲线和模型参数。 如图

16. 3 所示为二极管的正向电流 /电压特性曲线。 当模型编辑器第一次加载 PSpice
元器件库时， 模型将以文本形式显示， 通过选择菜单 View > Extract Model 可
以查看模型的特性曲线。 从图 16. 3 中可以看到一列表格， 在表格中输入生产厂

商的实验测试数据， 模型编辑器将以该数据为基础建立新的元器件模型。
建立新模型时首先选择菜单 File > New 建立元器件库， 然后选择 Model >

New 建立新元器件 （见图 16. 4）。
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图 16. 3　 模型编辑器

图 16. 4　 建立新模型

　 　 模型编辑器中共有 11 种类型的

元器件可供选择， 可以通过两种方

式建立元器件模型 Use Device Char⁃
acteristic Curves 和 Use Template。
Use Device Characteristic Curves 主要

用于建立普通的 PSpice 模型， 而

Use Template 主要用于建立参数确定

的元器件模型。 利用 Use Templates
建立的元器件模型主要用于 PSpice
高级分析， 此处不做深入讲解。

模型建立完成后， 模型编辑器

会自动生成该模型的 Capture 元器件

符号。 模型名称的首字母和模型类

型与表 16. 2 中定义一致， 并由此确

定元器件符号。 生成 Capture 元器件符号时一定要确保原理图编辑器选择正确。
如图 16. 5 所示， 通过菜单 Tools > Options > Schematic Editor 对 Capture 进行
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选择。
如前所述， 新建模型的元器件符号由模型名称的首字母和模型类型决定。 如

果新建元器件为标准的 PSpice 元器件， 可以通过菜单 File > Export to Capture
Part Library 建立模型元器件。 如图 16. 6 所示， 首先为 PSpice 模型 （. LIB） 及

其生成的 Capture 元器件 （. OLB） 选择保存地址， 然后单击 OK 按钮建立元器件

符号。 当元器件符号生成后将会出现一个消息窗口， 以提示 PSpice 模型———元

器件符号转换是否成功。

图 16. 5　 在 Options 中选择

Capture schematic Editor
图 16. 6　 建立和保存 PSpice 模型

和 Capture 元器件

16. 4. 1　 模型复制

利用模型编辑器可以从现有的库文件中对已经存在的 PSpice 模型进行复制。
通过选择菜单 Model > Copy From 将会出现如图 16. 7 所示的 Copy Model 模型

复制窗口。 首先通过浏览 Source Library 对话框选定需要复制的库文件， 然后从

所选库文件的模型列表中选择需要复制的模型并且在 New Model 对话框中输入新

模型名称， 最后单击 OK 按钮对设置进行确定。

16. 4. 2　 模型导入

选择菜单 File > Import Wizard [Capture] 可以进入模型导入向导， 在模
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图 16. 7　 从已存在元器件库中复制 PSpice 模型

型向导中可以对库文件进行查

看、 选择或者替换模型元器件符

号， 但是一次只能对一个模型进

行操作。 如图 16. 8 所示， 首先通

过浏览按钮选择输入模型库， 然

后为其指定匹配符号库。 值得庆

幸的是， 当利用模型向导建立由

模型编辑器生成的运算放大器模

型的元器件符号时， 该符号为运

算放大器的形状， 而不是矩形

框。 另外可以通过浏览选择现有

的 Capture 符号与模型相关联的

方式建立元器件模型符号， 该方法也非常实用。

图 16. 8　 模型导入向导

在图 16. 9 中， 从 IRF. lib 元器件库中复制一种国际整流器公司的 MOSFET，
对其进行修改并且保存为 myIRF540。 如果需要对元器件引脚进行查看， 可以通

过选择 view model text 按钮对模型的文本文件进行读取。
由于 MOSFET 还未配置器件符号， 所以单击 Associate Symbol 按钮对适合的

元器件库进行浏览。 如图 16. 10 所示， 从元器件库中找到一个 NMOS 晶体管与

MOSFET 相匹配。
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图 16. 9　 关联或者替换模型符号

图 16. 10　 为模型查找匹配的元器件符号

　 　 注意：
MOS 器件以子电路的形式定义， 如果使用模型编辑器生成元器件符号而不

是利用模型导入向导， 则其元器件符号为一个矩形框， 为了能够正常使用， 必

须对其符号形状进行编辑。

如图 16. 10 所示， 本例子中的 NMOS 器件符号来自 pwrmos. olb 元器件库。
如图 16. 11 所示， 接下来必须把模型端点 （1、 2、 3） 与 Capture 元器件符号引
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脚 （d、 g、 s） 相关联， 从图 16. 10 中可以看到所有符号引脚名称。

图 16. 11　 定义模型端点和引脚名称

当在图 16. 11 中选择 Save Symbol 按钮对模型库进行保存时， 将会出现如图

16. 12 所示的 myTransistors. lib 模型库文件列表。 从库文件列表中可以看到每个

模型都有各自关联的元器件符号， 并且此时 Replace Symbol 替换符号选项也出现

在对话框中。 如果模型还未配置关联符号， 则 Associate Symbol 关联符号选项将

会出现。

图 16. 12　 myTransistors PSpice 模型库总结

第 21 章的练习 2 通过实例对模型导入向导的使用进行了详细的讲解。
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16. 4. 3　 模型下载

模型编辑器对于模型的特性曲线显示非常实用， 尤其当 PSpice 模型已经从

供应商的网站下载， 对其进行性能测试的时候就更加重要了。 通常默认情况下，
模型编辑器会忽略 PSpice 模型文件的第一行， 因此在对 . model 语句进行编辑的

时候从第二行开始。 注释行可以添加到模型语句中， 但是该行必须以星号∗开

头。 所以利用注释行对模型进行标注非常实用， 例如：
* Q2N7777 transistor downloaded from semiconductor web⁃

site 23. 4. 2011
也可以在 Capture 中通过 PSpice 模型建立其元件符号。 在项目管理器中选择

设计文件 （. dsn）， 然后选择菜单 Tools > Generate Part 打开 Generate Part 窗
口， 如图 16. 13 所示。 在 Netlist / source file type 源文件类型对话框中选择 PSpice
Model Library 模型库， 然后在 Netlist / source file 对话框中通过浏览按钮选择

PSpice 模型文件。 接下来在 Implementation name 选项中选择模型名称。 如果已下

载的模型库中包含多个模型， 则所有的模型名字都将显示出来。

图 16. 13　 利用 PSpice 模型生成 Capture 元件
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16. 4. 4　 模型加密

模型编辑器具有加密功能， 利用该功能可以对 PSpice 模型或者元器件库进

行加密。 加密后的文件可以用于 PSpice 仿真， 但是模型的具体内容却不能看到。
选择菜单 File > Encrypt Library 可以对库文件进行加密， 如图 16. 14 所示为库

文件加密对话框， 通过浏览按钮对需要加密的库文件及其保存文件夹进行选择。

图 16. 14　 元器件库加密

如果只想对 PSpice 元器件库的部分元器件进行加密， 例如两个元器件， 可

以在该模型语句开头和结尾添加如下语句：
CDNENCSTART beginning of model text

CDNENCFINISH end of model text

如果 Partial Encryption 部分加密未选中， 则 Show Interfaces 显示端口选项

将允许对模型文本文件进行加密， 但仍然显示该模型端口， 即模型的连接引脚，
例如， 双极型晶体管的发射极、 基极和集电极。

　 　 注意：
注释行不能进行加密。

16. 4. 5　 IBIS 转换器

OrCAD 16. 5 版本仅支持 IBIS 1. 1 版本的模型， 但是 OrCAD 16. 6 一直支持到

IBIS 5. 0 版本。
在 OrCAD 16. 6 版本中， 利用模型编辑器可以把 IBIS 和 Cadence 专有的 De⁃

vice Model Language （DML） 文件转换为 PSpice 库文件。 被转换的 IBIS I / O 缓冲

器件被定义为宏模型。
IBIS 模型主要用于分析 ICs 之间的高速数字信号传输， 其中， 传输介质通常

为铜线， 该类介质被定义为传输线模型。 测量电压 /电流和电压 /时间所得数据表

格表征了 ICs 的输入和输出缓冲器特性， 但是所提供的 I / O 缓冲行为并没有披
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露关于内部实现的 I / O 缓冲器的任何特征信息。 以 V / I 和 V / T 数据表为基础构

成的 IBIS 模型， 通过预测传输线的阻抗失配、 串扰、 过冲、 下冲、 地面反弹和

高速数字信号的同步开关来分析传输数据的信号完整性。
IBIS 模型提供相对精确的仿真模型， 因为它们把芯片结构的 ESD 保护、 管

芯与 IC 封装引脚相关联的固有寄生效应都考虑进去了。 与标准 SPICE 模型相比，
IBIS 模型的仿真运行速度更快， 并且不会产生不收敛问题。

DML 文件由现有的高速仿真 Cadence 软件工具使用， 用于分析高速电路。
IBIS 转换器附属于模型编辑器， 通过顶部工具栏可以对其进行访问。
Model > IBIS Transiator

演示版光盘不含有 IBIS 转换器。

图 16. 15　 验证齐纳二极管的击穿电压

16. 5　 本章练习

练习 1
利用模型编辑器修改齐纳二极

管的击穿电压。
1. 创建名称为 zener diode 的

仿真项目， 然后绘制如图 16. 15 所

示的电路图。 齐纳二极管的稳压值

为 4. 7V， 该稳压管可以从 eval 或
者 diode 元件库中进行选取。

2. 创建 PSpice > New Simu⁃
lation Profile 仿真设置文件， Anal⁃
ysis type 分析类型为直流扫描分析， 起始电压为 1V， 结束电压为 10V， 步进为

0. 1V （见图 16. 16）， 以满足 4. 7 V 稳压二极管的击穿电压。 当电路进行直流扫

描分析时， 电压源 V1 的电压值为 0V， 并不影响电路的正常仿真分析。
3. 选定二极管然后选择 rmb > Edit PSpice Model 打开模型编辑器。 如图

16. 17 所示， 新建元器件库名称为 zener diode. lib， 显示在模型编辑器的顶部。
4. 从顶部工具栏选择 View > Extract Model 进行模型参数提取。 在第一个

PSpice 模型编辑器窗口中单击 Yes 按钮， 然后在接下来的参数窗口中单击 OK 按

钮。 如图 16. 17 所示， 模型编辑器中将显示二极管的正向电流特性曲线。
5. 在曲线图形显示窗口底部一共有五个选项， 分别对应二极管模型的不同

特性曲线。 当选定某条曲线时， 将会出现如图 16. 18 所示的参数窗口， 每个参数

均有 Active 动态功能选项， 该参数与曲线特性息息相关。 下面对二极管的反向击

穿特性曲线及其动态参数进行分析。
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图 16. 16　 直流扫描仿真设置

图 16. 17　 建立 zener. lib 文件

6. 参数设置对话框分布在模型编辑器底部， 向下拖动参数列表， 选择二极

管反向击穿电压参数 BV。 如图 16. 19 所示， 把该参数值从 4. 7 V 修改为8. 2V，
并且选定 Fixed 选项。 选择 Reverse Breakdown 反向击穿曲线进行查看， 将会看到
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图 16. 18　 利用模型编辑器对模型曲线进行参数提取

二极管的反向击穿电压已经改变为 8. 2V。

图 16. 19　 设置二极管反向击穿电压值

7. 选择菜单 File > Save 对元器件库进行保存， 然后关闭模型编辑器。
8. 编辑仿真设置文件。 选择 Configuration Files > Library 对元器件库进行

配置， 以确保 zener diode. lib 元器件库添加到配置文件中。 如图 16. 20 所示，
元器件库可以按照如下两种类型进行添加， 代表局部元器件库， 即该元器件

库只能用于该仿真项目， 不能为别的仿真项目使用； 代表全局元器件库， 即

该元器件库可以被所有仿真项目使用。 nom. lib 为全局仿真库， 里面包含所有

PSpice 库文件， 可以被所有仿真项目使用。
9. 选择 zener diode. lib 元器件库， 然后单击 Edit 按钮打开模型编辑器。 在

Models List 模型列表中选择 D1N750， 将会看到该二极管的模型参数。 通过这种

方法可以快速对库文件进行查看。 最后关闭模型编辑器和仿真设置窗口。
10. 重新运行仿真， 并确认目前二极管的击穿电压为 8. 2V。
练习 2
建立新的 PSpice 模型和 Capture 元器件时， 最科学的方法是为其建立新的目

录。 不要把新建的元器件库安装在 Capture 或者 PSpice 文件夹中。 当电脑安装新

的 OrCAD 版本时， PSpice 和 Capture 库文件将被重新安装， 这样所有建立的新模

型都将丢失。 下面对库文件进行实际操作练习， 首先假设晶体管的 PSpice 模型

已经从半导体网站上成功下载。 从 bipolar. lib 元器件库对晶体管模型进行复制以
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图 16. 20　 添加 Zener diode. lib 为项目元器件库

重现库文件下载场景， 然后把新的元器件库重命名为 myTransistors. lib。
1. 在 Orcad 16. 3 \Tools \PSpice \ Library 文件夹中选择 bipolar. lib 或者 eval. lib

PSpice 元器件库， 然后使用文本编辑器 WordPad 或者 Notepad 对其进行打开。 对

文件选择时一定要确保 Files of type 文件类型为 All Files 所有文件。
2. 在库文件中， 向下滚动并且选择 Q2N3904 模型， 该模型的详细定义如下：
. model Q2N3904 　 NPN（Is =6. 734f Xti =3 Eg =1. 11 Vaf =74. 03 Bf

=416. 4 Ne =1. 259
+ 　 　 Ise =6. 734f Ikf =66. 78m Xtb =1. 5 Br = . 7371 Nc =2 Isc =0

Ikr =0 Rc =1

+ 　 　 Cjc =3. 638p Mjc = . 3085 Vjc = . 75 Fc = . 5 Cje =4. 493p Mje

= . 2593 Vje = . 75
+ 　 　 Tr =239. 5n Tf =301. 2p Itf = . 4 Vtf =4 Xtf =2 Rb =10）

　 National pid =23 case =TO92

　 88 -09 -08 bam creation

3. 对模型的文本文件进行选定， 然后复制、 粘贴为新的文本文件。 如果使

用 WordPad 文字编辑器时， 切记不要把文本文件保存为 RTF 格式。
4. 把晶体管的模型名称修改为 Q2N7777， 并且在第 1 行添加注释， 修改后

的模型库文件为

example of a downloaded transistor model

. model Q2N7777 NPN（Is =6. 734f Xti =3 Eg =1. 11 Vaf =74. 03 Bf
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=416. 4 Ne =1. 259
+ 　 　 Ise =6. 734f Ikf =66. 78m Xtb =1. 5 Br = . 7371 Nc =2 Isc =0

Ikr =0 Rc =1

+ 　 　 Cjc =3. 638p Mjc = . 3085 Vjc = . 75 Fc = . 5 Cje =4. 493p Mje

= . 2593 Vje = . 75
+ 　 　 Tr =239. 5n Tf =301. 2p Itf = . 4 Vtf =4 Xtf =2 Rb =10）

　 　 National pid =23 　 case =TO92

　 　 88 -09 -08 bam creation

5. 将文本文件命名为 myTransistors. lib， 然后保存在 myTransistors 文件夹中。
确保库文件保存为文本格式而不是 RTF 格式， 否则将会有控制字符添加到模型

文本中。
6. 建立名称为 myTransistors 的 PSpice 仿真新项目。
7. 在项目管理器选中 Transistors. dsn 文件， 然后选择菜单 Tools > Generate

Part。 如图 16. 21 所示为元器件生成窗口：

图 16. 21　 生成 Capture 元器件
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在 Netlist / source file type 对话框中选择 PSpice Model Library；
在 Netlist / source file 对话框中通过浏览按钮选择 myTransistors. lib 库文件；
在 Destination part library 对话框中选择与 myTransistors. lib 相同的文件夹；
在 Implementation name 对话框中只有 Q2N7777 一个元器件。
单击 OK 按钮对设置进行确定。
8. 如图 16. 22 所示， Capture 符号库 myTransistors. olb 将会生成， 并且自动添

加到项目管理器的元器件库文件夹中。 展开库文件可以看到 Q2N7777 元器件。

图 16. 22　 myTransistors 库文件和 Q2N7777 元器件

图 16. 23　 myTransistors. olb 添加到元器件库中

9. 打开原理图页面， 选择菜单

Place > Part 或者按键盘上的 P 键。
如图 16. 23 所示， myTransistors 元器

件库已经自动添加到 PSpice 元器件库

中， 并且 Part List 元器件列表已经包

含 NPN 晶 体 管 Q2N7777。 另 外，
PSpice 仿真图标 出现在元器件窗

口下方， 表明该晶体管具有 PSpice 仿

真模型， 可以用于电路仿真。 接下

来， 把 myTransistors. lib 库文件配置到

仿真设置文件中。
10. 选 择 菜 单 PSpice > New

Simulation Profile 建立新的仿真设置

文件。 在 Configurations Files 文件配置

选项卡下选择 Category > Library，
然后通过浏览按钮对 myTransistors. lib
库文件进行选择。 按照练习 1 的步骤

8， 可以把库文件添加为全局库或者

局部库。 如图 16. 24 所示， 本练习把
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库文件添加为全局库， 最后单击 OK 按钮对仿真设置进行确定。 此时， 晶体管

Q2N7777 可以用于电路仿真， 并且 myTransistors. lib 元器件库可以被每个新的仿

真项目使用。

图 16. 24　 将 myTransistors. lib 添加为 PSpice 全局元器件库

练习 3
在练习 2 中， Q2N7777 模型名称的第一个字母为 Q， 所以该模型被确认为晶

体管， 并且模型类型为 NPN 型。 因此， 根据该模型生成的元器件符号为 NPN 晶

体管。 如果模型名称的开头字母为 X， 则该模型为子电路， 生成的元器件符号为

矩形框， 然后在 Capture 中通过元器件编辑器对其进行编辑。 在元器件库中选中

元件， 然后选择 rmb > Edit Part 对其进行编辑。 例如， 很多功率 MOSFET 模型

被定义为子电路。
在模型编辑器， 可以通过 Model Import Wizard 模型导入向导为模型选择已有

的 Capture 元件符号， 而不必在元器件编辑器中进行编辑。
1. 从开始菜单打开模型编辑器： All Programs > Cadence （or OrCAD） >

PSpice > Simulation Accessories > Model Editor。
2. 选择 File > Open 然后通过浏览选择 myTransistors. lib 库文件。 在模型列

表中单击 Q2N7777， 其模型文件将显示出来。 但是添加的第一行注释行的内容并

不能进行显示。
3. 在模型编辑器窗口中选择菜单 View > Extract model 然后单击 YES。 将

会出现 8 条晶体管模型的特性曲线。
4. 选择菜单 File > Export to Capture Part Library 导出 Capture 元器件库。
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如图 16. 5 所示， 如果 Capture 选项不可用， 那么选择菜单 Tools > Options， 然

后选择 Capture 作为原理图编辑器即可。
如图 16. 25 所示， 在 Create parts for Library window 创建元器件库窗口中可以

看到， 元器件符号输出库文件和 PSpice 模型库文件保存在相同的文件夹中。 单

击 OK 按钮， 如果出现对话窗口询问是否保存库， 单击 Yes 即可。 元器件符号库

创建之后将会出现转换信息窗口， 如果报告内容为无任何错误， 则转换成功。

图 16. 25　 Capture 元器件和 PSpice 模型库文件地址

练习 4
还可以在模型编辑器中对已有的 PSpice 模型文件进行复制。
1. 在模型编辑器中， 从 PSpice 库文件夹中打开 bipolar. lib 元器件库。
2. 选择菜单 Model > Copy From， 将会出现如图 16. 26 所示的 Copy Model

模型复制窗口， 在 New Model 新模型对话框中输入 Q2N3906X 作为新模型的名

称， 然后从库元器件列表中选择 Q2N3906 并单击 OK 按钮进行确定。

图 16. 26　 复制 PSpice 模型

练习 5
利用模型编辑器可以建立新的 PSpice 模型。 在演示版的 PSpice 软件中， 利
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用模型编辑器只能建立二极管模型。
模型编辑器主要通过以下两种方式建立 PSpice 模型： Use Templates 和 Use

图 16. 27　 建立新的 PSpice 模型

Device Characteristic Curves。
Use Templates 利用参数建立

模型， 主要用于 PSpice 高级

分析软件， 本书不做介绍。
本练习主要#使用 Use Device
Characteristic Curves， 根据元

器件特性曲线建立新模型。
1. 在模型编辑器中选择

菜单 File > New。
2. 选择 Model > New，

然后在图 16. 27 所示的窗口

中输入模型名称， 并且在下

拉菜单中选择模型类型。
3. 对其他不同类型的模

型分别进行练习。



第 17 章
传　 输　 线

高速信号通过传输线时， 其信号完整性取决于信号的频率和传输线的发散损

耗。 信号功率损耗随着导体电阻 （趋肤效应） 的增加、 电介质 （介电损耗） 电

导的增加和信号频率的增加而增大。 发散使信号波形产生失真， 主要由信号的延

迟造成， 而延迟主要由传输线分布电感和分布电容引起。 信号反射主要由于阻抗

失配造成， 也会造成能量损耗和分散， 最终导致传输线性能降低。
PSpice 中的理想传输线模型和有损传输线模型主要由 Tline 分布模型和

TLUMP 集总模型构成。

17. 1　 理想传输线

理想传输线的标准参数为特征阻抗 （Z0） 和传输延迟时间 （TD） 或者其归

一化传输线长度 （NL）， 其中 NL 为特定频率下传输某长度所需的波形数目， 设

置传输线参数时， 不能同时输入 TD 和 NL。 如果不能确定 NL 的频率， 则默认频

率为 0. 25， 它表示波形频率的四分之一。
传输线的延迟时间 TD 的计算公式为

TD = LEN
vP

（17. 1）

式中， TD 为传输延迟， 单位为秒 （s）； LEN 为传输线长度， 单位为米 （m）； vP
为信号传播速度， 单位为米 /秒 （m / s）。 对于传输线， 其传播速度通常用光速的

百分比表示， 即：
vP = c × VF （17. 2）

式中， VF 为速度因子， 其值为 0 ～ 1； c 为光速， 其值为 3 × 108m / s。
归一化的传输线长度计算公式为

NL = LEN
λ （17. 3）

因为 v = fλ， 所以波形长度公式为



第 17 章　 传　 输　 线 201　　

λ =
vP
f （17. 4）

根据转换公式， 等式 （17. 3） 可以重新写为

NL = LEN f
vP

（17. 5）

式中， f 为信号频率， 单位 Hz； λ 为信号波长， 单位 m。
PSpice 使用 analog 模型库中的元器件 T 对理想传输线进行模拟。 图 17. 1a 为

理想传输线的 Capture 符号， 图 17. 1b 为理想传输线的相关属性。

图 17. 1　 分布型理想传输线

a） Capture 元器件符号： T　 b） 分布型传输线的相关属性参数
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因此， 对于理想传输线， 如果不能确定其延迟时间 （TD）， 可以按照如上所

述输入 NL 和 f 的值均可， 如果频率 f 的值为空， 则其默认值为 0. 25， 即波形频

率的四分之一。
传输线也可以进行电压和电流等初始条件的设置， 以便仿真结果更加准确、

可靠。

图 17. 2　 传输线的 RLCG 集总单元

17. 2　 有损传输线

如图 17. 2 所示， 传输线可

以认为由许多相同的 RLCG 集

总单元构成， R 表示线路电阻；
L 表示线路电感； C 表示电介质

容抗； G 表示电介质导纳。 对

于长距离的传输线路， 可以等

效为许多 RLCG 集总单元顺次

连 接 而 成。 PSpice 专 门 提 供

Tline 传输线元件库， 并且规定最多允许 128 个 RLCG 集总单元相互连接。 但

是当许多单元连接在一起进行电路仿真时， 将需要大量的计算时间， 所以仿

真时间会比较长。
Tline 元件库中也包含简单的 RC 传输线模型， 例如， 有超过 40 种的同轴电

缆模型和双绞线模型可供用户使用。
有损传输线的另一种表示形式为分布模型， 该模型通过脉冲响应卷积的方法

确定传输线的响应。 如图 17. 3 所示为 PSpice 软件中 TLOSSY 元器件符号及其属

性编辑器中的相关属性。
传输线的长度由 LEN 设置， R、 L、 C 和 G 分别表示单位长度传输线的电阻、

电感、 容抗和导纳。

　 　 注意：
仿真分布式传输线模型时的最大步长为传输线延迟时间 TD 的二分之一。

因此， 当对短距离的传输线进行仿真分析时， 使用分布式传输线模型比使用集

总式传输线模型仿真时间要长得多。
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图 17. 3　 有损传输线 TLOSSY
a） Capture 元器件符号： TLOSSY　 b） TLOSSY 的相关属性

17. 3　 本章练习

通过下面练习对基本的传输线负载特性进行仿真分析。
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练习 1
RL 负载阻抗匹配

1. 绘制如图 17. 4 所示的电路图。 传输线 T 选自 analog 元件库， 脉冲电压源

选自 source 元件库。 当在电路图中放置负载电阻 RL 时， 电阻的引脚 1 在左侧。
对电阻 RL 进行三次旋转， 引脚 1 将位于电阻的顶端， 然后与传输线 T1 进行连

接。 通常情况下， 流进引脚 1 的电流为正， 如果测得引脚 1 的电流为负， 则表示

有电流从引脚 1 流出。

图 17. 4　 传输线的输入源和负载阻抗匹配

图 17. 5　 设置 TD 和 Z0 的属性值

2. 双击 T1， 打开属性编辑器，
按照图 17. 5 所示对其相关属性值进

行设置。
按住 Ctrl 键选中 TD 和 Z0， 单

击右键选择 Display， 然后在图 17. 6
的显示属性窗口中选择 Name and Value 对其名称和参数值进行显示。

图 17. 6　 显示 TD 和 Z0 的属性值
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3. 如图 17. 7 所示， 建立瞬态仿真设置文件， 运行时间为 50ns， 最大步长

为 100ps。

图 17. 7　 瞬态仿真设置

图 17. 8　 放置电压探针

4. 如图 17. 8 所示， 在入

射和反射节点放置电压探针，
然后对电路运行仿真分析。

5. 如图 17. 9 所示为脉冲

源的电压波形和 10ns 延时后的

负载脉冲电压波形。 因为输入

脉冲源的内阻和传输线构成分压器， 所以电压幅值降为 5V。
6. 如图 17. 10 所示， 在原理图中删除电压探针， 然后在传输线 T1 的输入引

脚和电阻 RL 的顶部引脚放置电流探针。
不必重新运行仿真， 电流波形会自动显示在 Probe 屏幕图形显示窗口中。 如

图 17. 11 所示， 两电流波形幅度相同， 但是延时 10ns。
当负载阻抗与传输线阻抗相等时称为阻抗匹配， 此时不会出现反射电压。
RL 负载短路

7. 删除电流探针， 然后把负载电阻的参数值修改为 1μΩ， 即负载短路。 如

图 17. 12 所示， 在传输线的入射点和短路电阻的顶端分别放置电压探针， 然后对
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图 17. 9　 阻抗匹配时的电压波形

图 17. 10　 放置电流探针

图 17. 11　 传输线阻抗匹配时的电流波形

电路重新运行仿真。



第 17 章　 传　 输　 线 207　　

图 17. 12　 负载短路

传输线的动态波形如图 17. 13 所示。 当负载短路时， 负载电压为 0V， 入射

电压波形将进行 180°反相。

图 17. 13　 传输线短路时的电压波形

8. 如图 17. 14 所示， 在 Capture 原理图中删除电压探针， 然后在传输线 T1
的入射端和负载电阻 RL 的顶端放置电流探针。

图 17. 14　 放置电流探针
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如图 17. 15 所示， 电流波形将以相同的幅度进行反射， 使得反射电流的幅度

为入射电流幅度的两倍。

图 17. 15　 传输线短路时的电流波形

RL 负载开路

9. 删除电流探针， 然后把负载电阻的参数值修改为 1TΩ， 即负载开路。 如

图 17. 16 所示， 在传输线的入射端和开路电阻的顶端分别放置电压探针， 然后对

电路重新运行仿真。

图 17. 16　 放置电压探针

传输线的动态波形如图 17. 17 所示。 反射电压等于电源电压， 所以在信号传

输过程中反射电压的幅度加倍。
10. 在 Capture 原理图中删除电压探针， 然后在传输线 T1 的入射端和负载电

阻 RL 的顶端放置电流探针。 不必对电路重新运行仿真， 电流波形将自动显示在

Prober 图形显示窗口中。 因为负载开路， 所以输出电流为 0。 如图 17. 18 所示，
开路电流将会以同样的幅度反射回入射端， 但是相位差为 180°。

练习 2
驻波比 （SWR）
如图 17. 19 所示为负载短路时的无损传输线电路。 在图 17. 13 中， 入射电压
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图 17. 17　 传输线开路时的电压波形

图 17. 18　 传输线开路时的电流波形

图 17. 19　 负载短路时的驻波电路

以等幅度 180°反相进行反射。 入射信号和反射信号叠加在一起形成驻波， 下面
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对驻波的形成过程进行说明。
负载短路时的 SWR
1. 删除电路中的电流探针， 把负载电阻 RL 的参数值修改为 1μΩ， 即负载

短路。 删除脉冲电压源 V1， 从 source 元件库中选择 VAC 交流源对其进行代替。
如前面章节所述， 对同一传输线不能同时设置其 TD 和 NL 参数值。 可以通

过属性编辑器删除 TD 属性， 或者使用新的传输线进行替换。
2. 删除传输线 T1。
3. 从 analog 元件库中选择传输线 T 放置于电路中。
4. 接下来对传输线的 NL 值进行修改。 首先在属性编辑器中对 NL 属性值进

行参数化。 如图 17. 20 所示， 通过双击 T 打开其属性编辑器， 选中 NL 属性对话

框， 此时对话框为阴影线， 然后输入 {wavelength}。 当在 NL 参数值对话框输入

字符时， 阴影线会自动消失。 {} 大括号代表该字符为参数变量。 切记不要关闭

属性编辑器， 继续进行设置。

图 17. 20　 设置波长参数值

5. 在属性编辑器中选中波形属性， 然后通过 rmb > Display 对其显示进行

设置， 在图 17. 21 中选择 Name and Value 对其名称和参数值进行显示。 切记不

要关闭属性编辑器， 继续进行设置。

图 17. 21　 显示 NL 属性的名称和参数值
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6. 与图 17. 19 电路中的参数一致， 按照步骤 5 方法继续对电路各元器件的

图 17. 22　 添加新的波长参数， 默认值为 1

参数值及其显示进行设置， 频率 F
设置为 100megHz， 特征阻抗 Z0 设

置为 75R， 设置完成后关闭属性编

辑器。
7. 对波长参数的默认值进行

设置。 从 special 库中选择 Param
元器件放置于电路中， 然后双击

打开 其 属 性 编 辑 器。 选 择 New
Row 或者 New Column 将会出现如

图 17. 22 所示的对话框， 在 Name
栏中输入参数名称 wavelength， 在

Value 栏中输入参数值 1。
8. 显示 wavelength 的名称和参数值， 关闭属性编辑器。
9. 设置完成后电路原理图如图 17. 19 所示。

　 　 注意：
在原理图中对属性参数值进行设置比在属性编辑器中设置更加方便。

10. 下面对电路进行参数扫描和交流扫描分析设置。 选择菜单 PSpice >
New Simulation Profile 创建新的 PSpice 仿真设置文件。 如图 17. 23 所示， 从分

析类型中选择 AC Sweep / Noise 交流扫描分析， 起始频率为 100megHz， 结束频

率为 200megHz， 对数扫描方式， 每 10 倍频的扫描点数为 1。 单击 Apply 按钮对

仿真设置进行确定， 切记不要退出仿真设置窗口。
如图 17. 24 所示， 在 Options 选项中选择 Parametric Sweep 参数扫描， 然后在

扫描变量对话框中选择 global parametric 全局变量， 参数名称设置为 wavelength，
线性扫描方式， 起始值为 0， 结束值为 1， 步长为 0. 01。 设置完成后单击 OK 按

钮进行确定。
11. 在传输线的入射端放置电压探针， 然后运行电路仿真。 在 Available Sec⁃

tions 输出显示窗口中对波形全部选定， 然后单击 OK 按钮进行确定。 将会看到如

图 17. 25 所示的驻波波形。
负载开路时的 SWR
当负载开路时， 电压以相同幅度反射回入射端， 但是相位相差 180°。
12. 在图 17. 26 中， 把负载电阻值修改为 1TΩ， 即负载开路， 然后按照相同

的设置对电路进行仿真。 驻波波形如图 17. 27 所示。
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图 17. 23　 交流扫描设置

图 17. 24　 参数扫描设置
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图 17. 25　 负载短路时的驻波波形

图 17. 26　 负载开路时的驻波电路

图 17. 27　 负载开路时的驻波波形



第 18 章
数字电路仿真

PSpice 使用相同的引擎对模拟器件和数字器件进行仿真分析。 数字晶体管逻

辑阵列 （TTL） 和互补型金属氧化物半导体 （CMOS） 均为数字器件， 主要包括

逻辑门、 寄存器、 触发器和反相器等， 该类器件的 PSpice 模型由子电路建立。
在每个子电路中， 最原始的数字器件不仅构成门电路功能 （与门、 或门等）， 还

定义了门电路的延时和接口规范。 其他的数字器件还包括延迟线、 模 - 数转换

（A - D）、 数 -模转换 （D - A）、 RAM、 ROM 和可编程逻辑阵列。

18. 1　 数字器件模型

二输入 CMOS 与非门的 PSpice 模型定义如下：
　 　 CD4011B　 CMOS NAND GATE QUAD 2 INPUTS

　 　 The CMOS Integrated Circuits Data Book， 1983， RCA

Solid State

　 　 tvh　 09/29/89 Update interface and model names

. subckt CD4011B　 A B J

+ 　 　 optional： VDD = G CD4000 VDD VSS = G CD4000 VSS

+ 　 　 params： MNTYMXDLY =0 IO LEVEL =0

U1 nand（2） VDD VSS

+ 　 　 A B　 J

+ 　 　 D CD4011B 　 IO 4000B 　 MNTYMXDLY = {MNTYMXDLY} IO

LEVEL ={IO LEVEL}

. ends
模型语句的前五行为注释行， 主要对该模型的名称、 功能以及器件生产和模
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型建立日期进行说明。 第六行为 CD4011B 的子电路模型定义， 包括模型名称和

引脚 A、 B 和 J。 VDD = G CD4000 VDD 和 VSS = G CD4000 VSS 为全局电

源， 专门为 CD4000 系列的数字电路供电。 MNTYMXDLY = 0 为可选参数， 用来

定义数字门电路的最小、 典型和最大延迟时间。 当数字电路与模拟电路进行连接

时， IO LEVEL 用来定义模 - 数 （A - D） 或者数 - 模 （D - A） 转换的四个数

字接口子电路。
U1 定义了一个双输入与非门， 输入接口分别为 VDD、 VSS、 A、 B 和 J。

“ + ” 表示模型语句还未结束， 继续延续到下一行。 下一行 （第 11 行） 出现两

个型号， 第一个为时序模型 D CD4011B， 它定义了与非门的时序特性， 例如信

号的延迟、 建立和保持时间； 第二个为输入 /输出 （I / O） 模型 IO 4000B， 用来

定义门电路的负载和驱动特性。 如第 12 行所示， 子电路模型通常以 “. ENDS”
语句结束。 时序模型 D CD4011B 保存在 CD4000. lib 元件库中； 输入 /输出 （I /
O） 模型 IO 4000B 保存在 dig io. lib 元件库中。 如果需要更加详细的模型信

息， 请查阅 PSpice 参考手册。

18. 2　 数字电路设计

通常情况下数字门电路的电源引脚不进行显示， 因为对数字门电路的电源引

脚与供电电源进行连接时需要大量的导线， 将会使得电路过于复杂。 相反， TTL
和 CMOS 器件会自动与全局电源节点相连接， 该节点并未显示在电路图中， 但是

具有电源的功能， 并且默认值为 5V。 CMOS 器件的电源电压范围为 3 ～ 18V。 但

是 CMOS 器件的供电电压改变时不会影响其输入阈值和输出驱动能力， 但是信号

延迟时间由 5V 供电时的特性决定。 通过修改数字门电路的时序模型可以获得准

确的信号延迟时间。

图 18. 1
a） 数字高 HI　 b） 数字低 LO　 c） 上拉电阻　 d） 断开

通过选择菜单 Place > Pow⁃
er 元器件库中的数字高 HI、 数

字低 LO 元件符号或者 dig misc
元器件库中的上拉电阻， 可以

把集成电路 （ IC） 引脚的数字

逻辑电平设置为高或者低。 No
Connect 为断开符号， 通过 Place
放置菜单对其进行放置， 用来

标识未连接引脚。 图 18. 1 为

Capture 中相关的元器件符号。
在图 18. 2 中， 某数字时钟信号与 8 位二进制计数器 （U1A 和 U1B） 相连
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接。 为了使计数器正常工作， U1A 和 U1B 的 CLR 清零端通过数字低 LO 符号连

接至低电平。 选择菜单 Place > Bus Entry、 点击图标 或者按下键盘 E 键

在每个计数器输出端放置总线接口， 然后把所有接口与 8 位数据总线相连接。

图 18. 2　 四位计数器输出与 8 位总线连接

　 　 注意：
从 16. 3 版本开始， 元件引脚可以与数据总线自动连接。 绘制数据总线， 然

后选择菜单 Place > Auto Wire > Connect to Bus。 首先单击待连接引脚， 然后

单击总线 （将会提示输入网络名称）。 PSpice 将会自动绘制总线接口和引脚之

间的连接导线。

与总线接口相连接的每条导线分别标记为 D1、 D2 等， 总线名称为 D [8 -
1]， 其次序按照 MSB - LSB 进行排列。 元件 U3 的数据输入总线的名称也为 D
[8 - 1]， 因此该总线将与 8 位总线相连接。 根据仿真习惯， 数据总线也可以被

命名为 D [7 - 0] 或者 D [7. . 0]。 只有相同类型的信号才能由总线连接， Cap⁃
ture 无法定义混合总线。 然而， 在 Probe 图形显示窗口中， 不同类型的信号可以

整理到一起， 以总线的形式进行显示。 在总线上放置探针与在导线上放置探针完

全一样， 非常方便实用。

18. 3　 数字仿真设置

如图 18. 3 所示， 在仿真设置窗口中选择 Option 选项卡， 然后在 Category 对
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话框中选择 Gate - level Simulation， 可以对电路进行数字仿真设置。 在 Timing
Mode 时序模式选项中， 可以为数字器件配置最小、 最典型、 最大或者最坏情况

下的时序特性。 有四种 I / O 接口可以用于模 - 数 （A - D） 和数 - 模 （D - A）
转换。 最重要的是， 可以按照设计要求对触发器的工作状态进行初始化， 例如 x
不确定、 逻辑 0 或者逻辑 1。 也可以通过设置对仿真过程中出现的错误信息进行

抑制， 例如 PSpice 将会对数字电路的竞争冒险和时序冲突进行错误信息输出，
该数据量非常大， 将会影响仿真速度。

图 18. 3　 数字仿真设置选项

18. 4　 数字信号波形显示

数字信号通常以高、 低逻辑电平的形式进行显示。 然而， 当信号进行高

低转换时， 在转换期间信号的状态不能确定， 上升和下降转换波形如图

18. 4 中的黄色区域显示。 如图 18. 4 所示， 两条红线表示未知状态， 三条蓝

线表示高阻状态。
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　 　 注意：
常见的错误是未对寄存器 （触发器） 电路进行初始化， 这将导致仿真输出

波形中出现两条红线， 以表示仿真时有未知状态。 如图 18. 3 所示， 仿真数字电

路时， 一定要对触发器进行初始化。

图 18. 4　 Probe 中的数字信号显示

　 　 图 18. 4 中从上到下依次为数字高、
数字低、 未知状态、 上升转换、 下降转

换和高阻状态。
在 Probe 屏幕图形显示窗口中， 可

以把数字信号进行分组以总线的形式进

行显示。 在 Trace > Add Trace 窗口中

的 Trace Expression 曲线表达式对话框中

输入总线名称。 一条总线最多可以包含

32 个数字信号， 这些信号按照 MSB 至

LSB 的顺序进行排列， 默认为十六进制，
也可以设置为十进制、 八进制或者二进

制。 例如：
{D4 D3 D2 D1}； myBus； d　 总线

名称为 myBus， 以十进制形式对数字信号 D4 至 D1 （MSB - LSB） 进行显示。
{WR RD CE}； control； b　 总线名称为 control， 以二进制形式对总线进行

显示。
在图 18. 5 中， 总线 QB [8：1] 以默认十六进制形式进行显示。 数字总线

Dbus 是一组数字信号的集合， 分别以十六进制、 十进制和二进制形式进行显示。

图 18. 5　 数字信号分别以十六进制、 十进制和二进制形式显示
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18. 5　 本章练习

练习 1
对模量 3 型同步计数器的输出时序进行校验。
1. 建立名称为 Mod 3 Counter 的仿真项目。 将名称为 SCHEMATIC1 的原理

图重命名为 counter， 然后按照图 18. 6 所示绘制模量 3 型同步计数器的原理图。
数字触发器和或门选自 CD4000 元器件库。 通过 Place 菜单或者按键盘上的 “F”
键放置数字 HI 和 LO 符号。 digClock 为数字激励源， 选自 source 元器件库。

图 18. 6　 模量 3 型同步计数器

2. 选择菜单 Place > Net Alias 或者按键盘上的 “N” 键对网络节点进行

命名。
3. 建立 PSpice 仿真配置文件， 仿真时间为 100μs， 然后如图 18. 7 所示， 选

择 Options > Category： Gate - level simulation 并且设置所有触发器的初始值

Initialize all flip - flops 为 0。
4. 在节点 CLK、 QA 和 QB 处放置电压探针。
5. 对电路运行仿真分析。 波形将会按照电压探针放置的顺序进行显示。 在

屏幕图形显示窗口中， 可以对波形重新进行排序， 例如 CLK 位于顶部， 然后从

上到下依次为 QA 和 QB。 可以通过剪切和粘贴命令实现上述功能。 选择波形名

称 CLK 然后按下 control - X， 波形将被删除， 然后按下 control - V 对波形进行粘

贴。 从图 18. 8 可以看到， 波形 QA 和 QB 的初始值均为逻辑 0。
6. 打开光标， 并且将光标沿着波形移动。 如图 18. 8 所示， 光标处所对应的

逻辑电平将会显示在 Y 轴上。 从图 18. 8 可以看出， 触发器的输出电平仅在时钟

信号为下降沿时进行改变。 所以 CD4027 触发器为下降沿触发。
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图 18. 7　 触发器的初始值设置为 0

图 18. 8　 数字计数器波形

7. 添加总线， 并对其进行二进制数显示。 选择菜单 Trace > Add， 然后在曲

线表达式对话框中输入：
{QB，QA}； count b； b

最后单击 OK 按钮， 波形将以二进制形式进行显示。
8. 选择菜单 Trace > Add， 然后在曲线表达式对话框中输入：
{QB，QA}； count d； d

最后单击 OK 按钮， 波形将以十进制形式进行显示。
9. 选择菜单 Trace > Add， 然后在曲线表达式对话框中输入：
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{QB，QA}； count h； h

最后单击 OK 按钮， 波形将以十六进制形式进行显示。
10. 波形类似于图 18. 9 所示， 模量 3 型计数器的计数顺序为 0、 1、 2、 0、

1、 2、 0 等。

图 18. 9　 计数器的输出数字波形

练习 2
图 18. 10 所示电路主要用于练习信号与总线的连接和 IC 模块内部 A 和 B 不

同部件的选择。 时钟信号首先由两个 4 位二进制计数器 U1A 和 U1B 进行分频，
然后再通过两个八进制缓存器 U2 和 U3， 最后进入 8 位总线。 U3 为八路反相缓

存器。

图 18. 10　 信号与总线连接
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图 18. 11　 同一器件的不同部件选择

1. 如图 18. 11 所示， Packaging
窗口中 74HC393 包含两个相同的部

件 A 和 B。 当选择部件 B 时， 器件

的引脚编号也会相应发生变化。
2. 放置如图 18. 10 所示电路的

器件， 切记不要进行导线和总线的

连接。 DSTM1 为数字时钟信号源，
选自 source 元器件库， HC 类数字元

器件选自 74HC 元器件库。 选择菜

单 Place > Power 放置 HI 和 LO 元器件符号。
3. 在电路中绘制总线。 绘制倾斜总线步骤如下： 按住 shift 键， 然后单击鼠

标左键确定倾斜角度， 最后绘制总线。
4. 如图 18. 10 所示， 从器件 U1A 的 3 引脚开始， 在引脚和总线之间放置总

线接口。 然后在总线接口和 U1A 的引脚 3 之间绘制导线， 对其进行连接。
5. 选择导线然后放置网络标识 （按 N 键）， 对该导线命名为 D1。 按 escape

键或者 rmb > End Mode 退出网络命名。

图 18. 12　 选择导线、 总线接口和网络名称

6. 如图 18. 12 所示， 在导线、
网络名称和总线接口周围绘制选

择框。
7. 按住 Ctrl 键， 然后将光标

放在导线上并将其拖至引脚 4。 网

络名称将自动更改变为 D2。 当导

线处于选定状态时， 按 F4 键两

次， 将会出现两个网络 D3 和 D4，
使用该方法， 可以快速进行网络

连接。

　 　 注意：
在 16. 3 版本中， PSpice 可以实现两节点的自动连线： 首先选择菜单

Place > Auto Wire 或者点击图标 ， 然后选择需要连线的两节点， 之后两节

点将会进行自动连线。 PSpice 的另一项新功能为 Place > Auto Wire > Con⁃
nect to bus， 即导线和总线自动连接。 首先单击需要连接的引脚， 然后单击总

线， 导线和总线接口将会自动连接。 在连接过程中 PSpice 将会提醒用户输入网

络节点名称。
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如果软件版本为 16. 3， 继续执行步骤 8； 否则， 直接转到步骤 9。
8. 选择菜单 Place > Auto Wire > Connect to bus 或者点击图标 ， 对

图 18. 10 中 IC 的其余引脚进行自动连线。
9. 选择菜单 Place Net > Alias 对总线进行命名， 使得总线名称与导线名称

一致。 对总线命名时， 一定要确保三条总线按照 MSB - LSB 的顺序标记正确。
10. 对电路进行瞬态仿真分析设置， 运行时间为 10μs。 如图 18. 13 所示， 在

设置窗口中选择 Options > Category： Gate - level simulation， 然后在 Initialize
all flip - flops 对话框中选择 0， 设置所有触发器的初始值为 0。

图 18. 13　 触发器的初始值设置为 0

11. 如图 18. 10 所示， 在每条总线上面放置电压探针， 然后运行电路仿真。
12. 如图 18. 14 所示， 总线 D [8 - 1] 和 QA [8 - 1] 按照递增的形式进行

计数。 因为 U3 是反相缓冲器， 所以 QB [8 - 1] 的起始值为 FF， 并且以递减的

形式进行计数。 将仿真输出波形与图 18. 14 中波形进行对比， 检验输出结果是否

正确。
13. 选择菜单 Trace > Delete All Traces 删除所有波形。
14. 选择菜单 Trace > Add Trace。 然后在右侧的函数和宏模型列表中选择

大括号 {}， Trace Expression 波形表达式对话框中将会出现 {}， 并且光标在大

括号 {} 中间， 等待选择波形名称。
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图 18. 14　 数字总线波形

15. 依次选择 D4、 D3、 D2、 D1。 然后输入如下文字表达式， 单击 OK 按钮

进行确定：
{D4，D3，D2，D1}；myBus；d
16. 创建名称为 nibble 的数据总线， 总线由 QA4、 QA3、 QA2 和 QA1 构成，

以二进制显示总线：
{QA4 QA3 QA1 QA2}；nibble； b

输入波形如图 18. 15 所示。

图 18. 15　 自定义总线名称， myBus 和 nibble

17. 在 Capture 中， 对引脚进行使能设置 （G）， 通过菜单 Place > Power 选

择 D HI 数字高电平符号， 把芯片 U2 的 1 和 19 引脚设置为高电平。 对电路重

新运行仿真。
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图 18. 16　 最近放置元器件列表

　 　 提示：
如图 18. 16 所示， 从最近放

置元器件列表中选择 D HI 符

号放置于电路中。 如果该符号未

出现在下拉列表中， 在对话框中

输入 D HI， 然后按下回车键

即可。

18. 运行电路仿真。
19. 如图 18. 17 所示， 波形 QA [8 - 1] 显示为 X㊀， 表明该信号为高阻抗三

态输出。

图 18. 17　 芯片 U2 各引脚高阻抗输出

练习 3
PSpice 输出报告提示设置时间、 保持时间和最小脉冲宽度相冲突， 不符合设

置规则。 通过减小时钟脉冲宽度， 对错误报告进行研究。
1. 改变时钟关断时间 OFFTIME 为 0. 01μs， 开通时间 ONTIME 为 0. 01μs。
2. 仿真时间从 10μs 减小为 1μs。
3. 运行电路仿真。
4. 仿真信息窗口如图 18. 18 所示。

㊀　 原书中 X 写为 Z， 出现错误。 ———译者注
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　 　 5. 单击 OK 按钮， 将会看到如图 18. 18 所示的警告信息列表。

图 18. 18　 仿真信息数量

6. 在图 18. 19 中， Minimum Severity Level 最低安全等级对话框的下拉菜单

中列出了如下安全等级： 致命等级、 严重等级、 警告和信息等级。 当出现致命等

级时， 电路停止仿真。 设置安全等级为 Warning 警告等级， 然后单击 Plot 按钮对

设置进行确定。

图 18. 19　 警告信息列表

图 18. 20　 警告信息

　 　 7. 如图 18. 20 所示为警告

信息， 该信息显示什么时刻、 什

么元器件仿真时出现警告。 该消

息不仅提供警告发生的时间， 而

且指定出现警告的原因。 同时， PSpice 还提供警告出现的时序波形。
每选择一条消息将打开一个新的屏幕图形显示窗口， 以显示该信息所对应的

时序波形。
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PSpice 使用相同的仿真引擎进行模拟和数字电路分析。 在 Probe 屏幕图形显

示窗口中， 仿真结果共同使用同一时间轴， 但是分别独立显示于模拟和数字波形

窗口中。 在电路中， 模拟和数字器件在节点处进行连接。 PSpice 包含三种类型的

连接节点： 模拟节点， 连接该节点的所有器件均为模拟器件； 数字节点， 连接该

节点的所有器件均为数字器件； 连接接口， 用于模拟和数字器件混合连接。 连接

接口自动分离成一个模拟节点和一个或多个数字节点， 然后该节点与模拟和数字

接口子电路相连接， 这些节点主要用于模 - 数转换 （A - D） 或者数 - 模转换

（D - A） 接口子电路。 这些子电路具有各自的供电电源。 上述过程在后台自动

完成， 所以通常不必为接口子电路担心， 在 Probe 屏幕图形显示窗口中可以对子

电路接口波形进行观测。
图 19. 1 为模拟比较器电路， 该电路由集电极开路晶体管和数字门电路组成。

图 19. 1　 模拟比较器驱动数字门电路
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上拉电阻与数字电源相连接， 比较器的输出信号地与数字信号地相连接。 图

19. 2 为仿真输出波形， 数字信号波形显示于 Probe 上部， 模拟信号波形显示于

Probe 下部。
模拟和数字混合电路仿真步骤与纯模拟、 纯数字电路仿真一致， 首先在电路

图中放置元件， 然后创建仿真设置文件， 最后对电路运行仿真。

图 19. 2　 模拟和数字信号波形

19. 1　 本章练习

练习 1
图 19. 3 为数 -模转换电路 （D - A）， 该电路由数 -模转换芯片 AD7224 和输入

数字信号 01111111 构成。 从芯片生产商提供的数据资料可以求得输出电压为

Vo = VREF × 127
256 = 4. 96V （19. 1）

数 -模转换芯片 DAC 的时钟周期已经按照生产商的数据手册进行设置。
1. 绘制如图 19. 3 所示的电路图。 AD7224 芯片选自 DATACONV 元器件库，

DigClock 激励源选自 source 元器件库。
2. 对电路进行瞬态仿真分析设置， 运行时间为 5μs。 在仿真设置窗口中选择

Options 选项， 如图 19. 4 所示， 选择 Category > Gate - level Simulation， 然后设

置触发器的初始值 Initialize all flip - flops 为 0。 仿真设置完成后关闭窗口。
3. 在网络节点 LDAC、 WR、 CS 和 OUT 放置电压探针。
4. 运行电路仿真。
5. 在 Probe 屏幕图形显示窗口中， 如图 19. 5 所示， 上面为数字信号波形，

下面为输出模拟信号 OUT 波形。
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图 19. 3　 由 AD7224 构成的数 -模转换电路

图 19. 4　 触发器的初始值设置为 0 电平

　 　 6. 打开光标， 测试输出电压值为 4. 96V， 与计算值一致。
练习 2
图 19. 6 为通用的 NE555 定时器电路， 该电路应用非常广泛。 NE555 定时计

算公式为
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图 19. 5　 模拟和数字波形

f = 1. 44
（RA +2RB）C （19. 2）

Dutycycle = RA + RB
RA +2RB （19. 3）

按照图 19. 6 中的元件参数进行计算， 振荡时钟的频率为 218Hz， 占空比

为 0. 67。

图 19. 6　 NE555 时钟振荡器

1. 创建新仿真项目， 名称为 Clock Oscillator。 重命名 SCHEMATIC1 为 clock，
绘制如图 19. 6 所示的电路图。 芯片 555 选自 anl misc 元件库。 555 有三种型号：
555alt、 555B 和 555C， 每种型号的引脚布局都不一样。 仿真时利用 IC1 对电容

C1 进行初始值设置， IC1 保存在 special 元件库中。
2. 创建瞬态仿真设置文件， 仿真时间为 20ms。 在 VC 和 OUT 网络节点放置
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电压探针。
3. 运行电路仿真。
4. 显示光标数值， 确定振荡周期， 然后根据周期计算振荡频率。
5. 确定占空比， 即开通时间与关断时间的比值。
6. 选择菜单 Trace > Evaluate Measurement 对波形周期进行测量， 首先选择

Period （1） 然后选择 V （OUT）， 测量表达式如下：
Period（V（OUT））

7. 选择菜单 Trace > Evaluate Measurement 对指定范围的波形周期进行测

量， 首先选择 Period XRange， （1， begin x， end x）， 然后选择 V （OUT），
接着输入 5m 和 20m， 测量表达式如下：

Period XRange（V（out），5m，20m）

8. 选择菜单 Trace > Evaluate Measurement 对波形占空比进行测量， 首先选

择 DutyCycle （1）， 然后选择 V （OUT）， 测量表达式如下：
DutyCycle（V（OUT））

9. 如果测量结果未显示在屏幕图形显示窗口中， 选择菜单 View >Measure⁃
ment Results 对测量结果进行查看。 仿真结果应该与图 19. 7 所示相似。

图 19. 7　 仿真结果和测量值

Cadence \ OrCAD 安装软件中包含模拟、 数字和模数混合电路仿真实例， 每

种实例均放置在相应的文件夹中。 各种仿真实例可以在安装路径中进行查找，
例如：

<install path > \Cadence \SPB 16. 3 \tools \PSpice \capture
samples \

<install path > \Cadence \OrCAD 16. 3 \tools \PSpice \capture
samples \
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在 Capture 中， 仿真项目可以设计成平板式和层次式两种结构。 平板式设计

中， 信号在不同的电路图页之间进行连接； 层次式设计中， 整体电路分成不同的

图 20. 1　 项目文件结构

a） 平板式设计　 b） 层设计

功能模块， 信号在顶层和底层之

间进行传输。 如图 20. 1 所示，
平板式设计只有一个包含多个相

互关联页的原理图文件夹； 而层

次式设计可以包含多个原理图文

件夹。 在层次结构的原理图中，
每个原理图文件夹对应一个层模

块。 通过选择层模块， 可以选择

底层原理图， 并且可以打开模

块， 进入下层原理图进行查看和

编辑。
如图 20. 1 所示的平板式设

计项目由一个原理图文件夹构

成， 该原理图包含三张图纸， 层

次式设计由三个原理图文件夹构

成， 每层中的文件夹都有各自的

电路图。
如图 20. 2a 所示的项目管理器包含两个原理图文件夹， 分别为 Top 和

Bottom， 对应的原理图分别为图 20. 2b 和图 20. 2c。 图 20. 2b 为 Top 原理图， 由

Bottom 层模块和层引脚 IN 和 OUT 组成。 选定模块， 然后选择 rmb > Descend
Hierarchy可以进入底层模块； 也可以双击层模块打开 Bottom 原理图。 层模块和

原理图通过层引脚进行连接， Bottom 层模块的引脚与 Bottom 原理图接口具有相

同的名称 IN 和 OUT。
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图 20. 2　 层次式设计项目

a） 项目管理器　 b） 顶层原理图　 c） 底层原理图

图 20. 3　 利用层次结构显示每个

元件的所属位置

　 　 在项目管理器中， File 文件选

项卡和 Hierarchy 层选项卡布置在

一起。 通过选择 Hierarchy 层选项

卡， 可以对设计项目每个元件的所

属位置进行查看。 如图 20. 3 所示，
顶层原理图由一个电阻 R1、 一个

电压源 V1 和 HB1 层模块构成， 底

层原理图由两个电阻构成。

20. 1　 层电路端口连接器

在进行平板式仿真项目设计时， 通常情况下只有一个原理图文件夹和一个或

者多个页面。 为了实现不同页面之间的信号连接， 通常使用如图 20. 4 所示的

Off - page 分页连接器， 选择菜单 Place > Off - Page Connectors 在原理图中放置
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分页连接器。

图 20. 4　 Off - page 分页连接器

数据流向主要包括输入和输出两种类型。 当导线与分页连接器相连接时， 导

线的网络名称与连接器的名称一致。
层模块端口用于层模块之间的信号连接： Place > Hierarchical Ports （见图

20. 5）。 与分页连接器相似， 与层模块端口连接的导线网络的名称与端口名称

一致。

图 20. 5　 放置层模块端口

层模块端口有多种类型， 分别代表不同的数据流向。 图 20. 6 列出了 Capture
中可用的层模块端口类型， 例如 PORTRIGHT - R 为右侧端口， 在该元件符号的

右侧有一个连接端口。 实际设计时使用哪种端口完全由设计人员根据设计需求决

定， 没有严格的规定。
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图 20. 6　 Capture 中可用层模块端口

20. 2　 层电路模块和符号

层模块通常用于顶层—底层由上而下的设计中， 模块放置于顶层电路图中，
并对其添加相关的信号引脚。 然后进入模块所在的电路原理图， 原理图中的引脚

端口数量和名称均与模块定义一致。 层模块不能保存为库文件， 因为在仿真项目

中层模块被保存为原理图文件。
层模块符号通常用于底层—顶层由下而上的设计中， 首先绘制电路原理图，

然后在输入和输出信号节点添加端口。 层模块符号与信号引脚的数量和名称均相

同， 这些符号可以保存为元件库， 以供其他设计项目使用。

20. 2. 1　 层模块设置

如图 20. 7 所示， 选择菜单 Place > Hierarchical Block， 在原理图中创建层

模块。
根据设计需求， 在 Reference 对话框中输入层模块名称， 然后在 Implementa⁃

tion Type 和 Implementation Name 对话框中选择层模块类型、 层模块名称。 如图

20. 8 所示为层模块可选类型， 通过选择类型定义模块功能。 对于 PSpice 仿真项

目， 通常情况下 Implementation Type 选择 Schematic View， Implementation Name 设

置为原理图名称。
层模块设置完成之后， 在电路原理图中绘制矩形方框图， 然后选定该方框并

且选择菜单 Place > Hierarchical Pin 放置层模块引脚。 如图 20. 9 所示为层模块

引脚设置窗口， 在 Name 对话栏中输入引脚名称， 在 Type 对话栏的下拉菜单中

选择引脚类型。 Width 用于设置引脚宽度， 具有总线和矢量两种形式。 接下来可

以把引脚放置于矩形框的周边。
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图 20. 7　 创建层模块

图 20. 8　 配置层模块类型

图 20. 9　 定义层模块引脚
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20. 2. 2　 层模块符号

把电路转化成 Capture 元件符号， 然后由该元件符号代替电路的实际功能。
在电路图中添加层模块端口， 显示方式与层模块引脚一致。 如图 20. 10 所示， 在

Capture 中选择菜单 Tools > Generate Part 生成元件。 在 Netlist / source file type 源

文件类型对话框中选择 Capture Schematic / Design file （. dsn）， 然后为元件库配

置名称和地址， 并且在 Source Schematic name 对话框中选择原理图文件夹名称，
最后单击 OK 按钮生成层模块符号。

图 20. 10　 生成 Capture 层模块符号

20. 3　 参数传递

利用 Special 元件库中的 Subparam 子参数可以实现层电路之间的参数传递。
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这样就可以把不同的参数传递给层模块电路或者层模块符号。 例如， 通过单电阻

对滤波器模块的增益进行设置。 利用 Subparam 子参数元件可以对每个滤波器设

置不同的电阻值， 以实现不同的滤波器增益值。 图 20. 11 中利用 Subparam 子参

数设置 RVAL 为不同的数值， 以实现滤波器模块 HB1 和 HB2 不同增益值的设置。

图 20. 11　 为层模块符号传递 RVAL 子参数值

20. 4　 层模块网络表

PSpice 可以生成层电路网络表， 利用该网络表可以生成子电路。 在图 20. 12
中， 顶层电路引用了两个子电路， X U1 和 X U2， 该子电路的名称为

osc125Hz。 如果不同的元件使用相同的子电路， 在网络表中只定义一次子电路

即可。

20. 5　 本章练习

当建立层仿真设计项目时， 底层原理图中最好不要包括电源。 在原理图中为

层符号和层模块配置电源端口， 所有电源均在顶层进行连接， 这样整体电路的电

源分配可以一目了然。 接地符号对于所有设计均通用， 所以层模块或者层符号不
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图 20. 12　 层电路网络表

必设计接地端口， 除非设计中使用单独的数字地和模拟地。
练习 1
建立如图 20. 13 所示的由顶层至底层的层仿真设计项目， 其中， 顶层的层模

图 20. 13　 层模块仿真项目

块以底层电路图为参考。 注意层

模块不能保存为库文件。
1. 建立名称为 Top Down 的全

新仿真项目。
2. 在 项 目 管 理 器 中， 将

SCHEMATIC1 重命名为 top。
3. 建立名称为 Bottom 的原理

图： 首先选中 Top Down Design. dsn
文件， 然后选择 rmb > New Sche⁃
matic 建立新的仿真原理图， 并且

将其命名为 Bottom。
4. 在项目管理器中选择 Bottom 原理图， 然后选择 rmb > New Page 建立新

页， 并且对其命名为默认名称 Page1。
5. 设置完成后项目管理器如图 20. 14 所示。
6. 打开 Bottom 原理图， 绘制如图 20. 15 所示的电路。 选择菜单 Place > Hi⁃

erarchical Port， 在电路中的 out 节点放置 PORTRIGHT - L 层端口， 在 in 节点放

置 PORTRIGHT - R 层端口。 然后保存并且关闭原理图。
7. 打开顶层原理图。
8. 在项目管理器中选择菜单 Place > Hierarchical Block， 并且输入参考名
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称。 如图 20. 16 所示， 在 Implementation Type 层模块类型中选择 Schematic View；
在 Implementation name 层模块名称对话框中输入 Bottom。 因为所建层模块原理图

属于该仿真项目， 所以 Path and filename 保持为空。 最后单击 OK 按钮对仿真设

置进行确定。

图 20. 14　 层设计项目文件夹

　 　

图 20. 15　 电阻分压器

图 20. 16　 设置层模块及关联原理图

9. 当光标变成十字形时在电路图中单击鼠标一次， 然后绘制矩形框。 底层

原理图中的层端口名称在顶层的层模块中显示为引脚。 在如图 20. 17 所示的方框

中可以根据设计需求移动引脚。
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10. 选择层模块然后 rmb > Descend Hierarchy （或者双击层模块） 将会打

开底层原理图。
11. 在原理图中选择 rmb >Ascend Hierarchy 将会重新回到顶层原理图。
12. 如图 20. 18 所示， 在顶层原理图的层模块输入端放置直流电压源 VDC，

输出端放置电阻。 然后在输出端放置电压探针， 对电路进行直流工作点分析， 测

试输出电压是否为 5V。

图 20. 17　 添加引脚之后的层模块

　

图 20. 18　 测试层模块

图 20. 19　 将 SCHEMATIC1 文件夹

重命名为 osc125Hz

练习 2
建立能保存为库元件的层模块符号。
1. 建立名称为 Hierarchy 的新的仿真

项目。 如图 20. 19 所示， 在项目管理器

中， 将 文 件 夹 SCHEMATIC1 重 命 名

为 osc125Hz。
2. 绘制如图 20. 20 所示的电路。 运

算放大器 AD648 选自 opamp 元器件库。
如果使用的 PSpice 软件为演示版， 则运

算放大器改为 uA741， 从 eval 元器件库

进行选择。 如图 20. 21 所示， 选择菜单

Place > Hierarchical Port 放置层模块端口， 在输出节点 out 放置 PORTRIGHT - L
端口， 在 VCC 和 VSS 电源节点放置 PORTRIGHT - R 端口。 如图 20. 20 所示， 把

电源端口分别命名为 VCC 和 VSS， 并且在每个端口绘制一段短的连接导线。
与层端口 VCC 和 VSS 相连接的导线将自动分别命名为 VCC 和 VSS， 并且与

运算放大器的电源引脚进行连接。
为了使电路产生振荡， 需要把电容的初始电压值设置为 0V。 从 special 元器

件库中选择 IC1 放置于电容 C1 上端， 并且设置 IC = 0， 如图 20. 20 所示。
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图 20. 20　 125Hz 振荡器

图 20. 21　 放置层模块端口

　 　 提示：
当第一次将层端口放置于电路图中时， 其网络名称离端口很远， 旋转端口

四次之后其网络名称将会更加靠近端口。
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3. 保存仿真项目。
4. 在项目管理器中选择设计文件 （Hierarchy. dsn）， 然后选择菜单 Tools >

Generate Part 生成层元器件符号。
5. 在 Generate Part 生成元器件窗口中， 选择 Netlist / source file type： Capture

Schematic / Design， 然后在 Netlist / source file 对话栏中浏览项目文件夹 Hierarchy，
并且选择 Hierarchy. dsn 文件。 切记不要关闭窗口。

6. 为新的层元器件建立元器件库， 在 Destination Part Library 目标元器件库

对话框中选择 Hierarchy 元器件库， 并将其保存在该项目文件夹中， 或者根据设

计需求保存在对应的文件夹中。
7. 一定要注意， 此时 Source Schematic name 对话框显示原理图名称

osc125Hz， 而不是 SCHEMATIC1。 Generate Part 生成元器件窗口如图 20. 22 所示。

图 20. 22　 生成电路图 osc125Hz 的层元器件符号

8. 如果所用 PSpice 为 16. 3 版本， Split Part Section Input spreadsheet 对话窗

口将打开， 在对话框中单击 Save 对设置进行保存， 然后单击 OK 即可。
9. 在项目管理器中， 可以看到 hierarchy. olb 元器件库已经添加到 Outputs 输

出文件夹中。 如图 20. 23 所示， 将 hierarchy. olb 库文件从 Outputs 文件夹转移到

（或者通过剪切和粘贴） Library 文件夹， 展开 Library 文件夹可以看到 osc125Hz
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器件。
10. 在 Hierarchy 元器件库中双击 osc125Hz 器件， 打开元器件编辑器， 元器

件符号如图 20. 24 所示。

图 20. 23　 Hierarchy. olb Capture 元器件库已添加到库文件夹中

图 20. 24　 已生成的 osc125Hz 器件符号

11. 如图 20. 25 所示， 双击 < Value > ， 然后输入 osc125Hz。

图 20. 25　 输入元器件显示名称 osc125Hz

12. 双击 OUT 引脚， 打开其 Pin Properties 引脚属性编辑器， 如图 20. 26 所

示， Shape 设置为 Short， Type 设置为 Output， 引脚数值 Number 设置为 1， 然后

单击 OK 按钮对设置进行确定。
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13. 将 VCC 引脚的 Shape 设置为 Short， Type 设置为 Input， 引脚数值 Number
设置为 2。

14. 将 VSS 引脚的 Shape 设置为 Short， Type 设置为 Input， 引脚数值 Number
设置为 3。

图 20. 26　 设置元件 osc125Hz 的引脚属性

15. 如图 20. 27 所示， 在元器件编辑器的任意位置双击鼠标左键， 打开 User
Properties 属性对话框。 选中 Pin Numbers Visible， 然后在下拉菜单中选择 True。
单击 OK 按钮进行确定。

16. 将 output 输出引脚从左侧移到右侧， 并且重新调整元器件尺寸。 修改后

的 osc125Hz 器件符号类似于图 20. 28。

图 20. 27　 属性编辑器

17. 在元器件编辑器中双击鼠标左键， 打开 User Properties 属性编辑器窗口，
在该窗口中可以对生成元器件的属性进行查看， 单击 OK 按钮关闭属性编辑器窗
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口。 单击 Windows 窗口右上角的十字交叉符号关闭 Hierarcy. olb 元器件编辑器。
练习 3
以层模块符号形式对振荡器电路进行测试。
1. 以层模块符号形式对 osc125Hz 进行测试。 选择 Hierarchy. dsn， 然后选择

rmb >New Schematic 新建原理图， 并将其命名为 Test Osc125Hz。 默认情况下，
新原理图的名称为 SCHEMATIC1。 选中 SCHEMATIC1 然后选择 rmb > Rename，
将其重命名为 Test Osc125Hz。

2. 选中 Test Osc125Hz， 然后选择 rmb >New Page 建立新页， 采用默认名称

PAGE1， 然后单击 OK 按钮进行确认。 项目管理器窗口如图 20. 29 所示。

图 20. 28　 修改后的 osc125Hz 元件符号 图 20. 29　 项目管理器中的原理图

文件夹排列格式

3. 在 Test Osc125Hz 文件夹中双击 PAGE1， 然后绘制如图 20. 30 所示的电

路。 其中 osc125Hz 选自 Hierarchy 库文件， V1 设置为 12V， V2 设置为 - 12V。

图 20. 30　 层模块器件 osc125Hz 的测试电路

4. 建立名称为 transient 的仿真设置文件， 对电路进行瞬态仿真分析， 仿真
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时间为 200ms。
5. 尝试在 out1 网络节点放置电压探针。 将会出现如图 20. 31 所示的提示信息。

图 20. 31　 层信息

　 　 注意：
Test Osc125Hz 应 该 位 于 顶 层， 即 根 目 录 原 理 图 中。 可 以 在 Osc125Hz

oscillator原理图中进行仿真， 而不要在 Test Osc125Hz 原理图中仿真， 因为 Test
Osc125Hz 没有位于该层中。 比较合理的方法是从底层逐层向上对各级原理图进

行仿真。

图 20. 32　 设置 Test Osc125Hz 为
根目录原理图

　 　 6. 在项目管理器中选中 Test Osc125Hz 文

件夹然后选择 rmb > Make Root， 将其设置为

根目录文件夹。 此时将会出现另外一条提示信

息： 设计项目必须首先被保存。
7. 对设计项目进行保存， 在项目管理器中

选中 Test Osc125Hz 文件夹然后选择 rmb >
Make Root。 如 图 20. 32 所 示， 此 时， Test
Osc125Hz 文件放置于层顶部， 并且在黄色文件

夹上面出现斜杠符号。 如果没有看到以上现象

出现， 对供电电源进行检查， 并且确保电容 C1 进行了初始值设置。
8. 放置电压探针之前必须另外新建一个仿真设置文件。
9. 运行电路仿真。 振荡器输出电压波形如图 20. 33 所示。

图 20. 33　 osc125Hz 的输出波形
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练习 4
在 osc125Hz 电路中建立子参数， 该子参数将出现在层模块符号中， 利用该

参数对元器件数值进行输入， 然后把该数值传递到原理图中。
1. 按照如图 20. 34 所示修改 osc125Hz 电路。 子参数元器件选自 special 元器

件库。

图 20. 34　 设置 R2 为层电路参数

2. 双击 subparam 子参数元器件打开其属性编辑器， 添加新行 （或列）， 子

参数名称 RVAL， 默认值为 160k。 如图 20. 35 所示， 选择 RVAL 然后 rmb > Dis⁃
play 对其显示进行设置。 如图 20. 36 所示， 在 Display Properties 显示属性窗口中

选择 Name and Value， 对子参数的名称和参数值进行显示。

图 20. 35　 将子参数 RVAL 的属性值设置为 160k

3. 如图 20. 34 所示， 在原理图中输入@ RVAL 替换 R2 的参数值。
4. 保存原理图。
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5. 按照练习 2 的具体操作步骤生成新的 osc125Hz 器件， 并在元器件编辑器

中对其引脚进行修改。

图 20. 36　 显示子参数 RVAL 的名称和参数值

　 　 注意：
原理图中仍然包含旧的 osc125Hz 器件， 需要将其删除并且利用新建元器件

对其进行替换。 另外， 可以利用 Design Cache 对元器件进行更新。 Design Cache
实际上是一个元器件库， 包含原理图中的所有元器件。 虽然原理图中将某个元

器件删除， 但是 Design Cache 中仍然保存着该元器件， 除非利用 Clean up Cache
功能对其进行清空。 设计人员可以利用 Design Cache 对元器件进行升级和替换。
从 16. 6 版本开始， Replale Cache 可以应用于多个元器件。 通过按下 Ctrl 键或

Shift 键可以选择多个元器件。
6. 如图 20. 37 所示， 在项目管理器中展开 Design Cache， 然后选择 osc125Hz

器件。

图 20. 37　 利用 Design Cache 对原理图中的每个元器件进行显示
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7. 选择 rmb >Update Cache。 单击 YES 按钮对缓存进行更新， 然后在询问

对话框中单击 OK 按钮对设计进行保存。
8. 如图 20. 38 所示， Test Osc125Hz 原理图应已包含新的 osc125Hz 器件。

图 20. 38　 包含改进后的 osc125Hz 器件的测试电路

9. 把 RVAL 的参数值修改为 100k， 对电路重新运行仿真。 如图 20. 39 所示，
在屏幕图形显示窗口中将会看到振荡器的振荡周期发生了变化。

图 20. 39　 参数 RVAL 设置为 100k 时的振荡波形

练习 5
Digital Counter 仿真项目采用层方式进行设计， 该仿真项目也将在第 22 章测

试平台中使用。
图 20. 40 为层设计仿真项目， 该项目把第 19 章的 555 时钟振荡器电路和第

18 章的模量 3 型同步计数器电路组合到一起进行仿真分析。
图 20. 41 和图 20. 42 分别为改进后的时钟电路和计数器电路。
1. 建立名称为 Digital Counter 的新仿真项目， 并且把原理图 SCHEMATIC1 重

新命名为 Digital Counter。
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图 20. 40　 数字计数器的层设计

图 20. 41　 时钟振荡器电路

图 20. 42　 模量 3 型计数器

2. 打开第 19 章练习 2 的仿真项目 Clock Oscillator。
3. 将两个项目管理器并排放置。 从 Clock Oscillator 项目管理器中复制 clock

原理图文件夹， 然后把该文件夹粘贴至 Digital Counter 项目管理器中。 选中 clock
原理图文件夹， 然后同时按 Ctrl 和 C 对文件夹进行复制。 选中 Digital Count⁃
er. dsn， 然后同时按 Ctrl 和 V 将 clock 原理图文件夹进行粘贴。 复制粘贴完成之

后关闭 Clock Oscillator 仿真项目。 如果还未将 Clock Oscillator 仿真项目中的原理
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图 SCHEMATIC1 重命名为 clock， 选择 rmb > Rename 对其进行重命名。 最后关

闭 Clock Oscillator 仿真项目。
4. 打开第 18 章练习 1 的 Mod 3 Counter 仿真项目， 按照第 3 步的具体操作，

将 counter 原理图文件夹复制、 粘贴至 Digital Counter 项目管理器中。 设置完成之

后关闭 Mod 3 Counter 仿真项目。 此时项目管理器如图 20. 43 所示。

图 20. 43　 将 Clock 和 counter 原理图添加至 Digital counter 仿真项目

如图 20. 40 和图 20. 41 所示， 建立层设计项目， 在顶层原理图中放置 2 个层

模块， 分别对应 clock 和 counter 电路。 然后分别对 clock 和 counter 电路设置层端

口， 当生成层模块的时候， 其引脚将自动进行添加。
5. 打开 clock 原理图， 删除 9V 电压源 V1 及其相连接的 0V 接地符号。 删除

与 555 芯片的 3 引脚相连接的负载电阻和网络名称 out （如果已经添加）。
6. 选择 Place > Hierarchical Port 添加层端口。 如图 20. 44 所示， 选择 POR⁃

TRIGHT - L 并将其命名为 clk。 单击 OK 按钮将该端口添加至时钟电路的输出节

点。 然后在 VCC 节点放置名称为 VCC 的层端口。 根据设计习惯和电路原理选择

层端口的输入、 输出形式。 设置完成之后电路如图 20. 41 所示。
7. 双击 clk 端口打开属性编辑器。 如图 20. 45 所示， 在 Type 属性对话框中

单击下拉菜单选择端口输出类型为 Output， 然后关闭属性编辑器。 VCC 端口的

默认类型为 input。 设置完成之后保存并且关闭原理图。

　 　 注意：
通常情况下， 层输入端口放置在层模块的左侧， 层输出端口放置在层模块

的右侧。 可以通过双击层模块引脚随时对端口类型进行改变。
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图 20. 44　 添加层端口， 并命名为 clk

图 20. 45　 层端口类型

　 　 8. 打开 counter 原理图， 删除数字时钟信号源。 如图 20. 42 所示， 分别在

clk、 QA 和 QB 导线上放置层端口。 按照第 7 步的具体操作， 将 QA 和 QB 层端口

类型设置为 output。 保存并且关闭原理图。
9. 打开顶层的 Digital Counter 原理图。 选择菜单 Place > Hierarchical Block

在原理图中放置层模块， 然后按照如图 20. 46 所示对其进行设置， 并且保持 Path
and filename 空白。 单击 OK 按钮进行确定， 然后在原理图中绘制矩形方框。 层

模块的 VCC 和 clk 引脚如图 20. 40 所示。 如果层模块中未出现引脚， 双击层模块

打开属性编辑器， 检查 Implementation 名称是否确实为 clock。

　 　 注意：
如果忘记在 clock 原理图中添加 VCC 端口， 首先添加端口， 然后选择 rmb >

Ascend Hierarchy 返回顶层原理图。 选中 clock 层模块， 然后选择 rmb >Synchro⁃
nize Up， VCC 端口将以层引脚的形式添加到层模块中。
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图 20. 46　 建立层模块

　 　 10. 如图 20. 47 所示， 按照第 9 步的具体步骤绘制另外一个层模块， 并将其

命名为 counter。 单击 OK 按钮对设置进行确定， 然后如图 20. 40 所示在原理图中

对层模块进行放置。
11. 图 20. 40 为设计完成电路。

图 20. 47　 建立 counter 电路的层模块
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磁性元件编辑器

磁性元件编辑器 （MPE） 主要用于开关电源的变压器和电感设计。 尤其对

于单开关和双开关构成的正激变换器， 以及工作于断续工作模式的反激变换器，
利用 MPE 可以完成全部的变压器设计流程。 设计结束时， 利用 MPE 生成变压器

的综合数据， 生产厂家利用该数据进行变压器和电感的设计与制作。 另外， 还可

以利用 MPE 生成电感和变压器的 PSpice 仿真模型。
MPE 还包括商用磁心元件的数据资料， 包括导线类型、 绝缘材料、 绕制形

式和磁心结构。 可以根据生成的数据资料建立自己的磁性元件。

21. 1　 设计周期

设计周期由一系列的设计步骤构成。 下面以反激变换器拓扑结构为例讲解

DC - DC 直流变换器的具体设计步骤。
设计指标：
·最小直流输入电压： 50V
·直流输出电压 12V， 纹波峰峰值小于 100mV
·直流输出电流 0. 5A， 纹波峰峰值小于 5mA
·开关频率： 40kHz
·效率： 75%
·最大占空比： 45%
通过 PSpice 附属菜单启动 MPE 磁性元件编辑器。

21. 2　 本章练习

练习 1
从开始菜单启动 MPE。 选择 Start > All Programs > Cadence （OrCAD） <
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release number > PSpice Accessories >Magnetic Parts Editor， 打开磁性元件编辑

器。
第 1 步： 拓扑结构选择

如图 21. 1 所示， MPE 设计的第一步为选择拓扑结构， 本设计实例选择的拓

扑结构为断续工作模式的反激变换器。 选择菜单 File > New 将会出现如图 21. 1
所示的拓扑结构选择窗口。

图 21. 1　 拓扑结构选择

在图 21. 1 中， 窗口左侧为已完成的设计步骤， 通过对其查看， 可以确定此

时处于设计周期的哪一步。 设计人员可以随时单击已设计步骤， 以便对输入参数

进行回查。 窗口右侧为可供选择的设计拓扑结构。 本实例选择菜单中的 Flyback
Converter， 即反激变换器， 然后单击 NEXT >>进行下一步设计。

第 2 步： 通用信息设置

如图 21. 2 所示， MPE 设计的第 2 步为输入变压器的规格参数。 本设计实例

只有一个二次绕组， 在这种情况下， 绝缘材料采用电流密度为 3A / mm2 的尼龙。
根据设计指标， 效率设定为 75% 。

在 MPE 中最多可以设计 9 组二次绕组， 但是如果拓扑结构为正激变换器，
则只允许设计一组二次绕组。 变压器的默认绝缘材料为尼龙， 也可以根据设计需

求进行选择。 如图 21. 3 所示， PSpice 提供多种类型的绝缘材料。
如图 21. 4 所示， 选择菜单 Tools > Data Entry > Insulation 打开 Enter insula⁃
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图 21. 2　 变压器设计参数

图 21. 3　 可用绝缘材料列表

tion material 绝缘材料数据输入窗口， 然后输入指定的绝缘材料数据。
如图 21. 2 所示， 在变压器参数窗口中输入绝缘材料的设计参数， 然后单击

Next >>进行下一步设计。
第 3 步： 电气参数设置

图 21. 5 为电气设计参数输入窗口。
在设计参数输入窗口中， 变压器的二次电压和二次电流为方均根值

（RMS）。 隔离电压为一次和二次绕组之间的间隙或距离。 按照如图 21. 5 所示的

输入电气参数， 然后单击 Next >>进行下一步设计。
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第 4 步： 磁心选择

变压器磁心的选择由其形状和材料决定。 如图 21. 6 所示为磁心的物理外形，
您选择其他形状时图会更新， 如环形、 EE 或 UU。

图 21. 4　 输入新绝缘材料数据

图 21. 5　 变压器的电气参数设置

更改供应商名称为 Ferroxcube， 然后从 Family Name 下拉菜单中选择环形或
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图 21. 6　 磁心规格

者 UU 型磁心， 并对磁心的相应几何数据进行查看。
把 Family Name 重新修改回 EE。
如图 21. 7 所示， 选择菜单 Tools > Data Entry > Core Details > Core 输入其

他生产厂商的磁心数据。

图 21. 7　 建立磁心模型

如图 21. 8 所示， 也可以通过选择菜单 Tools > Data Entry > Core Details >
Material 输入磁心材质数据。

首先确定制造商的磁心材料， 然后利用 MPE 根据所选磁心材质提取磁心模

型。 通过计算， MPE 将会确定线圈绕组是否与所选磁心相匹配。
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MPE 磁心数据包括磁心的工作范围。 在本设计中， 采用 3C81 材料的铁氧体

EE 型低功率 （10W） 磁心， 并以该磁心为起点进行变压器的设计。 该磁心工作

于开关频率 67kHz， 最大输出电压为 12V。
首先把磁心的供应商设置为 Ferroxcube。

图 21. 8　 建立磁心材质

设置 Family Name 为 EE。
设置 Material 为 3C81。
单击 Propose Part。
根据输入数据， MPE 将自动提供一个适合的供应商的磁心型号， 并显示该

磁心的各种物理外形数据。 Vendor Part 供应商元件下拉菜单中还包含合适的磁心

模型列表， 这些磁心特性与输入数据相匹配。 如图 21. 9 和图 21. 10 所示， 本实

例选用的磁心型号为 E13 6 6。
磁心选择确定后， 单击 Next >>继续进行变压器设置。
第 5 步： 磁心骨架选择

本步骤对磁心的骨架进行选择， 所选骨架不光与磁心相匹配， 还要符合绕线

方式。 在图 21. 10 中， Bobbin Part No. 为 NO NAME， 表明在 MPE 中没有该骨
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图 21. 9　 磁心骨架和绕线特性设置

架数据。 如果未设定磁心的骨架厚度， 则默认厚度为 1mm， 并以该值为基础进行

磁心尺寸的计算。 如图 21. 11 所示， 通过菜单 Tools > Data Entry > Core Details >
Bobbin 可以对骨架数据进行添加和设置。

图 21. 10　 磁心骨架和绕线特性设置

如图 21. 12 所示为磁心供应商提供的骨架尺寸数据。
图 21. 12 为骨架的外形尺寸， 为了能够与所选磁心相匹配， 骨架的外形参数

计算公式为
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图 21. 11　 建立新骨架

图 21. 12　 骨架尺寸

骨架窗口高度 = 磁心窗口高度 - （2 × 骨

架厚度）
骨架窗口宽度 = 磁心窗口宽度 - （1 × 骨

架厚度）
骨架 Lx =磁心 Lx + （2 ×骨架厚度）
骨架 Ly =磁心 Ly + （2 ×骨架厚度）
对于本实例， 因为磁心的尺寸尚未最终

确定， 所以骨架使用默认名称 NO NAME。
图 21. 10 为骨架绕线选择窗口， 从中可以

得到变压器一次绕组和二次绕组的推荐导线

型号。 设计人员也可以根据需求在 AWG 和

SWG 两种不同的导线标准之间进行选择。

　 　 注意：
设计过程中可能会出现如下警告消息： 应该使用 LITZ 绕组代替单一绕组。

在本例中， 按照如图 21. 10 所示的步骤 5 选择单一绕组。

单击 Next >>进行下一步设置。
第 6 步： 设计结果显示

设计结果为如图 21. 13 所示的电子表格。 另外， 选择菜单 View > Steps View
可以对完整的数据表格进行查看。
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图 21. 13　 设计结果

在设计结果的电子表格底部， 出现如图 21. 14 所示的设计状态报告， 该报告

指出设计过程中出现的一个错误， 并且警告消息提示 P0 绕组与磁心不匹配。

图 21. 14　 设计中出现错误， 设计尚未成功

为了解决上述问题， 要么减小二次绕组的导线直径， 要么选择不同的磁心材

质或者更大尺寸的磁心。 也可以减小一次绕组和二次绕组之间的距离 （设计步

骤 3 的电压隔离）。
返回第 4 步： 在 Core selection 磁心选择窗口中选择 3C90 作为材质。
单击 Propose Part。
选择磁心 E19 8 9， 如图 21. 15 所示， 该磁心具有更大的物理尺寸。
单击 Next > > ， 然后对设计结果进行查看。
设计状态报告如图 21. 16 所示， 从报告中可以看出设计成功。 接下来建立与

磁心相匹配的骨架， 需要再次运行计算。
返回磁心选择 （第 4 步）。 如图 21. 17 所示， 选择菜单 Tools > Data Entry >

Core Details > Bobbin 对磁心尺寸进行查看。 选择推荐元件 Ferroxcube、 EE 型磁

心 19 8 9。 在 Bobbin Part No. 骨架型号对话栏中输入 BB01。
如图 21. 15 所示的磁心绕线区域尺寸再次显示在图 21. 17 中。
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图 21. 15　 修改磁心材质和磁心尺寸

图 21. 16　 设计报告显示设计成功

图 21. 17　 磁心绕线区域尺寸

参照图 21. 12 和相关的计算公式， 骨架壁厚设置为 1mm， 则所需骨架的具

体尺寸为

骨架窗口高度 = 11. 38 - 2 = 9. 38mm
骨架窗口宽度 = 4. 79 - 1 = 3. 79mm
骨架 Lx = 4. 75 + 2 = 6. 75mm
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骨架 Ly = 8. 71 + 2 = 10. 71mm
返回第 5 步 （磁心骨架选择）， 然后选择菜单 Tools > Data Entry > Core

Details Bobbin。 在图 21. 18 中将骨架命名为 BB01， 然后输入对应的骨架数据，
设置完成之后选择 Save 进行保存。

图 21. 18　 建立骨架

当对新建骨架进行保存时将会出现一条消息， 提示设计数据已经成功输入至

数据库中， 如下图所示。 单击 OK 按钮进行确定。

继续执行第 6 步， 检查设计状态对话框中是否仍然显示 Success 设计成功。
对设计进行保存， 生成 flyback. mgd 文件。
对设计进行保存的同时也将生成变压器的 PSpice 模型。 本设计实例将生成

flyback. lib 文件。 在 Results Spreadsheet 底部选择 Model View 选项卡对生成的

PSpice 变压器模型进行查看， 如图 21. 19 所示。
反激式拓扑结构的变压器模型采用子电路的形式进行建模， 包括 V IN1、

V IN2、 V OUT11 和 V OUT12 四个端子。 变压器电路如图 21. 20 所示。
当模型视图打开后， 再一次单击 Save 对 PSpice 模型进行保存。
按照第 16 章的设计步骤， 在模型编辑器中利用模型编辑向导生成变压器模
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图 21. 19　 PSpice 磁心模型

图 21. 20　 反激变换器的变压器模型

LIP—一次漏感　 RSp—一次侧串联电阻　 RSs1—二次侧串联电阻　 Np—一次绕组匝数　 Ns—二次绕组匝数

型的 Capture 元件符号， 并且把元件符号与 PSpice 模型进行关联， 以便用于电路

仿真。
练习 2
建立变压器模型

1. 选择开始菜单打开 PSpice 模型编辑器 Start > All Programs > Cadence （or
OrCAD） > PSpice > Simulation Accessories >Model Editor。

2. 在模型编辑器中选择 File > New。
3. 然后选择 File >Model Import Wizard。
4. 按照如图 21. 21 所示配置模型库， 单击 Browse 浏览按钮查找 flyback. lib，

并且保持 Destination Symbol Library 对话框为默认设置， 然后单击 Next > 按钮继

续进行设置。
5. 图 21. 22 为 Associate / Replace Symbol 元件符号关联 /替换窗口， 单击窗口

中的 Associate Symbol 按钮。 首先选择模型 Flyback， 然后单击 Associate Symbol 按
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图 21. 21　 输入 flyback. lib PSpice 模型库文件

钮。
6. 在 Select Matching 选择匹配窗口， 单击图标 ， 然后从软件安装路径

< install path > OrCAD （ or Cadence） > version xx. x > Tools > Capture > li⁃
brary > PSpice > breakout. olb 中选择 breakout. olb 元件符号库文件。

7. 图 21. 23 的左侧列出与 Flyback 引脚数量一致、 模型相匹配的元件符号。
选择如图 21. 23 所示的 XFRM NONLINEAR 变压器元件符号， 然后单击 Next >
按钮继续进行设置。

8. 为模型各端点配置符号引脚。 按照图 21. 24 所示选择引脚， 然后单击

Save Symbol 对元件符号进行保存。 该变压器模型的引脚排列顺序与图 21. 19 中

的子电路模型一致。
9. 从图 21. 25 中可以看到模型名称及其与之相关联的元件符号。
10. 单击 Finish 按钮， 然后在 sch2cap 窗口中单击 NO。 在状态概要窗口中确

认无错误信息出现之后单击 OK 按钮。 此时新建的 Capture 元件及其模型可以正

常使用了。
练习 3
利用图 21. 26 所示电路图对反激变换器进行测试。
1. 绘制如图 21. 26 所示电路。 电压控制开关选自 analog 元器件库， 脉冲电

压源选自 source 元器件库， 二极管选自 diode 元器件库。 在项目管理器中选择库

文件夹， 然后选择 rmb >Add File 对新建的 Flyback. olb 变压器元器件库进行添
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图 21. 22　 PSpice 模型与符号相关联

图 21. 23　 选择匹配的变压器元件符号

加。 Flyback. olb 元器件库将出现在 Place Part 放置元器件菜单中。 按照图 21. 26
所示， 在电路中放置变压器。

2. 必须为仿真项目配置 flyback. lib PSpice 模型库文件， 该模型才能正常使

用。 选择菜单 PSpice > New Simulation Profile 建立 PSpice 仿真设置文件， 对电
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图 21. 24　 配置元件符号引脚

图 21. 25　 与 Flyback 模型相关联的元件符号

路进行瞬态仿真分析设置， 仿真时间为 10ms。 在图 21. 27 中选择 Configuration
Files > Library 对模型库进行配置， 然后通过浏览查找 flyback. lib 模型文件， 最

后单击 Add to Design 按钮将其添加至本设计项目。
3. 选择菜单 PSpice > Markers > Voltage > Differential 在电路中放置差分探

针， 将第一支差分探针放置在 out1 网络节点， 第二支差分探针将自动出现， 将

其放置在 out2 网络节点。 因为反激变换器的输出电压为负值， 所以通常情况下

将差分探针的正极放置在 out2 网络节点。 探针放置完成之后运行电路仿真。
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图 21. 26　 反激变换器电路图

图 21. 27　 在仿真项目中添加 flyback. lib 模型文件

4. 从图 21. 28 中可以看到输出电压大于 12V。 设定最大占空为 45% ， 通过

降低占空比可以减小输出电压。 当占空比为 15% （Ton为 3μs） 时， 输出电压减

小至略高于 12V， 纹波小于 100mV。 从图 21. 29 可以看出， 通过电阻 R1 的电流

刚刚超过 510mA， 纹波电流小于 5mA。
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图 21. 28　 输出电压与设计指标相匹配

图 21. 29　 输出电流与设计指标相匹配
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通常情况下对电路进行仿真分析时， 需要对其添加电压源和负载电阻。 有时

为了仿真能够顺利进行， 甚至会删除电路中的一些元器件。 但是， 一旦电路仿真

顺利完成， 并且电路功能正常， 实际电路设计时需要把添加的元器件删除， 删除

的元器件复原， 以保持电路原状。
在 PSpice16. 5 版本之前， 可以通过对元器件添加 PSpiceOnly 属性， 设置该

元器件只用于仿真分析， 运行其他功能时该元器件将会自动移除， 比如印制电路

板 （PCB）。 从 PSpice16. 5 版本开始， 可以使用 Partial Design Feature 利用测试平

台对元器件的属性进行设置， 以使元器件只用于仿真分析， 而无其他功能。 可以

把不同的仿真项目进行有选择性的分类， 然后利用其他仿真项目的电路组成新的

设计项目。 当新的设计项目是由其他设计项目的电路集合在一起构成时， 利用测

试平台进行设计将会非常实用。 测试平台对构成该设计的每个电路均进行功能测

试， 以保证整体设计顺利工作。
建立测试平台时， 将会在项目管理器底层添加测试平台文件夹， 该文件夹包

含所有的设计原理图。 在测试平台文件夹中， 所有原理图中的全部元器件均显示

为灰色。 通过选择 “activate” 对需要进行仿真的元器件进行激活， 并且根据实

际仿真需求在电路中添加电压源和负载电阻等元器件。 通过主原理图设计和建立

的测试平台都可以对元器件进行取消和选定。
当建立测试平台时， 项目文件夹中还将建立另外一个设计文件夹。 这样项目

文件夹就包含两个文件夹：
<project name > -PSpiceFiles

<project name > -TBFiles

原理图实用程序 （SVS） 将测试平台设计与主设计进行对比， 然后利用改进

的元器件参数对主设计进行更新。
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22. 1　 测试平台元器件选择

如上所述， 项目管理器中包括两个设计文件夹： 主设计文件夹和测试平台设

计文件夹。 只要以上任何一个文件夹打开， 均可以对仿真元器件进行选择， 但是

最终只对测试平台设计文件夹进行仿真。 例如， 图 22. 1 为数字计数器的层设计

电路， 该设计由时钟振荡器模块和模量 3 型计数器模块组成。

图 22. 1　 数字计数器的层电路设计

以上两个模块分别通过 Test Clock 和 Test Counter 测试平台进行测试。 最

图 22. 2　 主设计包括两个测试平台

初， 原理图中所有元器件的颜色均为灰色。
从主设计中选择菜单 Tools > Test Bench >
Create Test Bench 建立测试平台并对其进行

命名， 然后把测试平台添加到主设计项目管

理器中。 同一个项目管理器中可以建立多个

仿真测试平台， 但是只能有一个测试平台处

于激活状态， 处于激活状态的测试平台的名

称前面以字母 A 进行标记。 在主设计中选定

元器件， 然后选择 rmb > Add Part （ s） To
Active Test bench 将其添加到激活状态的测

试平台中。 在图 22. 2 中， 测试平台 Test
Counter 处于激活状态。

在主设计中通过项目管理器， 利用层选项卡对元器件进行选择和取消， 图

22. 3 为主设计项目管理器中的层选项卡。 在本实例中， 只有在 Clock 层模块中的

元器件才被选中， 其他元器件均为灰色。
同样的， 也可以在测试平台中对元器件进行添加和删除。 在上述实例中， 打开

Test Clock / Test Bench > clock 原理图， 选择元器件， 然后选择 rmb > Test Bench
>Add Part （s） To Self 或者 Remove Part （s） From Self 对元器件进行添加和删除，
如图 22. 4 所示， 其中， Self 对应激活状态的测试平台 Test Clock / Test Bench。
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图 22. 3　 通过主设计对各层元器件进行选择

图 22. 4　 添加或者删除测试平台元器件

22. 2　 未连接的浮动网络

在设计原理图中对元器件进行添加和删除时会出现未连接导线， 从而产生浮

图 22. 5　 搜索浮动的网络节点

动节点错误。 如第 2 章所述，
所有节点必须具有对地直流

回路。 可以利用 Text to Search
Box 对浮动节点进行搜索， 图

22. 5 为搜索选项列表， 其中

之一为浮动节点网络。
对电路进行仿真时， 浮

动节点问题一定要解决， 否

则仿真不能顺利进行。 有时

解决办法很简单， 只要在浮

动节点对地之间连接一个电

阻， 用来提供对地直流通路

即可。
如图 22. 6 所示， 在 16. 6

版本中增加了 Regular Ex⁃
pressions 和 Property Name =
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Value 两项高级搜索功能。
Property Name = Value 需要完整的属性名称， 而对于 Value 可以使用通配符

“∗” 和字符 “？” 进行标记。 例如， 在 Digital Counter 设计项目中查找所有的 ICs，
如图 22. 7 所示选择 Property Name = Value。 然后输入 Part Reference = U∗，

。 如果只对 74 系列数字芯片中 76JK 触发器集成电路进行

更具体的搜索， 而忽略其采用的技术工艺， 即 LS、 HC、 AC 等， 可以输入 Value

= 74？？ 76， 。 Regular Expressions 为字符串条件搜索提供

了更多的灵活性， 即可以指定一个范围值， 或者可以有选择性地使用 “与” 或

者 “或” （I） 功能。 例如， 如果想要在 Digital Counter 设计项目中查找第一个电

阻 R1、 R2 或者第一个电容 C1、 C2， 可以输入 Part Reference = （C | R） [1 -
2]。 注 意 Regular Expressions 和 Property Name = Value 都 要 被 选 定。

搜索结果为 R1、 C1、 C2 和 IC1， 如图 22. 8 所示为符合搜

索条件的一部分元器件。

图 22. 6　 新增搜索功能 图 22. 7　 选择 Property Name = Value

图 22. 8　 Regular Expression 搜索结果

22. 3　 比较和更新主设计与测试平台设计之间的差异

SVS 对主设计和测试平台设计之间的差别进行对照显示， 并用颜色对设计差

别进行标注： 红色代表元器件缺失、 黄色代表元器件不匹配、 白色代表元器件匹

配。 在图 22. 9 中， 测试平台设计显示在左手侧， 主设计显示在右手侧。 从图

22. 9 中可以看出， 测试平台设计中的时钟原理图包含一个额外的电容 C3， 由红
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色进行显示。 另外电阻 R4 的参数值也不相同。

通过选择 Accept Left 图标， 将测试平台设计中修改的元器件参数值对主

设计进行更新。 然而， 仅仅只能对主设计的元器件参数值进行更新， 对于元器件

的其他操作则无能为力。 在上例中， 如果选定左侧面板中 R4 的参数框， 则电阻

R4 修改后的参数值将在测试平台对主设计进行更新。 但是额外电容 C3 不能在主

设计中进行更新。 另外， 主设计不能对删除的元器件进行更新， 所以如果测试平

台中删除了某个元器件， 则该元器件仍然在主设计中， 不能自动进行删除。

图 22. 9　 测试平台设计与主设计对比

22. 4　 本章练习

练习 1
图 22. 10 为第 20 章练习 5 的数字计数器的层设计电路。
下面通过建立 Test Clock 测试平台， 仅对振荡器电路进行仿真和性能验证。

首先在主设计管理器的层选项卡中选中元器件， 然后在主设计项目中对激活状态

的测试平台添加时钟模块。

图 22. 10　 数字计数器的层设计电路

1. 首先选择 Counter. dsn 设计项目， 然后从顶部工具栏中选择 Tools > Test
Bench > Create Test Bench 建立测试平台。 如图 22. 11 所示， 将测试平台命名为

Test Clock。 单击 OK 按钮进行确定， 如果系统提示是否保存， 再次单击 OK 按

钮对设计项目进行保存。
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图 22. 11　 建立 Test Clock 测试平台

图 22. 12　 Test Clock 测试平台

如图 22. 12 所示， Test Clock 测试平台位

于项目管理器的底部， 保存在 TestBenches 文件

夹中。
2. 在 TestBenches 文件夹中， 双击 Digital

Counter / Test Clock 打开 Test Clock. dsn 设计

项目。
3. 在 Test Clock 项目管理器中， 双击

Test Clock. dsn， 然后打开 counter Page1 原理

图， 将会看到所有元器件均为灰色。 关闭原

理图。
4. 在 Test Clock 项目管理器中打开 clock

原理图， 将会看到所有元器件均为灰色。 从主

图 22. 13　 选择项目管理器

设计中进入 Test Clock 测试平台， 然

后将 clock 元器件激活。
5. 选择主设计项目管理器： 从图

22. 13 中选择 Digital Counter tab 选项卡，

图 22. 14　 选择 clock 振荡器电路

或者选择菜单 Window > Digital Counter。 将

主设计与测试平台并排放置将会更加便于

操作。
6. 在主设计 （Digital Counter） 项目管理

器中单击 Hierarchy 层选项卡， 对层设计电路

进行显示。 如果 Digital Counter 和 clock 原理

图尚未展开， 首先将其展开， 然后对图 22. 14
中显示的 clock 电路的所有元器件进行检验。
最后单击 File 选项卡。

7. 在 TestBenches 文件夹中， 通过双击

Digital Counter / Test Clock 测试平台激活其项

目管理器， 然后打开 clock 原理图并检查所有
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元器件是否均为激活状态 （非灰色）。 然后关闭原理图并且进行保存。
8. 在 Test Clock 项目管理器中打开 Digital Counter 原理图， 如图 22. 15

所示。

图 22. 15　 Test Clock > Digital Counter 原理图

电压源 V1 仍然显示为灰色。 绘制方框选择 V1、 连接导线和 0V 接地符号，
然后如图 22. 16 所示选择 rmb > TestBench > Add Part （s） To Self。

图 22. 16　 将电压源 V1 添加至激活状态的测试平台中

图 22. 17　 搜索浮动网络节点

现在， 只有时钟振荡电路

处于激活状态， 在 Test Clock
测试平台中对未连接网络进行

搜索。 确保搜索菜单处于显示

状态： 选择菜单 View > Tool⁃
bar > Search 进行显示设置。

9. 选中 Test Clock. dsn，
搜索图标 与 Search Box 搜

索栏紧邻 （见图 22. 17）， 然

后从 顶 部 工 具 栏 搜 索 图 标

右边的下拉菜单中进行

选择。
10. 单 击 DeselectAll。 首

先选择 Floating Nets 浮动节点，
然后单击搜索图标 。 如图

22. 18 所示， Find 查找窗口位于屏幕底部， 原理图下方。
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图 22. 18　 浮动网络节点报告

　 　 注意：
如果浮动网络节点报告中指出 0V 网络节点浮动， 则主要因为电源 V1 与

0V 符号之间未连接导线。 选择 0V 符号， 然后对其进行拖拽， 将会出现细长连

接导线， 再次运行网络浮动节点搜索， 将会仅有 clk 网络节点浮动。

11. 如图 22. 19 所示， 在 clk 网络节点与地之间放置 1k 电阻， 为 clk 网络节

点提供对地直流通路。

图 22. 19　 在 clk 网络节点与 0V 符号之间添加 1k 电阻

12. 建立瞬态分析仿真设置文件， 运行时间设置为 20ms。 设置完成后不要退

出仿真设置文件。 在设置窗口中选择Options tab >Gate - level Simulation， 将所

有触发器的初始值设置为 0。
13. 在 clk 网络节点放置电压探针， 运行电路仿真。
14. 时钟电路输出波形如图 22. 20 所示， 时钟频率为 216Hz。
15. 双击 clock 层模块打开原理图， 然后与 C1 并联放置另外一个 220nF 电

容。 将图 20. 41 所示电路中的电阻 R4 的参数值修改为 6k8， 重新运行电路仿真，
此时时钟频率改变为 138Hz。 关闭 clock 原理图并保存。 现在对计数器电路进行

功能验证， 但是首先需要从激活状态的测试平台中选择激活元器件。 将计数器电

路中的元器件添加至激活状态的测试平台中， 并将时钟电路中的元器件从该平台

删除。
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图 22. 20　 时钟电路输出波形

16. 打开项目管理器， 选择 Digital Counter （主设计）。
17. 选中 Digital Counter. dsn， 然后选择菜单 Tools > Test Bench > Create Test

Bench 建立测试平台。 在图 22. 21 中输入测试平台名称 Test Counter。

图 22. 21　 建立 Test Counter 测试平台

18. 如图 22. 22 所示， 在主设计 counter 中有两个测试平台。 字母 A 出现在

Test Counter 测试平台名称前面， 表明该测试平台处于激活状态。 通过选择

rmb >Make Active 可以对测试平台的激活状态进行设置。

图 22. 22　 激活状态的 Test Counter 测试平台

19. 双击 Test Counter 测试平台， 打开 Test Counter 设计项目管理器。
20. 双击 Test Counter. dsn， 打开 Digital Counter 原理图 Page1。
21. 绘制方框选择 clock 层模块、 电压源 V1 和 0V 接地符号， 然后选择

rmb >Remove Part （s） From Self 对所选电路及元器件从测试平台移除， 如图
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22. 23 所示。

图 22. 23　 从激活状态的 Test Counter 测试平台中移除时钟电路及其相关元器件

22. 绘制方框选择层模块 counter， 并且确保 clk、 QA 和 QB 网络节点也被同

时选中。 然后如图 22. 24 所示选择 rmb > TestBench > Add Part （s） To Self， 将

所选电路和元器件添加至测试平台。

图 22. 24　 将 counter 层模块及其元器件添加至 Test Counter 测试平台

23. 重复步骤 17， 对浮动网络节点进行检测。 检测报告中应该警告节点 QA
和 QB 浮动。 因为 QA 和 QB 为数字输出节点， 不需要直流接地回路， 因此忽略

以上警告信息。
24. 从 source 元器件库中选择 DigClock 数字时钟信号源， 并将其放置到原理

图中， 然后按照图 22. 25 所示对其进行参数设置。

图 22. 25　 对计数器电路进行测试

25. 建立瞬态分析仿真设置文件， 运行时间设置为 20ms。 设置完成后不要退

出仿真设置文件。 在设置窗口中选择Options tab >Gate - level Simulation， 将所

有触发器的初始值设置为 0。
26. 在 QA 和 QB 网络节点放置电压探针， 运行电路仿真。 电路输出波形如

图 22. 26 所示

练习 2
测试平台仿真验证完成之后， 主设计和测试平台设计之间的任何差异， 元器
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图 22. 26　 计数器电路输出波形

件的添加、 移除和参数修改均被标注出来。
1. 如图 22. 27 所示， 在主设计中选中 Digital Counter. dsn， 然后选择 Tools >

Test - Bench > Diff and Merge。

图 22. 27　 对比主设计与测试平台设计之间的差异

2. 在 SVS 窗口中， 测试平台设计在左侧面板， 主设计在右侧面板。 左边面

板中的 / Clk 展开如图 22. 28 所示。

图 22. 28　 主设计与 Test Clock 测试平台之间的差异显示

黄色表示 Test Clock 测试平台与主设计之间存在差异， 需要将改进参数对

主设计进行更新。 在时钟电路中额外电容 C3 被标注为红色， 在主设计中显示

NOT PRESENT， 表示该元器件不存在。

　 　 注意：
在进行差异检测之前必须保存并且关闭测试平台。

3. 展开 / CLK / R4， 会看到 Test Clock 测试平台和主设计， 如图 22. 29 所

示。 可以决定是否接受 R4 的值。 对于 R4 的修改后的值将被更新到主设计。 偏
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压值功率为测量值， 对这项工作不是非常重要。

图 22. 29　 检测到电阻 R4 的参数值进行过修改

4. 单击 Accept Left 图标 ， 将 R4 的新参数值对主设计进行更新， 如图

22. 30 所示， 在 SVS 窗口中不再显示电阻 R4 在主设计和测试平台设计之间存在

差异。

图 22. 30　 不再检测到电阻 R4 的差异

如果试图增加额外电容 C3 对主设计进行更新， 在仿真记录中将显示如下警

告信息：
WARNING（ORCAP - 37003）： Could not add object ’/Clk/C3’ at

the target design， as this operation is not supported

5. 关闭 SVS 窗口， 打开 Test Clock 测试平台设计。
6. 打开 clock 原理图。
7. 删除电容 C3， 修改电容 C1 的值为 470n。
8. 保存并且关闭 clock 原理图。
9. 打开主设计项目管理器， 选中 Digital Counter. dsn 设计项目。 选择菜单

Tools > Test Bench > Diff and Merge， 检查主设计与测试平台设计之间的差异。
10. 从 SVS 窗口可以看到两设计之间仅存在参数值差异， 并用黄色进行标

注。 在图 22. 31 中对 / Digital Counter 右侧的方框进行选定， 然后单击 Accept Left
图标 对主设计进行更新。

11. 图 22. 32 所示的消息窗口将会出现， 用来提示两设计之间不存在差异。
图 22. 33 为 SVS 窗口， 里面没有任何输入信息。
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图 22. 31　 选择测试平台中的元器件参数进行更新

图 22. 32　 无设计差异

图 22. 33　 清除 SVS 窗口内容

　 　 注意：
按照选择电阻 R4 的参数值的步骤对电容 C1 的参数值进行选择， 但是如果

需要对大量的元器件参数值进行更新时， 可以通过对整个测试平台进行更新以

实现元器件参数值的更新。 当选定整个测试平台时， 在仿真记录中将会出现如

下警告信息：
WARNING（ORCAP -37003）： Could not add object ’/Clk/R1’ at

the target design， as this operation is not supported

可以直接忽略上述警告信息， 继续对设计项目进行更新。



附录

测量函数定义

测量函数 注释

Bandwidth 　 波形的带宽 （需要选择 dB ）

Bandwidth Bandpass 3dB 　 波形的 3dB 带宽

Bandwidth Bandpass 3dB XRange 　 在指定的 X 轴范围内波形的 3dB 带宽

CenterFrequency 　 波形的中心频率 （需要选择 dB）

CenterFrequency XRange 　 在指定的 X 轴范围内波形的中心频率 （需要选择 dB）

ConversionGain 　 第一个波形与第二个波形最大值的比

ConversionGain XRange 　 在指定的 X 轴范围内第一个波形与第二个波形最大值的比

Cutoff Highpass 3dB 　 高通滤波器的 3dB 带宽

Cutoff Highpass 3dB XRange 　 指定 X 轴范围内高通滤波器的 3dB 带宽

Cutoff Lowpass 3dB 　 低通滤波器的 3dB 带宽

Cutoff Lowpass 3dB XRange 　 指定 X 轴范围内低通滤波器的 3dB 带宽

DutyCycle 　 第一个脉冲周期的占空比

DutyCycle XRange 　 指定 X 轴范围内第一个脉冲周期的占空比

Falltime NoOvershoot 　 无过冲的下降时间

Falltime StepResponse 　 阶跃响应曲线负向下降时间

Falltime StepResponse XRange 　 指定 X 轴范围内阶跃响应曲线负向下降时间

GainMargin 　 相位为 180°时的增益值 （dB）

Max 　 波形的最大值

Max XRange 　 指定 X 轴范围内的波形最大值

Min 　 波形最小值

Min XRange 　 指定 X 轴范围内的波形最小值

NthPeak 　 第 N 个波峰的值

Overshoot 　 阶跃响应曲线的过冲
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测量函数 注释

Overshoot XRange 　 指定 X 轴范围内阶跃响应曲线的过冲

Peak 　 第 N 个波峰的值

Period 　 时域信号的时间周期

Period XRange 　 在指定 X 轴范围内时域信号的时间周期

PhaseMargin 　 相位裕度

PowerDissipation mW 　 在时间周期内的功耗 （mW）

Pulsewidth 　 第一个脉冲的宽度

Pulsewidth XRange 　 指定 X 轴范围内的第一个脉冲宽度

Q Bandpass 　 计算指定 dB 值频率响应的 Q 值

Q Bandpass XRange 　 在指定的 X 轴范围内计算指定 dB 值频率响应的 Q 值

Risetime NoOvershoot 　 无过冲阶跃响应曲线的上升时间

Risetime StepResponse 　 阶跃响应曲线的上升时间

Risetime StepResponse XRange 　 在指定 X 轴范围内阶跃响应曲线的上升时间

SettlingTime 　 给定带宽， 从 < 指定 X > 到一个阶跃响应完成所需的时间

SettlingTime XRange
　 给定带宽， 给定范围， 从 < 指定 X > 到一个阶跃响应完成所

需的时间

SlewRate Fall 　 曲线的负向摆率

SlewRate Fall XRange 　 指定 X 范围的曲线的负向摆率

SlewRate Rise 　 曲线的正向摆率

SlewRate Rise XRange 　 指定 X 范围的曲线的正向摆率

Swing XRange 　 指定范围内的波形的最大值与最小值的差

XatNthY 　 对于指定的波形， 相对于第 N 个 Y 值的 X 值

XatNthY NegativeSlope 　 对于指定的波形， 沿负斜率方向第 N 个 Y 值对应的 X 值

XatNthY PercentYRange 　 第 N 个 Y 值范围百分比处的 X 值

XatNthY Positive Slope 　 对于指定的波形， 沿正斜率方向第 N 个 Y 值对应的 X 值

YatFirstX 　 X 范围起始处的波形值

YatLastX 　 X 范围结束处的波形值

YatX 　 给定 X 值处的波形值

YatX PercentXRange 　 在 X 范围给定百分比处的波形值

ZeroCross 　 Y 值第一个过 0 点处的 X 值

ZeroCross XRange 　 在指定范围内， Y 值第一个过 0 点处的 X 值
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